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Prologue
Welcome

Welcome to Geing Started with Ubuntu, an introductory guide wrien to
help new users get started with Ubuntu.
Our goal is to cover the basics of Ubuntu (such as installation and working with the desktop) as well as hardware and soware management, working with the command line, and security. We designed this guide to be
simple to follow, with step-by-step instructions and plenty of screenshots,
allowing you to discover the potential of your new Ubuntu system.
Please bear in mind that this guide is still very much a work in progress
and always will be. It is wrien speciﬁcally for Ubuntu . , and
although we have aimed to not limit our instructions to this version,
it is unavoidable that some things will change over the life of Ubuntu.
Whenever a new version of Ubuntu is released, we will incorporate updates and changes into our guide, and make a new version available at
http://www.ubuntu-manual.org.
Geing Started with Ubuntu . is not intended to be a comprehensive
Ubuntu instruction manual. It is more like a quick-start guide that will get
you doing the things you need to do with your computer quickly and easily,
without geing bogged down with technical details. As with prior versions,
Ubuntu .  incorporates many new features, including enhancements
to the Unity shell and . More about the Unity shell and what it means,
and the , can be found in Chapter : e Ubuntu Desktop.
For more detailed information on using Unity and the Ubuntu desktop, see the “Ubuntu Desktop Guide,” which can be obtained in any of the
following ways:

LTS is an abbreviation for “Long Term Support.”
A new LTS version is released every 2 years.
Starting with Ubuntu 12.04 LTS, both the
Desktop version and the Server version will
have ﬁve years support, meaning you get free
security updates for at least ﬁve years.

HUD is an abbreviation for heads-up display.
It is a new concept, integrated into Unity as of
Unity 5.2; it is still in development.

‣ in the Dash, type yelp;
‣ in the desktop menubar, click Help ‣ Ubuntu Help;
‣ go to https://help.ubuntu.com, Ubuntu .  ‣ Ubuntu Desktop
Help.
e Internet is also an excellent resource. For example, on https://help.
ubuntu.com you will ﬁnd documentation on installing and using Ubuntu,
and at the Ubuntu Forums, http://ubuntuforums.org, and Ask Ubuntu,
http://askubuntu.com, you ﬁnd answers to many Ubuntu related questions.
If something isn’t covered in this manual, chances are you will ﬁnd the
information you are looking for in one of those locations. We will try our
best to include links to more detailed help wherever we can.

More information about Ubuntu’s online
and system documentation can be found in
Chapter 8: Learning More.

Ubuntu Philosophy

e term “Ubuntu” is a traditional African concept that originated from
the Bantu languages of southern Africa. It can be described as a way of
connecting with others—living in a global community where your actions
aﬀect all of humanity. Ubuntu is more than just an operating system: it is
a community of people that come together voluntarily to collaborate on
an international soware project that aims to deliver the best possible user
experience.

People sometimes wonder how to pronounce
Ubuntu. Each “u” is pronounced the same as in
the word put.
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The Ubuntu Promise

‣ Ubuntu will always be free of charge, along with its regular enterprise
releases and security updates.
‣ Ubuntu comes with full commercial support from Canonical and hundreds of companies from across the world.
‣ Ubuntu provides the best translations and accessibility features that the
free soware community has to oﬀer.
‣ Ubuntu’s core applications are all free and open source. We want you to
use free and open source soware, improve it, and pass it on.
A brief history of Ubuntu

Ubuntu was conceived in  by Mark Shuleworth, a successful South
African entrepreneur, and his company Canonical. Shuleworth recognized
the power of Linux and open source, but was also aware of weaknesses that
prevented mainstream use.
Shuleworth set out with clear intentions to address these weaknesses
and create a system that was easy to use, completely free (see Chapter :
Learning More for the complete deﬁnition of “free”), and could compete
with other mainstream operating systems. With the Debian system as a
base, Shuleworth began to build Ubuntu. Using his own funds at ﬁrst,
installation s were pressed and shipped worldwide at no cost to the
recipients. Ubuntu spread quickly, its community rapidly grew, and soon
Ubuntu became the most popular Linux distribution available.
With more people working on the project than ever before, its core features and hardware support continue to improve. Ubuntu has gained the
aention of large organizations worldwide. One of IBM’s open source operating systems is based on Ubuntu. In , the French Police began to
transition their entire computer infrastructure to a variant of Ubuntu—a
process which has reportedly saved them “millions of euros” in licensing
fees for Microso Windows. By the end of , the French Police anticipates that all of their computers will be running Ubuntu. Canonical proﬁts
from this arrangement by providing technical support and custom-built
soware.
While large organizations oen ﬁnd it useful to pay for support services,
Shuleworth has promised that the Ubuntu desktop system will always
be free. As of , Ubuntu is installed on an estimated % of the world’s
computers. is equates to tens of millions of users worldwide, and is
growing each year. As there is no compulsory registration, the percentage
of Ubuntu users should be treated as an estimate.
What is Linux?

Ubuntu is built on the foundation of Linux, which is a member of the Unix
family. Unix is one of the oldest types of operating systems and has provided reliability and security in professional applications for almost half a
century. Many servers around the world that store data for popular websites (such as YouTube and Google) run some variant of a Unix system.
e Linux kernel is best described as the core, or almost the brain, of the
operating system.
e Linux kernel is the controller of the operating system; it is responsible for allocating memory and processor time. It can also be thought of as
the program which manages any and all applications on the computer itself.

Canonical is the company that provides ﬁnancial
and technical support for Ubuntu. It has
employees based around the world who work
on developing and improving the operating
system, as well as reviewing work submitted by
volunteer contributors. To learn more about
Canonical, go to http://www.canonical.com.

Debian is the Linux operating system that
Ubuntu is based upon. For more information
visit http://www.debian.org/.

For information on Ubuntu Server Edition, and
how you can use it in your company, visit http://
www.ubuntu.com/business/server/overview.

 

Linux was designed from the ground up with security and hardware
compatibility in mind, and is currently one of the most popular Unix-based
operating systems. One of the beneﬁts of Linux is that it is incredibly ﬂexible and can be conﬁgured to run on almost any device—from the smallest
micro-computers and cellphones to larger super-computers. Unix was entirely command line-based until graphical user interfaces (s) began to
emerge in the early s.
ese early s were diﬃcult to conﬁgure, clunky, and generally only
used by seasoned computer programmers. In the past decade, however,
graphical user interfaces have come a long way in terms of usability, reliability, and appearance. Ubuntu is just one of many diﬀerent Linux distributions, and uses one of the more popular graphical desktop environments
called .

While modern graphical desktop environments
have generally replaced early command-line
interfaces, the command line can still be a
quick and eﬃcient way of performing many
tasks. See Chapter 6: Advanced Topics for
more information, and Chapter 2: The Ubuntu
Desktop to learn more about GNOME and other
desktop environments.

To learn more about Linux distributions, see
Chapter 8: Learning More.

Is Ubuntu right for you?

New users to Ubuntu may ﬁnd that it takes some time to feel comfortable
when trying a new operating system. You will no doubt notice many similarities to both Microso Windows and Mac  , and some diﬀerences.
Users coming from Mac   are more likely to notice similarities due to the
fact that both Mac   and Ubuntu originated from Unix. e Unity shell,
which is the default in Ubuntu, is a completely new concept, which needs
some exploring to get used to it. See Chapter : e Ubuntu Desktop for
more information about the Unity shell.
Before you decide whether or not Ubuntu is right for you, we suggest
giving yourself some time to grow accustomed to the way things are done
in Ubuntu. You should expect to ﬁnd that some things are diﬀerent from
what you are used to. We also suggest taking the following into account:
Ubuntu is community based. at is, Ubuntu is developed, wrien, and
maintained by the community. Because of this, support is probably
not available at your local computer store. Fortunately, the Ubuntu
community is here to help. ere are many articles, guides, and manuals
available, as well as users on various Internet forums and Internet Relay
Chat () rooms that are willing to assist beginners. Additionally, near
the end of this guide, we include a troubleshooting chapter: Chapter :
Troubleshooting.
Many applications designed for Microso Windows or Mac   will not run on Ubuntu.
For the vast majority of everyday computing tasks, you will ﬁnd suitable
alternative applications available in Ubuntu. However, many professional applications (such as the Adobe Creative Suite) are not developed
to work with Ubuntu. If you rely on commercial soware that is not
compatible with Ubuntu, yet still want to give Ubuntu a try, you may
want to consider dual-booting. Alternatively, some applications develTo learn more about dual-booting (running
Ubuntu side-by-side with another operating
oped for Windows will work in Ubuntu with a program called Wine. For
system), see Chapter 1: Installation.
more information on Wine, go to http://www.winehq.org.
Many commercial games will not run on Ubuntu. If you are a heavy gamer,
then Ubuntu may not be for you. Game developers usually design games
for the largest market. Since Ubuntu’s market share is not as substantial
as Microso’s Windows or Apple’s Mac  , most game developers
will not allocate resources towards making their games compatible with
Linux. If you just enjoy a game every now and then, there is active game
See Chapter 5: Software Management to learn
more about Ubuntu Software Center.
development within the community, and many high quality games can
be easily installed through the Ubuntu Soware Center.
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Contact details

Many people have contributed their time to this project. If you notice any
errors or think we have le something out, feel free to contact us. We do
everything we can to make sure that this manual is up to date, informative,
and professional. Our contact details are as follows:
‣
‣
‣
‣

Website: http://www.ubuntu-manual.org/
Email: ubuntu-manual@lists.launchpad.net
: #ubuntu-manual on irc.freenode.net
Bug Reports: https://bugs.launchpad.net/ubuntu-manual/+filebug

About the team

Our project is an open source volunteer eﬀort to create and maintain quality documentation for Ubuntu and its derivatives.
Want to help?

We are always looking for talented people to work with, and due to the size
of the project we are fortunate to be able to cater to a wide range of skill
sets:
‣
‣
‣
‣
‣
‣
‣
‣
‣

Authors, editors
Programmers (Python or TEX)
User interface designers
Icon and title page designers
Event organizers and ideas people
Testers
Web designers and developers
Translators and screenshoers
Bug reporters and triagers

To ﬁnd out how you can get started helping, please visit http://ubuntu-manual.
org/getinvolved.
Conventions used in this book

e following typographic conventions are used in this book:
‣ Buon names, menu items, and other  elements are set in boldfaced
type.
‣ Menu sequences are sometimes typeset as File ‣ Save As…, which means,
“Choose the File menu, then choose the Save As….”
‣ Monospaced type is used for text that you type into the computer, text
that the computer outputs (as in a terminal), and keyboard shortcuts.

1

Installation

Getting Ubuntu

Before you can get started with Ubuntu, you will need to obtain a copy of
the Ubuntu installation image for  or . Some options for doing this are
outlined below.

Many companies (such as Dell and System76)
sell computers with Ubuntu preinstalled. If
you already have Ubuntu installed on your
computer, feel free to skip to Chapter 2: The
Ubuntu Desktop.

Minimum system requirements

Ubuntu runs well on most computer systems. If you are unsure whether it
will work on your computer, the Live  is a great way to test things out
ﬁrst. Below is a list of hardware speciﬁcations that your computer should
meet as a minimum requirement.
‣
‣
‣
‣
‣
‣

The majority of computers in use today will
meet the requirements listed here; however,
refer to your computer documentation or
manufacturer’s website for more information.

 GHz x processor (Pentium  or beer)
  of system memory ()
  of disk space (at least   is recommended)
Video support capable of × resolution
Audio support
An Internet connection (highly recommended, but not required)

Downloading Ubuntu

e easiest and most common method for geing Ubuntu is to download
the Ubuntu  image directly from http://www.ubuntu.com/download.
Choose how you will install Ubuntu:
‣ Download and install
‣ Try it from a  or  stick
‣ Run it with Windows
Download and Install / Try it from a CD or USB stick

For the Download and install, or Try it from a  or  stick options, select
whether you require the -bit or -bit version (-bit is recommended for
most users), then click “Start download.”
Installing and run alongside Windows

For the Run it with Windows option, simply select “Start download,” and
then follow the instructions for the Ubuntu installer for Windows.
32-bit versus 64-bit

Ubuntu and its derivatives are available in two versions: -bit and -bit.
is diﬀerence refers to the way computers process information. Computers capable of running -bit soware are able to process more information
than computers running -bit soware; however, -bit systems require
more memory in order to do this. Nevertheless, these computers gain performance enhancements by running -bit soware.
‣ If your computer has a -bit processor install the -bit version.

32-bit and 64-bit are types of processor
architectures. Most new desktop computers
have a 64-bit capable processor.
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‣ If your computer is older, a netbook, or you do not know the type of
processor in the computer, install the -bit version.
If your computer has a -bit processor, click on the “-bit” option
before you click “Start download.”
Downloading Ubuntu as a torrent

When a new version of Ubuntu is released, the download servers can get
“clogged” as large numbers of people try to download or upgrade Ubuntu
at the same time. If you are familiar with using torrents, you can download
the torrent ﬁle by clicking “Alternative downloads,” and then “BitTorrent
download.” Downloading via torrent may improve your download speed,
and will also be help to spread Ubuntu to other users worldwide.

Torrents are a way of sharing ﬁles and information around the Internet via peer-to-peer ﬁle
sharing. A ﬁle with the .torrent extension is
made available to users, which is then opened
with a compatible program such as uTorrent,
Deluge, or Transmission. These programs
download parts of the ﬁle from other people all
around the world.

Burning the CD image

Once your download is complete, you will be le with a ﬁle called ubuntu.-desktop-i.iso or similar (i here in the ﬁlename refers to the -bit
version. If you downloaded the -bit version, the ﬁlename contains amd
instead). is ﬁle is a  image—a snapshot of the contents of a —which
you will need to burn to a .

While the 64-bit version of Ubuntu is referred
to as the “AMD64” version, it will work on Intel,
AMD, and other compatible 64-bit processors.

Creating a bootable USB drive

If your  is able to boot from a  stick, you may prefer to use a 
memory stick instead of burning a . Scroll down to “Burn your  or
create a  drive,” select  or  stick, choose the  you are using to
create the  drive, and then click Show me how. If you select the “
Stick” option, your installation will be running from the  memory stick.
In this case, references to Live , will refer to the  memory stick.
Trying out Ubuntu

e Ubuntu  and  stick function not only as installation media, but
also allow you to test Ubuntu without making any permanent changes to
your computer by running the entire operating system from the  or 
stick.
Your computer reads information from a  at a much slower speed than
it can read information oﬀ of a hard drive. Running Ubuntu from the Live
 also occupies a large portion of your computer’s memory, which would
usually be available for applications to access when Ubuntu is running from
your hard drive. e Live / experience will therefore feel slightly
slower than it does when Ubuntu is actually installed on your computer.
Running Ubuntu from the / is a great way to test things out and
allows you to try the default applications, browse the Internet, and get a
general feel for the operating system. It’s also useful for checking that your
computer hardware works properly in Ubuntu and that there are no major
compatibility issues.
To try out Ubuntu using the Live / stick, insert the Ubuntu  into
your  drive, or connect the  drive and restart your computer.
Aer your computer ﬁnds the Live / stick, and a quick loading
screen, you will be presented with the “Welcome” screen. Using your

In some cases, your computer will not recognize
that the Ubuntu CD or USB is present as it
starts up and will start your existing operating
system instead. Generally, this means that
the priority given to boot devices when your
computer is starting needs to be changed. For
example, your computer might be set to look
for information from your hard drive, and then
to look for information on a CD or USB. To run
Ubuntu from the Live CD or USB, we want the
computer to look for information from the
appropriate device ﬁrst. Changing your boot
priority is usually handled by BIOS settings; this
is beyond the scope of this guide. If you need
assistance with changing the boot priority, see
your computer manufacturer’s documentation
for more information.

 

mouse, select your language from the list on the le, then click the button labeled Try Ubuntu. Ubuntu will then start up, running directly from
the Live / drive.
Figure 1.1: The “Welcome” screen allows you to
choose your language.

Once Ubuntu is up and running, you will see the default desktop. We
will talk more about how to actually use Ubuntu in Chapter : e Ubuntu
Desktop, but for now, feel free to test things out. Open some applications,
change seings and generally explore—any changes you make will not be
saved once you exit, so you don’t need to worry about accidentally breaking
anything.
When you are ﬁnished exploring, restart your computer by clicking the
“Power” buon in the top right corner of your screen (a circle with a line
through the top) and then select Restart. Follow the prompts that appear on
screen, including removing the Live  and pressing Enter when instructed,
and then your computer will restart. As long as the Live  is no longer in
the drive, your computer will return to its original state as though nothing
ever happened!

Alternatively, you can also use your mouse to
double-click the “Install Ubuntu 12.04” icon that
is visible on the desktop when using the Live
CD. This will start the Ubuntu installer.

Installing Ubuntu—Getting started

At least   of free space on your hard drive is required in order to install
Ubuntu; however,   or more is recommended. is will ensure that
you will have plenty of room to install extra applications later on, as well
as store your own documents, music, and photos. To get started, place the
Ubuntu  in your  drive and restart your computer. Your computer
should load Ubuntu from the . When you ﬁrst start from the , you
will be presented with a screen asking you whether you want to ﬁrst try
out Ubuntu or install it. Select the language you want to view the installer
in and click on the Install Ubuntu buon. is will start the installation
process.
If you have an Internet connection, the installer will ask you if you
would like to “Download updates while installing.” We recommend you
do so. e second option, “Install this third-party soware,” includes the
Fluendo  codec, and soware required for some wireless hardware. If
you are not connected to the Internet, the installer will help you set up a
wireless connection.
e “Preparing to install Ubuntu” screen will also let you know if you

Clicking on the underlined “release notes” link
will open a web page containing any important
information regarding the current version of
Ubuntu.
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have enough disk space and if you are connected to a power source (in case
you are installing Ubuntu on a laptop running on baery). Once you have
selected your choices, click Continue.
Internet connection

If you are not connected to the Internet, the installer will ask you to choose
a wireless network (if available).
. Select Connect to this network, and then select your network from the
list.
. If the list does not appear immediately, wait until a triangle/arrow appears next to the network adapter, and then click the arrow to see the
available networks.
. In the Password ﬁeld, enter the network  or  key (if necessary).
. Click Connect to continue.

We recommend that you connect during install,
though updates and third-party software can be
installed after installation.

Figure 1.2: Set up wireless.

Allocate drive space

is next step is oen referred to as partitioning. Partitioning is the process
of allocating portions of your hard drive for a speciﬁc purpose. When you
create a partition, you are essentially dividing up your hard drive into sections that will be used for diﬀerent types of information. Partitioning can
sometimes seem complex to a new user; however, it does not have to be. In
fact, Ubuntu provides you with some options that greatly simplify this process. e Ubuntu installer will automatically detect any existing operating
system installed on your machine, and present installations options based
on your system. e options listed below depend on your speciﬁc system
and may not all be available:
‣
‣
‣
‣
‣

Install alongside other operating systems
Install inside Windows
Upgrade Ubuntu … to .
Erase … and install Ubuntu
Something else

If you are installing on a new machine with no
operating system, you will not get the ﬁrst
option. The upgrade option is only available if
you are upgrading from a previous version of
Ubuntu.

 

Install alongside other operating systems.

If you are a Windows or Mac user and you are trying to install Ubuntu for
the ﬁrst time, select the Install alongside other operating systems option.
is option will enable you to choose which operating system you wish to
use when you computer starts. Ubuntu will automatically detect the other
operating system and install Ubuntu alongside it.

Ubuntu provides you with the option of either
replacing your existing operating system
altogether, or installing Ubuntu alongside
your existing system. The latter is called dualbooting. Whenever you turn on or restart your
computer, you will be given the option to select
which operating system you want to use for
that session.

For more complicated dual-booting setups, you will need to conﬁgure the partitions manually.

Figure 1.3: Choose where you would like to
install Ubuntu.

Upgrade Ubuntu … to 12.04

is option will keep all of your Documents, music, pictures, and other
personal ﬁles. Installed soware will be kept when possible (not all your
currently installed soware may be supported on the new version). Systemwide seings will be cleared.
Erase disk and install Ubuntu

Use this option if you want to erase your entire disk. is will delete any
existing operating systems that are installed on that disk, such as Windows
, and install Ubuntu in its place. is option is also useful if you have
an empty hard drive, as Ubuntu will automatically create the necessary
partitions for you.
Formaing a partition will destroy any data currently on the partition. Be sure to
back up any data you want to save before Formaing.

Something else

is option is for advanced users and is used to create special partitions, or
format the hard drive with a ﬁle system diﬀerent to the default one.
Aer you have chosen the installation type, click Continue, or Install
Now.

Ubuntu installs a home folder where your
personal ﬁles and conﬁguration data are
located by default. If you choose to have your
home folder on a separate partition, then in the
event that you decide to reinstall Ubuntu or
perform a fresh upgrade to the latest release,
your personal ﬁles and conﬁguration data won’t
be lost.
More information and detailed instructions
on partitioning are available at: https://help.
ubuntu.com/community/HowtoPartition.
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Conﬁrm Partition choices and start install

If you chose Something else, conﬁgure the partitions as you need. Once
you are happy with the way the partitions are going to be set up, click the
Install Now buon at the boom right to move on.
To reduce the time required for installation, Ubuntu will continue the
installation process in the background while you conﬁgure important user
details—like your username, password, keyboard seings and default timezone.
Where are you?

Figure 1.4: Tell Ubuntu your location.

e next screen will display a world map. Using your mouse, click your
geographic location on the map to tell Ubuntu where you are. Alternatively,
you can use the drop-down lists underneath the map. is allows Ubuntu
to conﬁgure your system clock and other location-based features. Click
Forward when you are ready to move on.
Keyboard layout

Figure 1.5: Verify that your keyboard layout is
correct.

Next, you need to tell Ubuntu what kind of keyboard you are using.

 

In most cases, you will ﬁnd the suggested option satisfactory. If you are
unsure which keyboard option to select, you can click the Detect Keyboard
Layout buon to have Ubuntu determine the correct choice by asking you
to press a series of keys. You can also manually choose your keyboard
layout from the list of options. If you like, enter text into the box at the
boom of the window to ensure you are happy with your selection, then
click Continue.
Who are you?

Ubuntu needs to know some information about you so it can set up the
primary user account on your computer. When conﬁgured, your name will
appear on the login screen as well as the user menu, which we discuss in
Chapter : e Ubuntu Desktop.
On this screen you will need to tell Ubuntu:
‣
‣
‣
‣
‣

your name
what you want to call your computer
your desired username
your desired password
how you want Ubuntu to log you in

Figure 1.6: Setup your user account.

Enter your full name under “Your name?”. e next text ﬁeld is the name
your computer uses, for terminals and networks. You can change this to
what you want, or keep the predetermined name. Next is your username,
the name that is used for the user menu, your home folder, and behind the
scenes. You will see this is automatically ﬁlled in for you with your ﬁrst
name. Most people ﬁnd it easiest to stick with this. However, it can be
changed if you prefer.
Next, choose a password and enter it into the password ﬁeld on the
le, and then enter same password into the password ﬁeld on the right.
When both passwords match, a strength rating will appear to the right
that will show you whether your password is “too short,” “weak,” “fair,” or
“strong.” You will be able to continue the installation process regardless
of your password strength, but for security reasons it is best to choose a
strong one. is is best achieved by having a password that is at least six
characters long, and is a mixture of leers, numbers, symbols, and upper-
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case/lowercase. Avoid obvious passwords that include your birth date,
spouse’s name, or the name of your pet.
Login Options

Finally, at the boom of this screen you have three options from which to
choose regarding how you wish to log in to Ubuntu.
‣ Log in automatically
‣ Require my password to log in
‣ Encrypt my home folder
Log in automatically

Ubuntu will log in to your primary account automatically when you start
up the computer so you won’t have to enter your username and password.
is makes your login experience quicker and more convenient, but if
privacy or security are important to you, we don’t recommend this option.
Anyone who can physically access your computer will be able to turn it on
and also access your ﬁles.
Require my password to login

is option is selected by default, as it will prevent unauthorized people
from accessing your computer without knowing the password you created earlier. is is a good option for those who, for example, share their
computer with other family members. Once the installation process has
been completed, an additional login account can be created for each family
member. Each person will then have their own login name and password,
account preferences, Internet bookmarks, and personal storage space.
Encrypt my home folder

is option provides you with an extra layer of security. Your home folder
is where your personal ﬁles are stored. By selecting this option, Ubuntu
will automatically enable encryption on your home folder, meaning that
ﬁles and folders must be decrypted using your password before they can
be accessed. erefore if someone had physical access to your hard drive
(for example, if your computer was stolen and the hard drive removed), they
would not be able to see your ﬁles without knowing your password.
If you choose this option, be careful not to enable automatic login at a later date.
It will cause complications with your encrypted home folder, and will potentially
lock you out of important ﬁles.

Finishing Installation

Ubuntu will now ﬁnish installing on your hard drive. As the installation
progresses, a slideshow will give you an introduction to some of the default
applications included with Ubuntu. ese applications are covered in more
detail in Chapter : Working with Ubuntu. e slideshow will also highlight
the Ubuntu support options:
Aer approximately twenty minutes, the installation will complete and
you will be able to click Restart Now to restart your computer and start

 

Figure 1.7: Ubuntu community support options.
Where to get help for Ubuntu.

Ubuntu. e  will be ejected, so remove it from your  drive and press
Enter to continue.
Figure 1.8: You are now ready to restart your
computer.

Wait while your computer restarts, and you will then see the login window (unless you selected automatic login).
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Login Screen

Aer the installation is over and the computer is restarted, you will be
greeted by the login screen of Ubuntu. e login screen uses LightDM
which is a light on resources and easy to customize display manager. e
login screen will present you with your username and you will have to
enter the password to get past it. Click your username and enter your password. Once done, you may click the arrow or press Enter to get into the
Ubuntu desktop. Ubuntu’s login screen supports multiple users and also
supports custom backgrounds for each user. In fact, Ubuntu automatically will pick up your current desktop wallpaper and set it as your login
background. Ubuntu’s login screen also lets you select the diﬀerent environments to login. In a default Ubuntu installation, you will have two
environments; Ubuntu and Ubuntu-D. If you want to login to Ubuntu-D,
click on the Ubuntu icon and select Ubuntu-D from the list and then enter
your password to login. e login screen allows you to update your keyboard language, volume intensity and enable/disable accessibility seings
before you log in to your desktop. It also displays date/time and baery
power for laptops. You can also shut down or restart your system from the
login screen.

A guest session is also available at the login
screen. You can activate this session for guests
using your laptop or desktop.

Figure 1.9: Login Screen.

Ubuntu installer for Windows

You can install and run Ubuntu alongside your current installation of Windows:
. Download the Ubuntu installer for Windows http://www.ubuntu.com/
download/ubuntu/windows-installer
. Run the download ﬁle
. Install Ubuntu
Download and run the installer

Aer the ﬁle, wubi.exe, is downloaded, run the ﬁle to start the installation. If
a security message appears, click Continue, to proceed with the installation:

 

Figure 1.10: User Account Control dialog

Installation

e Ubuntu Installer will start. Choose and enter a “Username” and “Password.” e password must be entered twice to ensure accuracy. Aer
choosing a password, click Install. e Ubuntu Installer will download and
install Ubuntu. is process will take some time. e download ﬁle size is
Mb. Aer the installation is complete, click Finish on the “Completing
the Ubuntu Setup Wizard” screen to reboot the computer.
Figure 1.11: Ubuntu Windows Installer

Installation complete

Aer the computer restarts, you can select “Ubuntu” from the boot menu.
You will then be logged in to Ubuntu and will be presented with your new
desktop!

2

The Ubuntu Desktop

Understanding the Ubuntu desktop

Initially, you may notice many similarities between Ubuntu and other
operating systems, such as Microso Windows or Mac  . is is because
they are all based on the concept of a graphical user interface ()—i.e.,
you use your mouse to navigate the desktop, open applications, move ﬁles,
and perform most other tasks. In short, things are visually-oriented. is
chapter is designed to help you become familiar with various applications
and menus in Ubuntu so that you become conﬁdent in using the Ubuntu
.

Ubuntu 12.04 places an emphasis on “social
from the start” and features social network
integration in the desktop for sites like Twitter
and Facebook.

Figure 2.1: The Ubuntu 12.04 default desktop.

Unity

All -based operating systems use a desktop environment. Desktop environments encompass many things, such as:
‣ e look and feel of your system
‣ e way the desktop is laid out
‣ How the desktop is navigated by the user
In Linux distributions (such as Ubuntu), a number of desktop environments are available. Ubuntu uses Unity as the default desktop environment.
Aer installing and logging in to Ubuntu, you will see the Unity desktop. is initial view is comprised of the e Desktop Background and
two bars—one is horizontally located at the top of your desktop called e
Menu Bar, and the other bar is vertically oriented at the far le, called the
Launer.

To read more about other variants of Ubuntu,
refer to Chapter 8: Learning More.
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Unity comes in two versions—Unity D and Unity D. By default, Ubuntu
installs the Unity D interface. is interface is a graphic intensive desktop
interface allowing for smooth transitions, stacking icons in the Launcher, and
transparent utility and shell windows, to name a few features. Unity D is a
less-graphic-intensive shell interface—equal in comparsion to its “big brother”.
Unity D is available as an additional download. Although the two variants of
Unity may show slight diﬀerences in the “look and feel” of the desktop, Unity
does not impact the functionality of the application or utility being displayed.
e details of how Unity came to replace GNOME, features of the Unity interface,
and how to install both types, can be found by searching Unity user interface at
http://en.wikipedia.org

.
The Desktop Background

Below the menu bar is an image that covers the entire desktop. is is
the default desktop background, or wallpaper, belonging to the default
Ubuntu . theme known as Ambiance. To learn more about customizing
your desktop (including changing your background), see the section on
Customizing your desktop below.
The Menu Bar

e menu bar incorporates common functions used in Ubuntu .. e
icons on the far-right of the menu bar are called the indicator area. Each
installation of Ubuntu may contain slightly diﬀerent types and quantities
of icons based on a number of factors, including type of hardware and
available on-board accessories. e most common indicators are (starting
from the le):
Keyboard indicator allows you to select the keyboard layout you would like
and change your keyboard preferences.
Messaging indicator incorporates all your social applications. From here,
you can access your instant messenger client, your email client, your
microblogging application, and even UbuntuOne, your personal cloud!
Network indicator allows you to manage your network connections and
connect quickly and easily to a wired or wireless network.
Sound indicator provides an easy way to adjust the sound volume as well as
access your music player and sound seings.
Clock displays the current time and provides an easy way to access your
calendar and Time and Date seings.
User menu allows you to easily switch between diﬀerent users and access
your online and user accounts.
Session indicator provides an easy way to access System Seings, Updates,
Printers, and session options for locking your computer, logging out of
your session, restarting the computer, or shuing down completely.
Every application has a menuing system where diﬀerent actions can be
executed in an application (like File, Edit, View, etc.); the menuing system
for an application is appropriately called the application menu. In Unity,
the application menu isn’t on the titlebar of the application as is commonly
the case with other  environments. Instead, it is located to the le area
of the menu bar. To show an application’s menu, just move your mouse
to the Ubuntu desktop’s menu bar. While your mouse is positioned here,
the active application’s menus will superimpose itself over the Ubuntu

For more about:

‣ the Messaging Indicator see Microblogging;
‣ the Network Indicator see Getting online;
‣ the Session Indicator see Session options.
The keyboard indicator only shows when you
have chosen more than one keyboard layout in
the keyboard settings during installation.

Figure 2.2: The Indicators of the menu bar.

Note that some older applications may still
display their menu within the application
window.

   

desktop’s menu bar, allowing you to use the application’s menus. Moving
your mouse away from the menu bar will allow Ubuntu desktop’s menu
bar to reappear. is capability of Unity to only show the application’s
menu when needed is especially beneﬁcial for netbook and laptop users as
it provides you with more free work space.
The Launcher

Figure 2.3: The Ubuntu 12.04 Launcher on the
left with a sample of applications on it.

e vertical bar of icons on the le side of the screen is called the
Launcher. e Launcher provides easy access to applications, mounted
devices, and the Trash. All running applications on your system will place
an icon in the Launcher while the application is running. e ﬁrst icon at
the top of the Launcher is the Dash, a major innovation and core element
of Unity—we will explore the Dash in a later section of this chapter. By
default, other applications appear on the Launcher, including applications
such as LibreOﬃce and Firefox, the workspace switer lens, any mounted
devices, and, of course, the always-important Trash lens at the boom of
the Launcher.
Using Launcher

workspace switcher helps you to select the
workspace or the window you want. Trash
contains deleted ﬁles.
Tip: Pressing Super+S will show the content of
the workspaces on one screen.

Running applications

To run an application from the Launcher (or cause an already-running
application to appear), just click on the application’s icon. Running applications will have one or more triangles on the le side of its icon, indicating
the number of application windows open for this application. e application in the foreground (meaning on top of all other open application
windows) is indicated by a single white triangle on the right side of its icon.
You can also run an application through the Dash. We will talk about the
Dash, in the e Dash section.

If you hold the Super key, a number will appear
on each of the ﬁrst ten applications, along with
a margin containing useful shortcuts. You can
launch an application with a number n on it by
typing Super+n.
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Figure 2.4: Just below the Home Folder icon,
you will see the Firefox icon. Notice the
triangle on the right side indicating it is the
application in the foreground (on top of all
other applications), and the triangle on the
left side indicating there’s only one window
associated with Firefox at this time.

Adding and removing applications from the Launcher

ere are two ways to add an application to the Launcher:
‣ Open the Dash, ﬁnd the application to add, and drag and drop it to the
Launcher
‣ Run the application you want to add to the Launcher, right-click on the
application’s icon on the Launcher, and select Lo to Launer.
To remove an application from the Launcher, right-click on the application’s icon, then select Unlo from Launer.
The Dash

e Dash is a tool to help you access and ﬁnd applications and ﬁles on your
computer quickly. If you are a Windows user, you’ll ﬁnd the Dash to be
a more advanced Start Menu. If you are a Mac user, the Dash is similar to
Launchpad in the dock. If you’ve used a previous version of Ubuntu or another  Linux distribution, the Dash replaces the   menus. To
explore the Dash, click on the top-most icon on the Launcher; the icon has
the Ubuntu logo on it. Aer selecting the Dash icon, another window will
appear with a search bar on the top as well as grouping of recently accessed
applications, ﬁles, and downloads. e search bar provides dynamic results
as you enter your search terms. e ﬁve lenses at the boom are links to
your Home lens, Applications lens, Files lens, and Music and Videos lenses.
Lenses act as specialized search categories in the Dash.

The Dash allows you to search for information,
both locally (installed applications, recent ﬁles,
bookmarks, etc.) as well as remotely (Twitter,
Google Docs, etc.). This is accomplished by
utilizing one or more lenses, each responsible
for providing a category of search results for
the Dash. For more information about the Dash
and its lens, see: https://wiki.ubuntu.com/Unity

Figure 2.5: The Dash

   

Search for ﬁles and applications with the Dash

e Dash is an extremely powerful tool allowing you to search your entire
system for applications and ﬁles based on your search terms.
Find ﬁles/folder

Dash can help you ﬁnd the names of ﬁles or folders. Simply type in what
you remember of the name of the ﬁle or folder, and as you type, results
will appear in the Dash. e Files lens can also assist you in ﬁnding ﬁles
or folders. e Files lens shows you the most recent ﬁles accessed, as well
as recent downloads. You can use the ﬁlter results buon in the top-right
corner of the Dash to ﬁlter results to your requirements by ﬁle or folder
modiﬁcation times, by ﬁle type (.odt, .pdf, .doc, .tex., etc.), or by size.
Find applications

e standard Ubuntu installation comes with many applications. Users
can also download thousands more applications from the Ubuntu Soware
Center. As you collect an arsenal of awesome applications (and get a bonus
point for alliteration!), it may become diﬃcult to remember the name of a
particular application. Simply use the Application lens on the Dash. is
lens will automatically categorize installed applications under “Recently
Used,” “Installed,” or “Apps Available for Download.”You can also enter a
name of the application (or a part of it), in the search bar in the Dash, and
the names of applications matching your search criteria will appear. Even if
you don’t remember the name of the application at all, type a keyword that
is relevant to that application, and the Dash will ﬁnd it. For example, type
music, and the Dash will show you the default music player any any music
player you’ve used).

Ubuntu Software Center and software management will be discussed in detail at Chapter 5:
Software Management.

If you are new to the world of Ubuntu, be
sure to read the Chapter 3: Working with
Ubuntu. It will provide you help in choosing the
application(s) that suit your needs.

Figure 2.6: You can see the default results when
you press Application lens, and also the criteria
on the right side.

Workspaces

Workspaces are also known as virtual desktops. ese separate views of
your desktop allow you to group applications together, and by doing so,
help to reduce cluer and improve desktop navigation. For example, in one
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workspace, you can open all of your media applications; your oﬃce suite in
another, and your web browser open in a third workspace. Ubuntu has four
workspaces by default.
Switching between workspaces

To switch between workspaces, click on the workspace switcher located on
the Launcher. is utility you to toggle through the workspaces (whether
they contain open applications or not), and choose the one you want to use.
Managing windows

When opening a program in Ubuntu (such as a web browser or a text editor
—see Chapter : Working with Ubuntu for more information on using
applications)—a window will appear on your desktop. e windows in
Ubuntu are very similar to those in Microso Windows or Mac  . Simply
stated, a window is the box that appears on your screen when you start a
program. In Ubuntu, the top part of a window (the titlebar) will have the
name of the application to the le (most oen, the title will be the name
of the application). A window will also have three buons in the top-le
corner. From le to right, these buons represent close, minimize window,
and maximize window. Other window management options are available by
right-clicking anywhere on the title bar.
Closing, maximizing, restoring, and minimizing windows

Figure 2.7: This is the top bar of a window,
named titlebar. The close, minimize, and
maximize buttons are on the top-left corner of
window.

To close a window, click on the in the upper-le corner of the window
—the ﬁrst buon on the le-hand side. e buon immediately to the right
of the is the minimize buon ( ) which removes the window from the
visible screen and places it in the Launcher. is buon doesn’t close the
application, it just hides the application from view. When an application
is minimized to the Launcher, the le-side of the icon in the Launcher will
display a triangle showing you the application is still running. Clicking
the icon of the application that is minimized will restore the window to
its original position. Finally, the right-most buon ( ) is the maximize
buon, which makes the application window ﬁll the entire screen. Clicking

   

the maximize buon again will return the window to its original size. If
a window is maximized, its top-le buons and menu are automatically
hidden from view. To make them appear, just move your mouse to the menu
bar.
Moving and resizing windows

To move a window around the workspace, place the mouse pointer over
the window’s titlebar, then click and drag the window while continuing
to hold down the le mouse buon. To resize a window, place the pointer
on an edge or corner of the window so that the pointer turns into a larger,
two-sided arrow, (known as the resize icon). You can then click and drag to
resize the window.
Switching between open windows

In Ubuntu there are many ways to switch between open windows.
. If the window is visible on your screen, you can click any portion of it to
raise it above all other windows.
. Use Alt+Tab to select the window you wish to work with. Hold down
the Alt key, and keep pressing Tab until the window you’re looking for
appears in the popup.
. Click on the corresponding icon on the Launcher. Move your mouse to
the le side of your screen to show the Launcher, and right-click on the
application icon. If the application has multiple windows open, doubleclick on the icon in order to select the window you want.
Moving a window to diﬀerent workspace

To move a window to a diﬀerent workspace, make sure the window isn’t
maximized. If it is maximized, click on the right-most buon on the le
side of the titlebar to restore it to its original size. en right-click on the
window’s titlebar and select:
‣ Move to Workspace Le, to move the window to the le workspace
‣ Move to Workspace Right, to move the window to the right workspace
‣ Move to Another Workspace, and then choose the workspace you wish
to move the window to.
Window always on the top or on visible workspace

At times, you may want to have a window always on top so that it can be
seen or monitored while you work with other applications. For example, you may want to browse the web and, at the same time, view and
answer to any incoming instant message. To keep a window on top, rightclick on the window’s titlebar, then select Always On Top. Note that this
window will be on the top of all windows that are opened in the current
workspace. If you want to have a window always on the top regardless of
the workspace, right-click on the window’s titlebar, then select Always on
Visible Workspace. is window will now be on top of all other windows
across all workspaces.

You can also move a window by holding the Alt
key and dragging the window.

Figure 2.8: The workspace switcher on the
Launcher.
Super key is also known as the Windows key
(Win key). Press Super+D to hide all window
and display the desktop, the same works to
restore all windows.
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Browsing ﬁles on your computer

ere are two ways to locate ﬁles on your computer—either search for
them or access them directly from their folder. You can search for a ﬁle via
the Dash or Files & Folders in the Launcher. You can also use the Files &
Folders tool to access commonly used folders (such as Documents, Music,
Downloads), as well as most recently accessed ﬁles.

You can open your Home folder from the
Launcher.

Go

To access Go, move your mouse over the top bar and select Go. You can
browse the ﬁles on your computer by clicking Computer in this menu. If
you set up a home network, you will ﬁnd a menu item to access shared ﬁles
or folders.

If you do not see the desktop menu, click
somewhere on the desktop and it will appear.

Your Home Folder

e home folder is used to store your personal ﬁles. Your home folder
matches your login name. When you open your personal folder, you will
see there are several more folders inside, including Desktop (which contains any ﬁles that are visible on the desktop), Documents, Downloads,
Music, Pictures, Public, Templates, and Videos. ese are created automatically during the installation process. You can add more ﬁles and folders as
needed at any time.
Nautilus ﬁle manager

Just as Windows has Windows Explorer and Mac   has Finder to browse
ﬁles and folders, Ubuntu uses the Nautilus ﬁle manager by default.
The Nautilus ﬁle manager window

When you select the Home Folder shortcut in the Launcher, click on a
folder in the Dash, or double-click on a folder on the desktop, the Nautilus
ﬁle manager window opens. e default window contains the following
features:
menubar e menubar is located at the top of the screen, the so called
global menu. ese menus allow you to modify the layout of the browser,
navigate, bookmark commonly used folders and ﬁles, and view hidden
folders and ﬁles.
titlebar e titlebar shows the name of the currently selected folder. It also
contains the Close, Minimize, and Maximize buons.
toolbar e toolbar contains tools for navigation. On the right is the search
icon (which looks like a magnifying glass); clicking on this icon opens
a ﬁeld so you can search for a ﬁle or folder by name. Just below the
toolbar, you will see a representation of your current browsing. is is
similar to the history function in most browsers; it keeps track of where
you are and allows you to backtrack if necessary. You can click on the
locations to navigate back through the ﬁle browser.
le pane e le pane of the ﬁle browser has shortcuts to commonly used
folders. When a folder is bookmarked, it appears in the le pane. No
maer what folder is open, the le pane will always contain the same
folders. is le pane can be changed to display diﬀerent features (such

If you bookmark a folder, it will appear in the
Bookmarks menu and in the left pane.

If you start typing a location in the toolbar
starting with a / character, Nautilus will
automatically change the navigation buttons
into a text ﬁeld labeled Location. It is also
possible to convert the navigation buttons into
a text ﬁeld by pressing Ctrl+L.

   

as Information, Tree, History, etc.) by clicking the down arrow beside
“Places” near the top.
central pane e largest pane shows the ﬁles and folders in the directory
that you are currently browsing.

Figure 2.9: Nautilus ﬁle manager displaying
your home folder.

Navigating Nautilus

To navigate between folders, use the bookmarks in the le pane of the
Nautilus ﬁle manager. You can also retrace your steps by clicking on the
name of a folder in the path bar. Double-clicking on a visible folder will
cause you to navigate to it.

What is a Directory? Or a Folder? A directory is
a division of space in a ﬁle system that you can
use to organize ﬁles. A folder is the name given
to a directory in a Graphical User Interface (GUI)
environment like Nautilus.

Opening ﬁles

A ﬁle, in its simplest form, is data. Data can represent a text document,
database information, or data that will be used to produce music or video.
To open a ﬁle, you can either double-click on its icon or right-click the icon
and select one of the Open With options. Ubuntu aempts to determine
what application to use for the ﬁle being opened, and most of the time,
Ubuntu chooses correctly. However, if you want to open the ﬁle using an
application other than what is selected, then choose Open With Other
Application. A selection of installed applications will appear. Make your
selection, and the ﬁle will open in the selected application.
Creating new folders

To create a new folder from within Nautilus, click File ‣ Create New Folder.
en, name the folder that appears by replacing the default “Untitled
Folder” with your desired label (e.g., “Personal Finances”). You can also
create a new folder by pressing Ctrl+Shift+N, or by right-clicking in the
ﬁle browser window and selecting Create New Folder from the popup
menu (this action will also work on the desktop).
Hidden Files and Folders

If you wish to hide certain folders or ﬁles, place a dot (.) in front of the

You can easily view hidden ﬁles by clicking
View ‣ Show Hidden Files or by pressing
Ctrl+H. Hiding ﬁles with a dot (.) is not a
security measure—it simply provides a way to
keep folders organized and tidy.
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name (e.g., “.Personal Finances”). In some cases it is impossible to hide ﬁles
and folders without preﬁxing them with a dot. In Nautilus, these folders can
be hidden by creating a .hidden ﬁle. is is accomplished by opening the
ﬁle and typing the name of the ﬁle or folder you wish to hide. Make sure
that each ﬁle or folder is on a separate line. When you open Nautilus, the
folder will no longer be visible.
Copying and moving ﬁles and folders

You can copy ﬁles or folders in Nautilus by clicking Edit ‣ Copy, or by rightclicking on the item and selecting Copy from the popup menu. When using
the Edit menu in Nautilus, make sure you’ve selected the ﬁle or folder you
want to copy ﬁrst (by le-clicking on it once). Multiple ﬁles can be selected
by le-clicking in an empty space (i.e., not on a ﬁle or folder), holding the
mouse buon down, and dragging the cursor across the desired ﬁles or
folders. is “click-drag” move is useful when you are selecting items that
are grouped closely together. To select multiple ﬁles or folders that are
not positioned next to each other, hold down the Ctrl key while clicking
on each item individually. Once multiple ﬁles and/or folders are selected,
you can use the Edit menu to perform actions just like you would for a
single item. When one or more items have been “copied,” navigate to the
desired location then click Edit ‣ Paste (or right-click in an empty area of
the window and select Paste) to copy them to the new location. While the
copy command can be used to make a duplicate of a ﬁle or folder in a new
location, the cut command can be used to move ﬁles and folders around.
at is, a copy will be placed in a new location, and the original will be
removed from its current location. To move a ﬁle or folder, select the item
you want to move then click Edit ‣ Cut. Navigate to the desired location,
then click Edit ‣ Paste. As with the copy command above, you can also
perform this action using the right-click menu, and it will work for multiple
ﬁles or folders at once. An alternative way to move a ﬁle or folder is to click
on the item, and then drag it to the new location.

You can also use the keyboard shortcuts
Ctrl+X, Ctrl+C and Ctrl+V to cut, copy, and
paste (respectively) ﬁles and folders.

When you “cut” or “copy” a ﬁle or folder,
nothing will happen until you “paste” it
somewhere. Paste will only aﬀect the most
recent item that was cut or copied.
In the Nautilus Edit menu, you will also ﬁnd
the Copy To and Move To buttons. These can
be used to copy or move items to common
locations and can be useful if you are using
panes (see below). Note that it is unnecessary
to use Paste when using these options.
If you click on a ﬁle or folder, drag it, and then
hold down the Alt key and drop it to your
destination folder, a menu will appear asking
whether you want to copy, , move, or link the
item. Notice that the symbol of the mouse
cursor changes from an arrow into a question
mark as soon as you hold down the Alt key.

Using multiple tabs and multiple Nautilus windows

Opening multiple Nautilus windows can be useful for dragging ﬁles and
folders between locations. e option of tabs (as well as panes) is also available in Nautilus. To open a second windows when browsing a folder in
Nautilus, select File ‣ New Window or press Ctrl+N. is will open a new
window, allowing you to drag ﬁles and/or folders between two locations.
To open a new tab, click File ‣ New Tab or press Ctrl+T. A new row will appear above the space used for browsing your ﬁles containing two tabs—both
will display the directory you were originally browsing. You can click these
tabs to switch between them to click and drag ﬁles or folders between tabs
the same as you would between windows. You can also open a second pane
in Nautilus so you can see two locations at once without having to switch
between tabs or windows. To open a second pane, click View ‣ Extra Pane,
or press F3 on your keyboard. Again, dragging ﬁles and folders between
panes is a quick way to move or copy items.

When dragging items between Nautilus
windows, tabs, or panes, a small symbol will
appear over the mouse cursor to let you
know which action will be performed when
you release the mouse button. A plus sign
(+) indicates you are about to copy the item,
whereas a small arrow means the item will be
moved. The default action will depend on the
folders you are using.

Searching for ﬁles and folders on your computer

You can search for ﬁles and folders using the Dash or Nautilus.

Search for ﬁles and folders quickly by pressing
Ctrl+F in Nautilus and then typing what you
want to ﬁnd.

   

Search using the Dash

In the Dash, simply type your search terms in the search bar at the top of
the Dash.
Search using Nautilus

In Nautilus, click Go ‣ Sear for Files, or press Ctrl+F. is opens the
search ﬁeld where you can type the name of the ﬁle or folder you want to
ﬁnd.
Customizing your desktop

Figure 2.10: You can change most of your
system’s settings here.

One of the advantages to a windowed environment through Unity is the
ability to change the look and feel of your desktop. Don’t like the default
Ubuntu theme? Do you have a picture of your third cousin’s aunt’s uncle’s
nephew’s pet chihuahua that you’d love to see on your desktop as wallpaper? All of this (and more) is possible through desktop customizations in
Unity. Most customizations can be reached via the Session Indicator and
then selecting System Settings to open the System Seings application window. e Dash, desktop appearance, themes, wallpapers, accessibility, and
other conﬁguration seings are available here. For more information see
Session options.
Appearance

You can change the background, fonts, and window theme to further modify the look and feel of your desktop. To begin, open Appearance by either
right-clicking on your background and selecting Change Desktop Baground or selecting Session Indicator ‣ System Settings ‣ Appearance.
Theme

e “Appearance” window will display the current selected background
wallpaper and theme. emes control the appearance of your windows,
buons, scroll bars, panels, icons, and other parts of the desktop. e Ambiance theme is used by default, but there are other themes from which you
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Figure 2.11: You can change the theme in the
Look tab of the “Appearance” window.

can choose. Just click once on any of the listed themes to give a new theme
a try. e theme will change your desktop appearance immediately.
Desktop background

Under Baground, you may choose from Wallpapers, Pictures Folder,
and Colors and Gradients. When Wallpapers is selected, you will see
Ubuntu’s default selection of backgrounds. To change the background
simply click the picture you would like to use. You’re not limited to this
selection though. To use one of your own pictures, click the +… buon, and
navigate to the image you would like to use, double-click the image, and the
change will take eﬀect immediately. is image will then be added to your
list of available backgrounds. If you want to choose from a larger selection
of desktop backgrounds, click the “Get More Backgrounds Online” link at
the boom of the ”Appearance Preferences” window. is link will open
your web browser, and direct you to the http://art.gnome.org/backgrounds
website.
Accessibility

Ubuntu has built-in tools that make using the computer easier for people
with certain physical limitations. You can ﬁnd these tools by opening the
Dash and searching for “Universal Access.” On the Seeing tab you can manage the text size, the contrast of the interfaces, enable a zoom tool and even
a screen reader. Selecting high-contrast themes and larger on-screen fonts
can assist those with vision diﬃculties. You can activate “Visual Alerts”
though the Hearing tab, if you have hearing impairment. Also you can adjust keyboard and mouse seings to suit your needs through the Typing
and Pointing and Cliing tabs respectively.
Orca screen reader

Orca is a useful tool for people with visual impairments. Orca comes preinstalled in Ubuntu. To run Orca, click on the Dash in the Launcher and type
Orca, and click on the displayed result. Orca is the ”Screen Reader” part of
Universal Access and can be launched once the “Screen Reader” is activated.
Orca’s voice synthesizer will activate and assist you through the various op-

   

Figure 2.12: Universal allows you to enable
extra features to make it easier to use your
computer.

tions such as voice type, voice language, Braille, and screen magniﬁcation.
Once you have ﬁnished selecting your seings, you will need to log out of
the computer (Orca will oﬀer to do this for you). When you log back in, the
Orca seings you selected will automatically run every time you use your
computer.
Session options

When you have ﬁnished working on your computer, you can choose to log
out, suspend, restart, or shut down through the Session Indicator on the far
right side of the top panel.
Logging out

Logging out will leave the computer running but return you to the login
screen. is is useful for switching between users, such as when a diﬀerent
person wishes to log in to their account, or if you are ever instructed to “log
out and back in again.”
Suspend

To save energy, you can put your computer into suspend mode, which will
save its current condition to internal memory, power oﬀ all devices, and
allow you to start back up more quickly. While in a suspended state, the
computer will use just a trickle of energy; this is required because the session is saved to internal memory, and if no power goes to internal memory,
the data will be lost.
Rebooting

To reboot your computer, select Shut Down… from the “Session Indicator”
and click on Restart.
Shut down

To totally power down your computer, select Shut Down… from the “Session Indicator”.

You can also log out by pressing the
Ctrl+Alt+Del keys.
Before logging out, you should always verify
your work in any open applications is saved.
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Other options

From the Session Indicator, you can select Lo Screen to require a password before using the computer again—this is useful if you need to leave
your computer for some duration. You can also use the Session Indicator to
set up a guest session for a friend, or to switch users to log into another user
account without closing your applications.

You can lock your screen quickly by using the
keyboard shortcut Ctrl+Alt+L. Locking your
screen is recommended if you move away from
your computer for a short amount of time.

Getting help
General Help

Ubuntu, just like other operating systems, has a built-in help reference
called the Ubuntu Desktop Guide. To access it, click on the Dash and type
Help. Alternatively, you can select Ubuntu Help from the Help menu in the
menu bar.

Many applications have their own help section
which can be accessed by clicking the Help
menu within the application window.

Heads-Up Display help

Figure 2.13: The HUD (heads-up display) shows
application-speciﬁc help information based on
your general input.

e  (heads-up display) is a new help feature introduced in Ubuntu
.. is is a keyboard-friendly utility to help you ﬁnd commands, features, and preferences embedded deep within the menu structure of an
application. Activate the  by pressing the le Alt key on the keyboard.
If you want to search a menu item, such as creating a new message in underbird, then just type message in the  and the option for composing
a new email message will come up in the list of matching results. You can
press the Enter key to active the command. e  works for almost all
applications that are natively installable in Ubuntu; it also works for some
applications running under WINE.
Online Help

If you can’t ﬁnd an answer to your question in this manual or in the Ubuntu
Desktop Guide, you can contact the Ubuntu community through the
Ubuntu Forums (http://ubuntuforums.org). Many Ubuntu users open an
account on the forums to receive help, and in turn provide support to others
as they gain more knowledge. Another useful resource is the Ubuntu Wiki
(https://wiki.ubuntu.com), a website maintained by the Ubuntu community.

The HUD feature may not be available in all
applications as this is a new capability in Ubuntu
12.04. Your mileage may vary!
WINE is an acronym for Wine Is Not an Emulator.
It allows you to run some Windows-based
applications in Ubuntu. Discussion of how to
use WINE is beyond the scope of this manual,
but it is worth checking out if you need to run
Windows applications under Ubuntu.
We encourage you to check any information
you ﬁnd on other websites with multiple
sources when possible, but only follow directions if you understand them completely.

   

Figure 2.14: The built-in system help provides
topic-based help for Ubuntu.
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Working with Ubuntu

All the applications you need

If you are migrating from a Windows or Mac platform, you may wonder
if the programs that you once used are available for Ubuntu. Some of the
programs you already use have native Linux versions. And, for those that
don’t, there are free and open-source applications that will cover your
needs. is section will recommend some alternates that will work well
on Ubuntu. Most of the applications listed in this section are available via
the Soware Center. ose followed by an asterisk (*) can be downloaded
directly from their oﬃcial websites.

You can search for more applications in the
Ubuntu Software Center by the category that
you are interested in.

Oﬃce Suites

‣ Windows: Microso Oﬃce, LibreOﬃce
‣ Mac  : iWork, Microso Oﬃce, LibreOﬃce
‣ Linux: LibreOﬃce, KOﬃce,  Oﬃce, Kexi (database application)
In Ubuntu you may choose among many oﬃce suites. e most popular
suite is the LibreOﬃce (formerly OpenOﬃce). Included in the suite:
‣
‣
‣
‣
‣
‣

Writer—word processor
Calc—spreadsheet
Impress—presentation manager
Draw—drawing program
Base—database
Math—equation editor

LibreOﬃce Suite is installed by default. Note that Base is not installed by
default and it can be installed through Ubuntu Soware Center.
Email Applications

‣ Windows: Microso Outlook, Mozilla underbird
‣ Mac  : Mail.app, Microso Outlook, Mozilla underbird
‣ Linux: Mozilla underbird, Evolution, KMail
As with oﬃce suites, there are multiple options for email applications.
One very popular email application is Mozilla underbird, which is also
available for Windows. underbird is the default email application in
Ubuntu. Another option is Evolution—similar to Microso Outlook, it also
provides a calendar.
Web Browsers

‣ Windows: Microso Internet Explorer, Mozilla Firefox, Opera, Chromium,
Google Chrome
‣ Mac  : Safari, Mozilla Firefox, Opera, Chromium, Google Chrome
‣ Linux: Mozilla Firefox, Opera*, Chromium, Google Chrome*, Epiphany
e most popular web browsers can be installed directly from the
Ubuntu Soware Center.

Opera is available for download from http://
www.opera.com/browser/download/. Google
Chrome is available for download from https://
www.google.com/chrome/.
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PDF Readers

‣ Windows: Adobe Reader
‣ Mac  : Adobe Reader
‣ Linux: Evince, Adobe Reader, Okular
Evince is a user-friendly and minimalistic reader, and it is the default
PDF reader. If Evince doesn’t cover your needs, Adobe Reader is available
for Ubuntu too.
Multimedia Players

‣ Windows: Windows Media Player, VLC
‣ Mac  : icktime, VLC
‣ Linux: Totem, VLC, MPlayer, Kaﬀeine
For multimedia, Ubuntu users have a wide variety of options for high
quality players. Two popular and powerful media players for Ubuntu are
VLC and Mplayer. Meanwhile, the classic and user-friendly Totem is the
default media player in Ubuntu.
Music Players and Podcatchers

‣ Windows: Windows Media Player, iTunes, Winamp
‣ Mac  : iTunes
‣ Linux: Rhythmbox, Banshee, Amarok, Audacity, Miro
ere are several options for listening to music with Ubuntu: Rhythmbox
(installed by default), Rhythmbox, and Amarok, among many others. With
these you can listen to music and your favorite podcasts. Audacity is similar
to Winamp. ere is Miro for those of you who watch video podcasts and
TV series from the Internet.
CD/DVD Burning

‣ Windows: Nero Burning ROM, InfraRecorder
‣ Mac  : Burn, Toast Titanium
‣ Linux: Brasero, Kb, Gnome-baker
e are several popular disk burning applications such as Gnome-baker,
Brasero, Ubuntu’s default CD burner, and Kb. ese burners are powerful
tools, oﬀering user-friendly interfaces, many features and they are all open
source and free of charge!
Photo Management

‣ Windows: Microso Oﬃce Picture Manager, Picasa
‣ Mac  : Aperture, Picasa
‣ Linux: Shotwell, gumb, Gwenview, F-Spot
You can view and manage your favorite photos with Shotwell, Ubuntu’s
default photo manager, or with gumb, Gwenview, and F-Spot.
Graphics Editors

‣ Windows: Adobe Photoshop, GIMP

  

‣ Mac  : Adobe Photoshop, GIMP
‣ Linux: GIMP, Inkscape
GIMP is a very powerful graphics editor. You can create your own
graphics, taper your photographs, modify your pictures. GIMP, a powerful alternative to Photoshop, covers the needs of novice users, professional
photographers, and designers.
GIMP is not loaded by default, but can be installed via the Soware Center.

Instant Messaging

‣ Windows: Windows Live Messenger, AIM, Yahoo! Messenger, Google
Talk
‣ Mac  : Windows Live Messenger, AIM, Yahoo! Messenger, Adium,
iChat
‣ Linux: Empathy, Pidgin, Kopete, aMSN
None of the other platform  clients have Linux versions. However,
you can use Pidgin, Empathy or Kopete to communicate over most protocols including: AIM, MSN, Google Talk (Jabber/XMPP), Facebook, Yahoo!,
and ICQ. is means you need only one client to communicate with all of
your friends. e drawback is that some of these clients have limited video
support. If you are using MSN exclusively, aMSN may be worth a try.
VoIP Applications

‣ Windows: Skype, Google Video Chat
‣ Mac  : Skype, Google Video Chat
‣ Linux: Ekiga, Skype, Google Video Chat
VoIP technologies allow you to talk to people over the Internet. e
most popular such application is Skype, which is available for Linux. An
open-source alternative Ekiga supports voice communication using the SIP
protocol. Note that Ekiga isn’t compatible with the Skype.
BitTorrent Clients

‣ Windows: µTorrent, Azureus
‣ Mac  : Transmission, Azureus
‣ Linux: Transmission, Deluge, Azureus, KTorrent, Flush, Vuze, BitStorm
Lite
ere are a number of BitTorrent clients for Ubuntu: Transmission,
Ubuntu’s default client, is simple and light-weight, Deluge, Azureus and
KTorrent oﬀer many features and can satisfy the most demanding of users.
Getting online

is section of the manual will help you to check your connection to the
Internet and help you conﬁgure it where needed. Ubuntu can connect to
the Internet using a wired, wireless, or a dial up connection. Ubuntu .
also supports more advanced connection methods, which will be brieﬂy
discussed at the end of this section.
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A wired connection is when your computer connects to the Internet
using an Ethernet cable. is is usually connected to a wall socket or a
networking device—like a switch or a router.
A wireless connection is when your computer connects to the Internet
using a wireless radio network—usually known as Wi-Fi. Most routers now
come with wireless capability, as do most laptops and netbooks. Because of
this, Wi-Fi is the most common connection type for these types of devices.
Wireless connectivity makes laptops and netbooks more portable when
moving to diﬀerent rooms of a house and while traveling.
A dialup connection is when your computer uses a modem to connect to
the Internet through a telephone line.

In order to connect wirelessly, you must be in
a location with a working wireless network.
To set up your own wireless network, you will
need to purchase and install a wireless router
or access point. Some locations may already
have a publicly accessible wireless networks
available. If you are unsure whether your
computer has a wireless card, check with your
manufacturer.

NetworkManager

In order to connect to the Internet using Ubuntu, you need to use the NetworkManager utility. NetworkManager allows you to turn network connections on or oﬀ, manage wired and wireless networks, and make other
network connections, such as dial up, mobile broadband, and s.
You can access NetworkManager by using its icon found the top panel.
is icon may look diﬀerent depending on your current connection state.
Clicking this icon will reveal a list of available network connections. e
current connection (if any) will have the word “disconnect” underneath it.
You can click on “disconnect” to manually disconnect from that network.
is menu also allows you to view technical details about your current
connection or edit all connection seings. In the image to the right you
will see a tick mark next to “Enable Networking.” Click on the tick mark
to disable all network connections. Clicking a second time will enable
networking again. is can be very useful when you are required to turn oﬀ
all wireless communications, like in an airplane.

(a)
(b)
(c)
Figure 3.1: The network connection states: (a)
disconnected, (b) wired, and (c) wireless.

Figure 3.2: Here you can see the currently
active connection is “Wired connection 1.”

Establishing a wired connection

If you have an Ethernet cable running from a wall socket or networking
device, such as a switch or router, then you will want to setup a wired
connection in Ubuntu.
In order to connect to the Internet with a wired connection, you need to
know whether your network supports  (Dynamic Host Conﬁguration
Protocol).  is a way for your computer to automatically be conﬁgured
to access your network and/or Internet connection.  is usually automatically conﬁgured on your router. is is usually the quickest and easiest
way of establishing a connection to the Internet. If you are unsure whether
your router is setup to use , you may wish to contact your ’s (Internet Service Provider) customer service line to check. If your router isn’t
conﬁgured to use  then they will also be able to tell you what conﬁguration seings you need in order to get online.

Are you already online? If the NetworkManager
icon in the top panel shows a connection then
you may have successfully connected during
the Ubuntu setup process. You can also simply
open a browser and see if you have access
to the Internet. If so, you do not need to do
anything for the rest of this section.

Automatic connections with DHCP

If your network supports  then you may already be set up for online
access. To check this, click on the NetworkManager icon. ere should be
a “Wired Network” heading in the menu. If “Wired connection ” appears
directly underneath, then your machine is currently connected and probably setup for . If “Disconnected” appears in gray underneath the wired
network section, look below to see if an option labeled “Wired connecFigure 3.3: This window displays your IP address
and other connection information.

  

tion ” appears in the list. If so, click on it to aempt to establish a wired
connection.
To check if you are online, click on the NetworkManager icon in the
top panel and select the Connection Information option. You should see a
window showing details of your connection. If your  address is displayed
as ... or starts with ., then your computer was not successfully
assigned connection information through . If it shows another address
(e.g., ...), then it is likely that your  connection to the
router was successful. To test your Internet connection, you may want to
open the Firefox web browser to try loading a web page. More information
on using Firefox can be found later in this chapter.



An IP (Internet Protocol) address is a unique
number assigned to your machine so that your
router can identify you on the network. Think
of it like a phone number for your computer.
Having this unique address allows the router
to speak to your computer, and therefore
send/receive data.
If you are still not online after following these
steps, you may need to try setting up your
network connection manually using a static IP
address.

Manual conﬁguration with static address

If your network does not support  then you need to know a few items
of information before you can get online. If you do not know any of this
information, then you call your .
‣ An  address—is is a unique address used for identifying your computer on the network. An  address is always given in four numbered
groups, separated by dots, for example, .... When connecting using , this address will periodically change (hence, the name
“dynamic”). However, if you have conﬁgured a static  address, your IP
address will never change.
‣ A network mask—is tells your computer the size of the network to
which it is being connected. It is formaed the same way as the  address, but usually looks something like ....
‣ A gateway—is is the  address of the device that your machine looks
to for access to the Internet. Usually, this will be the router’s  address.
‣  server—is is the  address of the  (Domain Name Service)
server.  is what your computer uses to resolve  addresses to domain
names. For example http://www.ubuntu.com resolves to ....
is is the  address of the Ubuntu website on the Internet.  is
used so you don’t have to remember  addresses. Domain names (like
ubuntu.com) are much easier to remember. You will need at least one
 server address but you can enter up to three addresses in case one
server is unavailable.

If you do not know your ISP’s DNS
server addresses, Google has DNS
servers that anyone in the world
can use for free. The addresses of
these servers are: Primary—8.8.8.8
Secondary—8.8.4.4

To manually conﬁgure a wired connection, click on the NetworkManager
icon and select Edit Connections. Make sure you are looking at the “Wired
tab” inside the “Network Connections” window. e list may already have
an entry, such as “Wired connection ” or a similar name. If a connection is
listed, select it and click the Edit buon. If no connection is listed, click the
Add buon.
If you are adding a connection, you need to provide a name for the
connection. is will distinguish the connection being added from any
other connections added in future. In the “Connection Name” ﬁeld, choose a
name such as “Wired Home.”
To setup the connection:
. Make sure that the Connect automatically option is selected under the
connection name.
. Switch to the v Settings tab.
. Change the Method to “Manual.”
. Click on the Add buon next to the empty list of addresses.

Figure 3.4: In this window you can manually edit
a connection.
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. Enter your  address in the ﬁeld below the Address header.
. Click to the right of the  address, directly below the Netmask header
and enter your network mask. If you are unsure, “...” is the
most common.
. Click on the right of the network mask directly below the Gateway
header and enter the address of your gateway.
. In the  Servers ﬁeld below, enter the address of your  server(s).
If you are entering more than one, separate them with commas—for
example, “..., ...”.
. Click Apply to save your changes.

A  address is a hardware address for your computer’s network card. Entering
this information is sometimes important when using a cable modem connection.
If you know the  address of your network card, this can be entered in the
appropriate text ﬁeld in the Wired tab of the editing window. To ﬁnd the MAC
addresses for all installed networking devices, open a terminal window, and at
the command line prompt, type ifconfig. is will display a lot of information
about each of the network devices installed on the computer. e wired devices
will be labeled as LAN, LAN, etc. e wireless devices will appear as WLAN,
WLAN, etc.

When you have returned to the Network Connections screen, your
newly added connection should now be listed. Click Close to return to the
desktop. If your connection was conﬁgured correctly, the NetworkManager
icon should have changed to show an active wired connection. To test if
your connection is properly set up, simply open a web browser. If you can
access the Internet, then you are connected!
Wireless

If your computer is equipped with a wireless (Wi-Fi) card and you have a
wireless network nearby, you should be able to set up a wireless connection
in Ubuntu.
Connecting to a wireless network for the ﬁrst time

If your computer has a wireless network card, you can connect to a wireless
network. Most laptops and netbooks have a built-in wireless networking
card.
Ubuntu is usually able to detect any wireless network in range of your
computer. To see a list of wireless networks, click on the NetworkManager icon. Under the “Wireless Networks” heading you should see a list of
available wireless networks. Each network will be shown by its name and a
signal meter to the le showing its relative signal strength. e signal meter
looks like a set of bars similar to what is seen when viewing signal strength
of a cell phone. Simply put, the more bars, the stronger the signal.
A wireless network can be open to anyone, or it can be protected with
a password. A small padlock will be displayed by the signal bar if any
wireless network within range are password-protected. You will need to
know the correct password in order to connect to these secured wireless
networks.
To connect to a wireless network, select the desired network by clicking
on its name within the list. is will be the name that was used during
the installation of the wireless router or access point. Most s (Internet

To improve speed and reliability of your
wireless connection, try moving closer to your
router or wireless access point.

  



service providers) provide pre-conﬁgured routers with a sticker on them
detailing the current wireless network name and password. Most publicly
accessible wireless networks will be easily identiﬁable by the name used for
the wireless network—for example “Starbucks-Wireless.”
If the network is unprotected (i.e., the signal meter does not show a padlock), a connection should be established within a few seconds—and without a password required. e NetworkManager icon in the top panel will
animate as Ubuntu aempts to connect to the network. If the connection
is successful, the icon will change to display a signal meter. An on-screen
notiﬁcation message will also appear informing you that the connection
was successful.
If the network is password-protected, Ubuntu will display a window
called “Wireless Network Authentication Required” as it tries to make a
connection. is means that a valid password is required to make a connection. is is what the screen should look like:
Figure 3.5: Enter your wireless network
password.

If you know the password, enter it in the Password ﬁeld and then click
on the Connect buon. As you type the password, it will be obscured from
view to prevent others from reading the password as you type it. . Once the
password is entered, click on the Connect buon. e NetworkManager
icon in the top panel will animate as Ubuntu aempts to connect to the
network. If the connection is successful, the icon will change to display a
signal meter. An on-screen notiﬁcation message will also appear informing
you that the connection was successful.
If you entered the password incorrectly, or if it doesn’t match the correct password (for example if it has recently been changed and you have
forgoen), NetworkManager will make another aempt to connect to the
network, and the “Wireless Network Authentication Required” window will
re-appear so that you can re-type the password. You can hit the Cancel button to abort the connection. If you do not know the correct password, you
may need to call you ’s customer support line or contact your network
administrator.
Once you have successfully established a wireless connection, Ubuntu
will store these seings (including the password) to make it easier to connect to this same wireless network in the future. You may also be prompted
to select a keyring password here. e keyring stores passwords in one
place so you can access them all in the future by remembering just the
keyring password.
Connecting to a saved wireless network

If you have previously established a connection to a wireless network, this
connection information will be stored by Ubuntu. is will allow you to
connect to the network again without having to re-enter the password.
In addition, Ubuntu will automatically try to connect to a wireless net-

To verify the characters you are entering for
the password, you can view the password by
selecting the Show Password check box. Then,
you can make the password obscure again by
selecting the Show password check box again
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work in range if it has the seings saved. is works on both open and
secure wireless networks.
If you have numerous wireless networks in range that are saved on
your computer, Ubuntu may choose to connect to a one network while you
may want to connect to another network. To remedy this action, click on
the NetworkManager icon. A list of wireless networks will appear along
with their signal meters. Simply click on the network to which you wish to
connect, and Ubuntu will disconnect from the current network and aempt
to connect to the one you have selected.
If the network is secure and Ubuntu has the details for this network
saved, Ubuntu will automatically connect. If the details for this network
connection are not saved, or incorrect, or have changed, then you will be
prompted to enter the network password again. If the network is open (no
password required), all of this will happen automatically and the connection
will be established.
Connecting to a hidden wireless network

In some environments, you may need to connect to a hidden wireless network. ese hidden networks do not broadcast their names, and, therefore,
their names will not appear in the list of available wireless networks even
if they are in range. In order to connect to a hidden wireless network, you
will need to get its name and security details from your network administrator or .
To connect to a hidden wireless network:
. Click on NetworkManager in the top panel.
. Select Connect to a hidden wireless network. Ubuntu will then open
the “Connect to Hidden Wireless Network” window.
. In the Network name ﬁeld, enter the name of the network. is is also
known as the  (Service Set Identiﬁer). You must enter the name exactly how it was given to you. For example, if the name is “UbuntuWireless,” entering “ubuntu-wireless” will not work as the “U” and “W”
are both uppercase in the correct name.
. In the Wireless security ﬁeld, select one of the options. If the network
is an open network, leave the ﬁeld set to “None.” If you do not know the
correct seing for the ﬁeld, you will not be able to connect to the hidden
network.
. Click the Connect buon. If the network is secure, you will be prompted
for the password. Provided you have entered all of the details correctly,
the network should then connect, and you will receive an on-screen
notiﬁcation informing you that the connection was a success.
As is the case with visible wireless networks, hidden wireless network
seings will be saved once a connection is made, and the wireless network
will then appear in the list of saved connections NetworkManager.
Disabling and enabling your wireless card

By default, wireless access is enabled if you have a wireless card installed in
your computer. In certain environments (like on airplanes), you may need
to temporarily disable your wireless card.
To disable your wireless card, click on the NetworkManager icon and
deselect the Enable Wireless option. Your wireless radio will now be turned
oﬀ, and your computer will no longer search for wireless networks.

Many modern laptops also have a physical
switch/button built into the chassis that
provides a way to quickly enable/disable the
wireless card.

  

To reactivate your wireless card, simply reverse the process above.
Ubuntu will then begin to search for wireless networks automatically. If
you are in range of a saved network, you will automatically be connected.
Changing an existing wireless network

At times you may want to change the seings of a saved wireless network
—for example, when the wireless password gets changed.
To edit a saved wireless network connection:
. Click on the NetworkManager icon and select Edit Connections…
. A “Network Connections” window will open. Click on the Wireless tab.
. By default, saved networks are in chronological order with the most
recently connected at the top. Find the network you want to edit, click
on it, and click on the Edit buon.
. Ubuntu will now open a window called “Editing ⟨connection name⟩”,
where ⟨connection name⟩ is the name of the connection you are editing.
is window will display a number of tabs.
. Above the tabs, there is a ﬁeld called Connection name where you can
change the name of the connection to give it a more recognizable name.
. If the Connect automatically option is not selected, Ubuntu will detect
the wireless network but will not aempt a connection until it is selected from the NetworkManager menu. Select or deselect this option as
needed.
. On the Wireless tab, you may need to edit the  ﬁeld. A  is the
wireless connection’s network name. If this ﬁeld isn’t set correctly,
Ubuntu will not be able to connect to the wireless network in question.
. Below the  is a Mode ﬁeld. e “Infrastructure” mode means that
you would be connecting to a wireless router or access point. e “adhoc” mode is for a computer-to-computer connection (where one computer shares another’s connection) and is oen only used in advanced
cases.
. On the Wireless Security tab, you can change the Security ﬁeld. A
selection of “None” means that you are using an open network that
doesn’t require a password. Other selection in this tab may required
additional information:
 /-bit Key is an older security seing is still in use by some
older wireless devices. If your network uses this method of security,
you will need to enter a key in the Key ﬁeld that will appear when
this mode is selected.
 -bit Passphrase is the same older security as above. However,
instead of having a key, your network administrator should have
provided you with a passphrase to connect to the network.
 &  Personal is the most common security mode for wireless
networking. Once you select this mode, you will need to enter a
password in the Password ﬁeld.
If your network administrator requires , Dynamic  or  &
 Enterprise then you will need to have the administrator help
you with those modes.
. In the v Settings tab, you can change the Method ﬁeld from “Automatic ()” to “Manual” or one of the other methods. For seing up
manual seings (also known as a static address), please see the section
above on manual setup for wired network connections.
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. When you ﬁnish making changes to the connection, click Apply to save
your changes and close the window. You can click Cancel at any time to
close the window without saving any changes.
. Finally, click Close on the “Network Connections” window to return to
the desktop.
Aer clicking Apply, any changes made to the network connection will
take eﬀect immediately.
Other connection methods

ere are other ways to get connected with Ubuntu.
With NetworkManager, you can conﬁgure “Mobile Broadband” connections to connect to the Internet through your cellular data carrier.
You can connect to  (Digital Subscriber Line) networks, a method of
connecting to the Internet through your phone line via a modem.
It is also possible for NetworkManager to establish a  (Virtual Private
Network) connection. ese are most commonly used to create a secure
connection to a workplace network.
e instructions for making connections using “Mobile Broadband,” ,
or  are beyond the scope of this guide.
Browsing the web

Once you have connected to the Internet, you should be able to browse the
web. Mozilla Firefox is the default application for this in Ubuntu.
Figure 3.6: The default Ubuntu home page for
the Firefox web browser.

Starting Firefox

ere are several ways to start Firefox. By default Ubuntu has the Firefox
icon within the Launcher (the vertical bar down the le side of the screen).
Select this icon to open Firefox. Or, open the Dash (the top-most icon in the

  



Launcher) and search for firefox using the search box. If your keyboard
has a “” buon, you can press that buon to start Firefox.
Navigating web pages
Viewing your homepage

When you start Firefox, you will see your home page. By default, this is the
Ubuntu Start Page.
To quickly go to your home page, press Alt+Home on your keyboard or
press on the home icon in Firefox.
Navigating to another page

To navigate to a new web page, you need to enter its Internet address (also
known as a ) into the Location Bar. s normally begin with “hp://”
followed by one or more names that identify the address. One example
is “http://www.ubuntu.com/.” (Normally, you can omit the “hp://“ part.
Firefox will ﬁll it in for you.)

URL stands for uniform resource locator, which
tells the computer how to ﬁnd something on
the Internet—such as a document, web page or
an email address. WWW stands for World Wide
Web, which means the web pages by which
most people interact with the Internet.

Figure 3.7: You can enter a web address or
search the Internet by typing in the location
bar.

To navigate:
. Double-click in the Location Bar, or press Ctrl+L, to highlight the 
that is already there.
. Enter the  of the page you want to visit. e  you type replaces
any text already in the Location Bar.
. Press Enter.
If you don’t know the  that you need, type a search term into the
Search Bar to the right of the Location bar. Your preferred search engine
—Google by default—will return a list of websites for you to choose from.
(You can also enter your query directly into the Location Bar).
Selecting a link

Most web pages contain links that you can select. ese are known as
“hyperlinks.” A hyperlink can let you move to another page, download a
document, change the content of the page, and more.
To select a link:
. Move the mouse pointer until it changes to a pointing ﬁnger. is happens whenever the pointer is over a link. Most links are underlined text,
but buons and pictures on a web page can also be links.
. Click the link once. While Firefox locates the link’s page, status messages will appear at the boom of the window.
Retracing your steps

If you want to visit a page you have viewed before, there are several ways
to do so.
‣ To go back or forward one page, press the Ba or Forward buon by
the le side of the Location Bar.

To go backwards and forwards you can also use
Alt+Left and Alt+Right respectively.
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‣ To go back or forward more than one page, click-and-hold on the respective buon. You will see a list of pages you have recently visited. To
return to a page, select it from the list.
‣ To see a list of any s you have entered into the Location Bar, press
the down arrow at the right end of the Location Bar. Choose a page from
the list.
‣ To choose from pages you have visited during the current session, open
the History menu and choose from the list in the lower section of the
menu.
‣ To choose from pages you have visited over the past few months, open
the History ‣ Show All History (or press Ctrl+Shift+H). Firefox opens a
“Library” window showing a list of folders, the ﬁrst of which is “History.”
Select a suitable sub-folder, or enter a search term in the search bar (at
the top right), to ﬁnd pages you have viewed before. Double-click a
result to open the page.
Stopping and reloading

If a page is loading too slowly or you no longer wish to view a page, press
Esc to cancel it. To reload the current page if it might have changed since
you loaded it, press on the Reload buon or press Ctrl+R.

The Reload button is at the right end of the
Location Bar.

Opening new windows

At times, you may want to have more than one browser window open. is
may help you to organize your browsing session beer, or to separate web
pages that you are viewing for diﬀerent reasons.
ere are four ways to create a new window:
‣ On the top bar, select File ‣ New Window.
‣ Press Ctrl+N.
‣ Right-click on Firefox’s icon on the Launcher and select Open New
Window.
‣ Click on Firefox’s icon on the Launcher using your middle mouse buon.
Once a new window has opened, you can use it exactly the same as
the ﬁrst window—including navigation and opening tabs. You can open
multiple windows.
Opening a link in a new window

Sometimes, you may want to click a link to navigate to another web page,
but do not want the original to close. To do this, you can open the link in its
own independent window.
ere are two ways to open a link in its own window:
‣ Right-click a link and select Open Link in New Window.
‣ Press-and-hold the Shift key while clicking a link.
Tabbed browsing

An alternative to opening new windows is to use Tabbed Browsing instead.
Tabbed browsing lets you open several web pages within a single Firefox
window, each independent of the other. is frees space on your desktop
as you do not have to open a separate window for each new web page. You

A new tab is independent of other tabs in the
same way that new windows are independent
of other windows. You can even mix-and-match
—for example, one window may contain tabs
for your emails, while another window has tabs
for your work.

  



can open, close, and reload web pages in one place without having to switch
to another window.
You can alternate quickly between diﬀerent tabs by using the keyboard
shortcut Ctrl+Tab.
Opening a new blank tab

ere are three ways to create a new blank tab:
‣ Click on the Open new tab buon (a green plus-sign) on the right side of
the last tab.
‣ On the top bar, open File ‣ New Tab.
‣ Press Ctrl+T.
When you create a new tab, it contains a blank page with the Location
Bar focused. Type a web address () or other search term to open a website in the new tab.
Opening a link in its own tab

Sometimes, you may want to click a link to navigate to another web page,
but do not want the original to close. To do this, you can open the link in its
own tab.
ere are several ways to open a link in its own tab.
‣ Right-click a link and select Open Link in New Tab.
‣ Press-and-hold the Ctrl key while clicking a link.
‣ Click the link using either the middle mouse buon or both le and right
mouse buons simultaneously.
‣ Drag the link to a blank space on the tab bar or onto the Open new tab
buon.
‣ Press-and-hold Ctrl+Shift while clicking a link.
Closing a tab

Once you have ﬁnished viewing a web page in a tab, you have various ways
to close it:
‣
‣
‣
‣

Click on the Close buon on the right side of the tab.
Click the tab with the middle mouse buon or the mouse wheel.
Press Ctrl+W.
Right-click the tab and select Close Tab.

Restoring a closed tab

Sometimes, you may close the wrong tab by accident, or want to bring back
a tab that you have recently closed. Bring back a tab in one of the following
two ways:
‣ Press Ctrl+Shift+T to re-open the most recently closed tab.
‣ Select History ‣ Recently Closed Tabs, and choose the name of the tab to
restore.

A tab always opens “in the background”—in
other words, the focus remains on the original
tab. The last method (Ctrl+Shift) is an
exception; it focuses the new tab immediately.
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Changing the tab order

Move a tab to a diﬀerent location on the tab bar by dragging it to a new
location using your mouse. While you are dragging the tab, Firefox displays
a small indicator to show the tab’s new location.
Moving a tab between windows

You can move a tab into a new Firefox window or, if one is already open,
into a diﬀerent Firefox window.
Drag a tab away from the tab bar, and it will open into a new window.
Drag it from the tab bar into the tab bar of another open Firefox window,
and it will move there instead.
Searching

You can search the web from within Firefox without ﬁrst visiting the home
page of the search engine. By default, Firefox will search the web using the
Google search engine.
Searching the web

To search the web in Firefox, type a few words into the Firefox search Bar.
For example, if you want to ﬁnd information about the Ubuntu:
. Move your cursor to the Sear Bar using your mouse or press Ctrl+K.
. Type the phrase Ubuntu. Your typing replaces any text currently in the
Search Bar.
. Press the magnifying glass or Enter to search.
Search results from Google for “Ubuntu” will appear in the Firefox window.
Selecting search engines

If you do not want to use Google as your search engine in the Search Bar,
you can change the search engine that Firefox uses.
To change your preferred search engine, press the search logo (at the
le of your Search Bar—Google by default) and choose the search engine of
your choice. Some search engines, such as Bing, Google and Yahoo, search
the whole web; others, such as Amazon and Wikipedia, search only speciﬁc
sites.
Searching the web for words selected in a web page

Sometimes, you may want to search for a phrase that you see on a web
page. You can copy and paste the phrase into the Search Bar, but there is a
quicker way.
. Highlight the word or phrase in a web page using your le mouse button.
. Right-click the highlighted text and select Sear [Sear Engine] for
[your selected words].
Firefox passes the highlighted text to the search engine, and opens a new
tab with the results.

Figure 3.8: These are the other search engines
you can use—by default—from the Firefox
search bar.

  

Searching within a page

Figure 3.9: You can search within web pages
using the Find Toolbar.

You may want to look for speciﬁc text within the web page you are
viewing. To ﬁnd text within the current page in Firefox:
. Choose Edit ‣ Find or press Ctrl+F to open the Find Toolbar at the
boom of Firefox.
. Enter your search query into the Find ﬁeld in the Find Toolbar. e
search automatically begins as soon as you type something into the ﬁeld.
. Once some text has been matched on the web page, you can:
‣ Click on Next to ﬁnd text in the page that is below the current cursor
position.
‣ Click on Previous to ﬁnd text that is above the current cursor position.
‣ Click on Highlight all to highlight all occurrences of your search
words in the current page.
‣ Select the Mat case option to limit the search to text that has the
same capitalization as your search words.
To quickly ﬁnd the same word or phrase again, press F3.
You can skip opening the Find Toolbar altogether.
. Turn on the relevant Accessibility option with Edit ‣ Preferences ‣
Advanced ‣ General ‣ Accessibility ‣ Sear for text when I start typing ‣ Close.
. Now, provided your cursor is not within a text ﬁeld, when you start
typing, it will automatically start searching for text.
Viewing web pages full screen

To display more web content on the screen, you can use Full Screen mode.
Full Screen mode hides everything but the main content. To enable Full
Screen mode, choose View ‣ Full Screen or press F11. While in full-screen
mode, move your mouse to the top of the screen to reveal the  and
search bars.
Press F11 to return to normal mode.
Copying and saving pages

With Firefox, you can copy part of a page so that you can paste it elsewhere,
or save the page or part of a page as a ﬁle on your computer.
Copying part of a page

To copy text, links or images from a page:
. Highlight the text and images with your mouse.
. Right-click the highlighted text and select Copy, or press Ctrl+C.
To copy just a single image, it is not necessary to highlight it. Just rightclick the image and select Copy.
You can paste the results into another application, such as LibreOﬃce.
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Copying a link

To copy a text or image link () from a page:
. Position the pointer over the text, link or image. Your mouse pointer
changes to a pointing ﬁnger.
. Right-click the link or image to open a pop-up menu.
. Select Copy Link Location.
You can paste the link into other applications or into Firefox’s Location
Bar.
Saving all or part of a page

To save an entire page in Firefox:
. Choose File ‣ Save Page As from the top bar, or press Ctrl+S. Firefox
opens the “Save As” window.
. Choose a location for the saved page.
. Type a ﬁle name for the page.
. Press Save.
To save an image from a page:
. Position the mouse pointer over the image.
. Right-click the image and select Save Image As. Firefox opens the “Save
Image” window.
. Choose a location for the saved image.
. Enter a ﬁle name for the image.
. Press Save.
Changing your home page

Firefox shows the home page when it opens. By default, this is the Ubuntu
Start Page. You can change your default home page to a new one, or even to
several new ones.
Figure 3.10: Change Firefox settings in this
window.

To change your home page:

  

. Navigate to the page that you would like to become your new home
page. If you want Firefox to open more than one tab when it starts, open
a new tab and navigate to the extra page as many times as you would
like.
. Choose Edit ‣ Preferences ‣ General ‣ Startup ‣ Use Current Pages ‣
Close.



The home page can also be set by entering the
addresses that should be open in the Home
Page, with a pipe (“|”) separating pages to be
opened in separate tabs.

Download settings

In Edit ‣ Preferences ‣ General ‣ Downloads, you can hide or show the
Downloads window, tell Firefox where to place downloaded ﬁles, and
whether or not to ask where each time.
Bookmarks

When browsing the web you may want to come back to certain web pages
again without having to remember the . To do this, you bookmark each
page. ese bookmarks are saved in the web browser, and you can use them
to re-open to those web pages.
Bookmarking a page

Aer navigating to a web page you can save its location by bookmarking it.
ere are two ways to bookmark a page:
‣ From the top bar, choose Bookmarks ‣ Bookmark is Page, or press
Ctrl+D. A window opens, allowing you to provide a descriptive name for
the bookmark and a location (within the browser’s bookmarks) to save it.
Press Done to save.
‣ Press the star on the right-hand side in the Location Bar. It turns yellow.
is saves the page in the Unsorted Bookmarks folder.
Navigating to a bookmarked page

To navigate to a bookmarked page, open the Bookmarks menu from the top
bar, and choose your bookmark. Firefox opens the bookmark in the current
tab.
You can reveal the bookmarks, including the Unsorted Bookmarks, in a sidebar
on the le of the browser window. Select View ‣ Sidebar ‣ Bookmarks, or press
Ctrl+B. Repeat, or press the close button at its top, to hide the sidebar.

Deleting or editing a bookmark

To delete or edit a bookmark, do one of the following:
‣ If you are viewing the page already, the star in the Location Bar will be
yellow. Press it. Firefox opens a small pop-up window, where you can
either Remove Bookmark or edit the bookmark.
‣ Select Bookmarks ‣ Show All Bookmarks or press Shift+Ctrl+O. In
the window that opens, you can navigate to bookmarks. Select the one
you would like to change. To delete, right-click and choose Delete or
press Delete on your keyboard. To edit, change the details shown at the
boom of the window.

The Downloads window shows the progress
of currently downloading ﬁles, and lists ﬁles
downloaded in the past. It can be used to open
or re-download ﬁles.
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History

Whenever you are browsing the web, Firefox saves your browsing history.
is allows you to come back to a web page that you have recently visited
without needing to remember or bookmark the page’s .
To see your most recent history, open the History menu from the top
bar. e menu displays several of the most recent web pages that you have
viewed. Choose one of the pages to return to it.
To view the complete history, either:
‣ Select View ‣ History or press Ctrl+H to view the history in a sidebar;
this replaces the bookmarks sidebar if it is open. (Repeat, or press the
close button at its top, to hide the sidebar.)
‣ Select History ‣ Show All History or press Shift+Ctrl+H to view the
history in a pop-up window.
Your browsing history is categorized as “Today,” “Yesterday,” “Last 
days,” “is month,” the previous ﬁve months by name, and ﬁnally “Older
than  months.” If history for a category does not exist, that category will
not be listed. Select one of the date categories in the sidebar to expand it
and reveal the pages that you visited during that time. Once you ﬁnd the
page you want, select it to re-display it.
You can also search for a page by its title or . Enter a few leers
from one or more words or, optionally, the  in the Sear ﬁeld at the
top of the history sidebar. e sidebar displays a list of web pages matching
your search words. Select the page you want. (You can even do this in the
Location Bar, saving you from having to open the History sidebar or pop-up
window.)
Clearing private data

Firefox stores all its data only on your computer. Nevertheless, if you share
your computer, you may at times want to delete all private data.
Select Tools ‣ Clear Recent History or press Shift+Ctrl+Delete. Choose
your Time range to clear, and under Details which items to clear, and press
Clear Now.
Preventing Firefox from recording private data

You can start “private browsing,” where Firefox will not record anything
permanently. is lasts until you turn it oﬀ or until you restart Firefox.
Choose Tools ‣ Start Private Browsing or press Shift+Ctrl+P. Press the
buon Start Private Browsing to conﬁrm. As long as you remain in this
mode, Firefox will not record browsing, download, form or search history,
or cookies, nor will it cache ﬁles. However, if you bookmark anything or
download ﬁles, these will be retained.
Repeat Tools ‣ Start Private Browsing or Shift+Ctrl+P, or restart Firefox, to end private browsing.
Using a diﬀerent web browser

If you choose to install a diﬀerent web browser on your computer, you
may want to use it as the default browser when you click links from
emails, instant messages, and other places. Canonical supports Firefox
and Chromium (Google’s Linux version of Chrome), but there are several
others that you can install.

  

Figure 3.11: The Default Applications where
you can change your preferred browser.

To change your preferred web browser, open Session Indicator from the
top panel on the far right-hand side, and open System Settings ‣ Details ‣
Default Applications. Choose your preferred web browser from the dropdown menu Web.
Reading and composing email
Introduction to Thunderbird

underbird is an email client developed by Mozilla and is easy to setup and
use. It is free, fast, and comes packed full of useful features. Even if you are
new to Ubuntu and underbird, you will be up and running in no time,
checking your email and staying in touch with friends and family.
Setting up Thunderbird

In the top right corner of the Ubuntu desktop you will see an envelope
icon in the notiﬁcation area. is is the messaging menu. From here, you
can launch underbird by clicking set up mail. Alternatively, you can
click the Ubuntu buon in the top le corner of the screen at the top of the
Launcher to bring up the Dash and type thunderbird into the search box.
Once underbird opens, you will be greeted by a pop-up box prompting
you to setup your email account.
Figure 3.12: Setting up Thunderbird

Enter your name in the ﬁrst text box, your email address in the second
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text box (for example, username@domain.com), and your email password in
the third text box.
Once completed, click the continue buon. underbird will automatically set up your email account for you. When underbird ﬁnishes
detecting your email seings, click create account and underbird will
do the rest. You can also set underbird as your default news and 
reader by checking the boxes in the pop-up box that appear aer you click
create your account. If you don’t want to see this message box every time
you start underbird, simply deselect Always perform this e when
starting underbird. You are now ready to start using underbird.
Around the Thunderbird workspace

Now that you have your email account set up, lets get to know the underbird workspace. underbird is designed to be very user-friendly and
easy to navigate. When you open the application, you will see the main
workspace with your email folders (all folders window) on the le. On the
right of the screen, you will see two windows. e top-right window displays a list of your received email, and the boom-right window displays
the current email you are viewing. e size of these windows can be easily
resized to suit your viewing environment. To resize the windows, simply
le-click and hold the dividing bar that separates the two windows and drag
the bar up or down to the desired position. e All Folders window is where
you can see your mail folders. is window can also include:
Inbox Where your email is stored and accessed
Email address folder You will see one of these folders for each of the accounts you have setup
Dras Where your dra emails are stored
Sent mail Where the emails you have sent are stored
Spam is is where suspected spam email is stored so you can check them
to make sure you haven’t lost any important emails
Trash is is where messages you’ve deleted are stored so you can double
check to make sure you haven’t accidentally deleted an important email
(also one of the local folders)
Important is is where emails you have marked as important are stored
Starred is is where emails you have marked with a star are stored
Personal is is where emails you have marked as personal are stored
Receipts You can move important receipts to this folder.
Travel You can use this folder to store travel emails such as ﬂight times and
bookings
Work You can store work emails in this folder to keep them separate from
your personal email
Outbox Where the emails you are in the process of sending are stored (also
one of the local folders)
Across the top of the underbird workspace, you will see four control buons, get mail, write, address book, and tag. ese are used to get
your mail, write your mail, access your address book, and tag your email
messages.
At the top-right of the All Folders window, you will see a set of quick
ﬁlter buons, unread, starred, contact, tags, andattament. You can use
these buons to ﬁlter your email messages so that you only see your unread
mail, your favorite mail (starred), mail from people in your address book,
mail you have tagged, and mail that includes aachments.

  

If you are accustomed to a more traditional desktop and you have underbird maximized to full screen, you might be wondering where the menus
are located. ey are still there, and if you want to access them, move your
mouse to the top of the screen and you will see the familiar menus: ﬁle,
edit, view, go, message, tools, and help.
At the top of the window that displays your email, you can see ﬁve
action buons, reply, forward, arive, junk, and delete. You will ﬁnd
these very useful for quickly replying to email, forwarding your email to
another person, archiving (backing up) your email, marking an email as
junk mail, and quickly deleting an email. To the le of these quick action
buons, you will see information about the email you are viewing that
includes the sender’s name, the subject of the email, the reply address, and
the recipient of the email.
Using your address book

At the top of the main workspace, you will see the address book buon.
Click this buon to access your address book. Once the address book opens
you, will see the address book window. From here, you can easily organize
your contacts. At the top of the address book window, you will see ﬁve
buons, new contact, new list, properties, write, and delete. ey function
in the following ways:
New Contact is buon allows you to add a new contact and add as much
detail as you wish to save, including name, nickname, address, email,
additional email, screen name, work number, home number, fax, pager
and mobile/cell number.
New List is buon allows you to add lists for your contacts such as
family, friends, acquaintances, etc.
Properties is buon allows you to rename your address book name. e
default name is personal address book, but you can change the name as
you see ﬁt.
Write is buon allows you to quickly send an email to a selected contacted without needing to go back to the main underbird workspace.
Simply select a contact from your contacts list and click the write buon
to send them an email.
Delete is buon allows you to quickly delete a contact from your address
book. Just select the contact you want to delete and press delete to
remove the contact from your address book.
Checking and reading messages

underbird will automatically check your email account for new messages every ten minutes, but if you need to manually check for new messages at any time, le-click the get mail button in the top le corner of the
workspace. underbird will then check your email account for new messages and download them. As they are downloaded, you will see the new
email appear in the message window on the right side of the workspace.
When you click on one of your emails, it will appear in the window below
your email list. If you want to view your email in a full window, doublele-click your chosen email, and underbird will display the email in a
full window in its own tab. At the top of the open email, you will see information about the email and the ﬁve quick action buons, reply, forward,
arive, junk and delete as previously discussed. If an email has remote
content, you will see a message asking if you want to display the email or
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not. You may want to ﬁlter your emails from time to time; this is easily
done with underbird. When you have an email selected and you want
to tag the email, simply click the tag buon and a drop down list will be
displayed. In this drop down list, you have the options to Remove All Tags
or Mark as…, Important, Work, Personal, To Do, Later. You can also create
a new tag more suited to your own personal requirements.

Remote content represent parts of an email
that may be hosted elsewhere. Remote content
might consist of video or audio, but most
often is graphics or HTML content. For security
purposes, Thunderbird will as you if you wish to
view this remote content.

Composing and Replying to Messages

To compose a new email message, click the write buon in the top le of
the workspace. is will bring up a new window where you can compose
your new email. In the To: ﬁeld, enter the email address of the destination
—the contact to whom you are sending this email. If there is more than one
contact to whom you are writing, separate multiple recipients with commas.
If a contact that you are addressing is in your address book, you can address
them by name. Start typing the name of the contact; underbird will display the list of mailing contacts below your text. Once you see the contact
you intend to address, click on their email address or use the down arrow
key and then press Enter to select the address. If you would like to carboncopy (Cc) some contacts, click the To: ﬁeld and select Cc:. Contacts who are
listed on the To: and Cc: lines will receive the email, and will see the rest of
the contacts to whom an email was sent. If you would like to send an email
to some contacts without disclosing to whom your email was sent, you can
send a blind carbon-copy, or Bcc. To enable Bcc, select Bcc: by clicking the
To: ﬁeld and selecting Bcc:. Any contacts entered in the Bcc: ﬁeld will receive the message, but none of the recipients will see the names or emails of
contacts on the Bcc: line. Instead of typing the email addresses or names of
the contacts you are addressing in the message, you can select the contacts
from your address book. Start typing a few leers from your contact’s ﬁrst
or last name in the To: ﬁeld to ﬁlter the list to only show mailing contacts.
Once you identify the contact you would like to address, click on their name
in the list. If you’ve added the contact in error, delete their address and
enter the correct address. You may enter a subject for your email in the Subject ﬁeld. Messages should have a subject to help the recipient identify the
general contents of the email while glancing at their message list. Enter the
contents of your message in the big text ﬁeld below the subject. ere is no
practical limit on the amount of text you can include in your message. By
default, underbird will auto-detect the correct format for your email but
you can change this by clicking Options then mouse over Format and select
your preferred option from the list. You have a choice of Auto-Detect, Plain
Text Only, Rich Text (HTML) Only, and Plain and Rich (HTML) Text. When
you have ﬁnished composing your email, click on the Send buon on the
window’s toolbar. Your message will be placed in the Outbox, and will be
sent to your desired recipient.

If you do not include a subject in your email,
Thunderbird will warn you about this omission.

Attaching ﬁles

At times, you may want to send ﬁles to your contacts. To send ﬁles, you
will need to aach them to your email message. To aach a ﬁle to an email
you are composing, click on the Atta buon. When the new window
opens, select the ﬁle you want to send and click open. e ﬁle you selected
will then be aached to the email when you click send.

You can attach quite a few diﬀerent ﬁle types
to emails, but be careful about the size of the
attachments! If they are too big, some email
systems will reject the email you are sending,
and your recipient will never receive it!

  

Replying to Messages

In addition to composing new messages, you may want to reply to messages
that you receive. ere are three types of email replies:
Reply or Reply to Sender sends your reply only to the sender of the message
to whom you are replying.
Reply to All sends your reply to the sender of the message as well as any
address in To: or Cc: lines.
Forward allows you to send the message, with any additional comments
you may add, to some other contacts.
To use any of these methods, click on the message to which you want
to reply and then click the Reply, Reply to All, or Forward buon on the
message toolbar. underbird will open the reply window. is window
should look much like the window for composing new messages, but the
To:, Cc:, Subject:, and main message content ﬁelds should be ﬁlled in from
the message to which you are replying. Edit the To:, Cc:, Bcc:, Subject: or
main body as you see ﬁt. When your reply is ﬁnished, click on the Send
buon on the toolbar. Your message will be placed in the Outbox and will
be sent.
Using instant messaging

Instant messaging allows you to communicate with people in real time
online. Ubuntu includes the Empathy application that lets you use instant
messaging features to keep in touch with your contacts. To start Empathy,
open the Messaging Menu (the envelope icon on the menubar), then select
Chat.
Empathy lets you connect to many instant messaging networks. You
can connect to: Facebook Chat, Google Talk, Jabber, People Nearby, ,
Gadu-Gadu, Groupwise, , , , mxit, myspace, , sametime, silc,
, , Yahoo!, and Zephyr.
Running Empathy for the ﬁrst time

When you open Empathy for the ﬁrst time you will need to conﬁgure it
with the details of your instant messaging accounts.
When Empathy starts you will see the “Welcome to Empathy” window.
Choose the option corresponding to your situation.
You have a previous account

If you have an account that you have used previously with another instant
messaging program, then select the Yes, I’ll enter my account details now
option. en, click Forward to continue.
On the next screen, choose your account type from the drop-down list
below What kind of at account do you have?. en, enter your account
details in the ﬁeld below.
Depending on the account type that you choose, Empathy may request
that you enter a username, or an  for your account, followed by a password.
If you do not remember your account information, you will need to visit
the website of the instant messaging service to retrieve that information. (It
is suggested that you visit the web sites where you have instant messenger
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Figure 3.13: Creating a new instant messenger
account in Empathy.

accounts, before you start Empathy, so you can gather all of the credentials
for each account.)
If you have another account to add then select the Yes option, and click
Forward to repeat the above process. When you have entered all of your
accounts leave the No, that’s all for now option selected, and click Apply to
ﬁnish the setup process.
Next, Empathy should display the “Please enter personal details” screen.
If you choose to ﬁll in this information, you will be able to communicate
with people who are on your local network either at home or from the
oﬃce.
Enter your ﬁrst name in the First name ﬁeld, and your last name in
the Last name ﬁeld. Enter a nickname that you want to use on your local network in the Niname ﬁeld. When you have completed all of the
information, click Apply.
If you don’t want to communicate with people on your local network,
select the I don’t want to enable this feature for now option, and click
Apply.
You do not have a previous account

If you don’t have an account that you can use, then you can create one by
selecting the No, I want a new account option. Click Forward to display
the next set of options.
Choose the account type that you would like to create from the dropdown list below What kind of at account do you want to create? You
can create either a Jabber or a Google Talk account.
Next, enter the account name that you would like in the text ﬁeld, and in
the following text ﬁeld enter a password of your choice. If you would like
to set up another account then select the Yes option, and repeat the above
process.
When you have entered all the accounts leave the No, that’s all for now
option selected, and click Forward.
Empathy should display the “Please enter personal details” window.
Providing this information allows you to communicate with people who are
on your local network either at home or in the workplace.
Enter your First name in the text ﬁeld, and enter your Last name in the
next ﬁeld. In the Niname ﬁeld enter a nickname by which you would like
to be identiﬁed. When you have ﬁlled all of the text ﬁelds click Apply to
save your seings.
If you don’t want to talk to people on your local network then select the
I don’t want to enable this feature for now option and click Apply.

Note: If you wish to create a type of account
other than one of these, then you will need
to visit the relevant website and create the
account ﬁrst. Then follow the instructions in
the “You have an account” section.

  

You want to talk to people nearby

If you would only like to communicate with people on your local network
either at home or in the workplace, then you should select the No, I just
want to see people online nearby for now option.
Click Forward to display the next set of options. en enter your First
name in the text ﬁeld, and enter your Last name in the next ﬁeld. In the
Niname ﬁeld enter a nickname by which you would like to be identiﬁed.
When you have ﬁlled all of the text ﬁelds, click Forward.
Figure 3.14: You can talk to people nearby by
entering your information.

Changing account settings

If you need to add more accounts aer the ﬁrst launch, open the Edit menu,
then select Accounts. Empathy will then display the “Accounts” window.
Adding an account

To add an account click on the + buon on the boom le of the “Accounts”
window. Empathy should display some options on the right-hand side
of the window. Choose your account type from the Protocol drop-down
list. Next, enter your account name in the ﬁrst text ﬁeld. en enter your
password in the Password text ﬁeld. Finally click on the Log in buon to
save and verify your seings.
Editing an account

You might need to edit an account if you change the password or get the
password wrong. Fortunately, this is very easy to do. Select the account you
want to change on the le side of the “Accounts” window. Empathy should
show the current information for the account. Once you have made your
changes, click Save.
Removing an account

To remove an account select the account on the le hand side of the window and click on the - buon. Empathy should open the “Do you want to
remove” window. Click on the Remove buon to conﬁrm that you want to
remove the account, or click Cancel to keep the account.
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Editing contacts
Adding a contact

To add a contact open the Chat menu, then select Add contact. Empathy
should open the “New Contact” window.
In the Account drop-down list, choose the account that you want to add
the contact to. When creating a contact you must select the service that
matches the service your contact is using.
For example if your contact’s address ends in “@googlemail.com” then
you will need to add it to an account that ends in “@googlemail.com.”
Likewise if the contact’s email ends in “@hotmail.com” then you will need
to add it to an account ending in “@hotmail.com.”
Aer choosing the account you wish to add the contact to, enter their
login , their username, their screen name or their email address in the
Identiﬁer text ﬁeld. Next, in the Alias text ﬁeld, enter the name you want to
see in your contact list. Click Add to add the contact to your list of contacts.
Removing a contact

Click on the contact that you want to remove, then on the Unity bar at the
top of the screen, open the Edit menu, select Contact, then Remove. is
will open the “Remove contact” window.
Click on the Remove buon to conﬁrm that you want to remove this
contact, or click Cancel to keep the contact.
Communicating with contacts
Text

To communicate with a contact, select the contact in Empathy’s main window and double-click their name. Empathy should open a new window
where you can type messages to your contact, and see a record of previously exchanged messages.
To send a message to the contact, enter your message in the text ﬁeld below the conversation history. When you have typed your message press the
Enter key to send the message to your contact. If you are communicating
with more than one person then all of the conversations will be shown in
tabs in your Empathy window.
Audio

If your contact has audio capabilities then there will be a microphone icon
next to their name. Click on the microphone icon to open the popup menu.
Select the Audio call option from the menu. Empathy should then open the
“Call” window.
is window shows your picture on the right and your contact’s picture
on the le. Ensure that your microphone and speakers are connected, and
proceed with the audio conversation. You can ﬁnish the conversation by
clicking on the Hang up buon.
Video

If your contact has video chat capabilities then there will be a webcam icon
next to their name. Click on the icon to open a popup menu. Select the
Video call option from the menu. Empathy should then open the “Call”

  

window. is window shows your webcam view in the top right and your
contact’s webcam will be in the middle. If you don’t have a webcam then
your picture will be shown instead. You can ﬁnish the call by clicking on
the Hang up buon.
Sending and receiving ﬁles
Sending a ﬁle

When you are in a conversation with a contact and you would like to send
them a ﬁle, open the Contact menu, then select Send ﬁle. Empathy should
open the “Select ﬁle” window. Find the ﬁle you wish to send, and click on
the Send buon. A “File Transfers” window will open showing the ﬁle and
its transfer progress. When the ﬁle transfer is complete, you can close the
“File Transfers” window.
Receiving a ﬁle

When a contact wants to send you a ﬁle, the status icon to the le of the
contact’s name will ﬂash with an icon of a paper plane. To receive the ﬁle,
double-click the contact’s name. Empathy will open the “Select a destination” window. Choose the location where you would like Empathy to save
the ﬁle, and click Save. Empathy should open the “File Transfers” window.
e “File Transfers” window shows you the progress of current ﬁle transfer.
You can stop the ﬁle transfer by clicking on the Stop buon, open transferred ﬁles by clicking on the Open buon, and clear the list of completed
transfers by clicking on the Clear buon.
Changing your status

You can use your status to show your contacts how busy you are or what
you are doing. You can use the standard statuses, which are:
‣
‣
‣
‣
‣

Available
Busy
Away
Invisible
Oﬀ-line

ese can be changed in one of two ways. e ﬁrst method is in the
main Empathy window from the drop-down list at the top of the window.
e same drop-down list lets you set a custom status by choosing “Custom Message…” next to the icon that matches your status. Enter what you
would like your status to say, and click on the green check mark.
e second method is to click the Messaging Icon on the top Unity
Bar. >From this menu, you will see all of the same options that Empathy
presents, but accessible without having to open the application window.
Changing your picture

Your picture is what your contacts will see next to your name in their contact list. e default picture is the outline of a person. You can change your
picture by opening the Edit menu, then choosing Personal Information.
Empathy should open the “Personal Information” window. From the Account drop-down list choose the account that you want to change, then
click on the picture on the right-hand side of the window. Empathy should
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open the “Select Your Avatar Image” window. Find the ﬁle containing your
picture, and click Open. If you would like to return it to the default avatar,
click on the No Image buon, instead.
Desktop Sharing

Desktop sharing is a very niy feature available with Ubuntu. It can be used
for a lot of purposes like troubleshooting, online meetings or just showing
oﬀ your cool desktop to your friend. It is very easy to get remote desktop
sharing working between two Ubuntu machines.
. Click on System ‣ Preferences ‣ Remote Desktop and select Allow remote desktop. It is strongly recommended you add a password, for
security reasons.
. Open Empathy and login using your Google/Jabber client 
. Double click on the user with whom you want to share your desktop
. From the new window, click on Contact ‣ Share your desktop.
It should be noted that the other user will obviously be able to see the
information displayed on your screen. Please be sure to keep this in mind
if you have documents or ﬁles that are of a private nature open on your
desktop.
Microblogging

Gwibber is the default microblogging application that lets you access
multiple social networking accounts, without having to open an Internet
browser. Gwibber can be used to access and post on Twier, Facebook,
Identi.ca, Ping.fm, Flickr, Digg, Status.net, Foursquare, Qaiku and FriendFeed.
Upgrades and add-ons

Before you begin using Gwibber, go to Ubuntu Soware Center and search
for Gwibber. Select Gwibber; press More Info; check each add-on that you
want (or just select all of them); and press Apply Changes. You need addons for Ping.fm, Flickr, Digg, Status.net, Foursquare, Qaiku and FriendFeed.
Wait for the them to ﬁnish installing. You need to log out and in again to
activate the add-ons.
Working with social networking accounts on Gwibber

Pull down the Message menu from the top panel bar and select Broadcast.
is starts the app.
If you have not previously entered an account, the Accounts Manager
will open automatically. Otherwise, select Edit ‣ Accounts to open it.
To add a new account, select the + buon; select the account type (e.g.,
Facebook, Twier); select Add. Select account seings and Authorize; and
follow any instructions to authorize the account.
Removing accounts from Gwibber is easy too. Go to the Accounts Manager window and select the account to be removed. Click the - buon to
remove the account.

You can add more than one account from a
service provider.

  



Figure 3.15: Use the Ubuntu Software Center to
to get Gwibber add-ons.

Figure 3.16: The Gwibber pull-down menu
shows you a quick overview of your feeds.

Figure 3.17: Add an account for use with
Gwibber using the Accounts Manager.

Using Gwibber to follow streams

Gwibber displays feeds from each service provider as streams. You can
list them in either ascending or descending order by selecting View ‣ Sort.
You can separate the feeds as messages, replies, and private messages. In
addition the aachments from the feed are sorted as images, links and
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videos. Click the image, link or the video to take you to the website in a
new tab in your default browser; images can be previewed within Gwibber.
Figure 3.18: A stream in Gwibber. Clicking on
the image should open the Facebook page in a
browser.

Notiﬁcations

You can customize how feeds display in the notiﬁcation bubble, and the frequency with which Gwibber refreshes, in the preferences (Edit ‣ Preferences).
Figure 3.19: A notiﬁcation from Gwibber.
Notiﬁcations can be customized from the
Gwibber Preferences menu.

Replying, Liking and Retweeting

Each tweet can be liked, retweeted or replied from within Gwibber’s window by clicking on the Twier icon at the top right of each post.
Updating your Status

To update your status using Gwibber, select Update Status from the message icon in the top panel; this opens a new window. Type your status
message and post it to all your accounts with one click. Press Esc to cancel.
You can customize each account in Gwibber to have its own color. You can also
shorten URLs as you post from Gwibber using a list of URL shortening services.
Play with Gwibber and discover other cool things it can do. Open http://gwibber.
com/docs/user-guide/current/master_social_networking_with_gwibber.pdf for
more information.

You can prevent an account from posting from
Gwibber; Edit ‣ Accounts ‣ Account Settings.

  



Figure 3.20: You can similarly “like” or comment
on updates from within Gwibber.

Viewing and editing photos

Shotwell Photo Manager is the default photo application in Ubuntu. is
application allows you to view, tag, edit, and share your photos. To start
Shotwell, click on the Ubuntu icon near the top-le of the screen, then
select the Shotwell icon labeled View Photos.
Figure 3.21: Manage your photo collection,
enhance your photos while keeping the original,
and share your memories online using Shotwell
Photo Manager.

Importing Photos

When you launch Shotwell for the ﬁrst time, you will be greeted by the
“Import” window. Aer the ﬁrst launch, you can import more photos by
dragging the photos into the Shotwell window. You can also import photos
by connecting your camera or external storage device to the computer.
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From a digital camera Connect your camera to the computer using the
data cable and power it on. If your camera is properly detected, you will
see a new window prompting you to launch an application. Select Shotwell
in the drop-down menu then click OK. Your camera will be listed in the
Shotwell sidebar. Select your camera in the sidebar. You will see a preview
of the camera’s contents. Select individual photos by pressing and holding
Ctrl and clicking on each photo you want to import, and then clicking
Import Selected on the boom bar of the window. Or, you can choose to
import all photos by clicking Import All.
From your computer You can import photos into Shotwell by dragging
photos from your ﬁle browser into the Shotwell window. Alternatively, you
can click File Import From Folder, ‣ select the folder containing the photos
you want to import.
From external hard drive,  ﬂash drive, or / Importing photos from
external storage is similar to importing from your computer. Your external
storage device may also appear under the Camera label on the Shotwell
sidebar. Follow the instructions for importing from a camera or computer.
Choosing where Shotwell saves photos

e default location for the Shotwell Library is your Pictures folder. When
importing pictures in the “Import” window, you will be given the option to
copy the ﬁles to your Library, or keep the ﬁles in place.
If you have your photos stored on your computer, the option Import
in Place will be suitable so photos aren’t duplicated. If you are importing
photos from an external source, such as a portable hard drive,  ﬂash
drive, or /, you should select Copy into Library so the photos are
copied to your computer—otherwise they won’t appear when you remove
the external source.
Viewing photos

Choose Library or any collection in the sidebar to display photos from
your selection. Use the slider on the boom bar to adjust the size of the
thumbnails. To view a full-window image, double-click an individual photo.
In the full-window view, you can navigate through the collection using
the back and forward arrows, zoom on the image using the slider, pan by
clicking and dragging the image, and exit the full-window view by doubleclicking the image.
To view the collection in full-screen mode, press F11 or go to View ‣
Fullscreen. You can navigate through the collection using the toolbar that
is available by moving your mouse to the boom of the screen. To view a
slideshow presentation of the collection, press F5 or go to View ‣ Slideshow.
Press the Esc key to exit the Fullscreen or Slideshow views.
Organizing photos

Shotwell makes ﬁnding photos of the same type easier by using tags. You
can apply as many tags to a photo as you like. To apply tags to photos,
ﬁrst select the photos. en right-click on the photos and select Add Tags.
Enter the tags you want into the text ﬁeld, separated by commas. If you are

  

adding new tags, these will appear in the side bar on the right under the
Tags label.
Editing images

You may want to edit some of the photos you import into Shotwell. For
example, you may want to remove something at the edge, adjust the color,
reduce the red-eye eﬀect, or straighten the image. To edit a photo, doubleclick on the photo that you want to edit and then click on one of the following buons:
Rotate

Click Rotate to rotate the image ° clockwise. You can click the buon
more than once and it will rotate the image clockwise in ° intervals.
Crop

Click Crop to change the framing of the photo. e image will darken and a
selection will appear. Adjust the selection to your desired crop by dragging
a corner or side. If you want to choose a speciﬁc aspect ratio, use the dropdown menu to select one of the preset ratios or enter your own custom
ratio. A pivot buon is provided to change your selection from landscape to
portrait and vice versa. Once you are happy with the selection, click OK to
apply the crop or Cancel to discard it.
Red-eye reduction

If you have taken a photo and the ﬂash has caused the subject to have red
eyes, you can ﬁx this problem in Shotwell.
Click the Red-eye buon. A circle will appear.
Drag this circle over one of the subjects eyes and then use the slider to
adjust the circle size.
When the circle is over the eye, click Apply to ﬁx the red eye. You will
need to repeat this for each individual eye. Use caution when adjusting
the size of the circle. A circle too large and covering the skin may cause
discoloration when applying the red-eye reduction.
Adjust

Clicking Adjust will bring up a window that lets you edit a few things:
Level Similar to contrast
Exposure How bright the image is
Saturation How colorful the image is
Tint e overall color
Temperature Whether the image is warm (more yellow) or cool (more blue)
Shadows How dark the shadows are
To change these values, drag the sliders until you are satisﬁed with the
image. Click OK to apply the changes, Reset to undo the changes and start
over, or Cancel to discard the changes.
Auto-adjustment with Enhance

Click Enhance to let Shotwell automatically adjust the color, levels, exposure, contrast and temperature to make a more pleasing image.





    .

Reverting an edited photo to the original

When you edit a photo in Shotwell, your original image remains untouched.
You can undo all of the changes and revert to the original version by rightclicking on the photo, then selecting Revert to Original. is option is only
available for photos you have edited.
Sharing your photos

You can easily share your photos on the web using Shotwell’s Publish
feature. Select the photos you want to share, then click the Publish buon
located on the boom bar. Choose Facebook, Flickr, or Picasa Web Albums
in the drop-down menu and log-in with your credentials. Some services
may require you to authorize Shotwell before allowing the application to
publish photos. Follow the instructions on the window, select your desired
options, and click Publish to upload your images to the web.
Further information

We’ve only just touched on the features of Shotwell. To get more help,
select Help ‣ Contents. is will load the online manual, where you can get
more detailed instructions on how to use Shotwell eﬀectively.
Watching videos and movies

To watch videos or s in Ubuntu, you can use the Movie Player application. To start the Movie Player, click on Dash, then search for “Movie
Player” and select it. is will open the “Movie Player” window.
Figure 3.22: Movie player (Totem) plays music
and videos.

Codecs

Watching s may require Ubuntu to install a “codec,” which is a piece of
soware that allows your computer to understand the contents of the ,
and display the video.
Legal Notice: Patent and copyright laws operate diﬀerently depending on which
country you are in. Please obtain legal advice if you are unsure whether a particular patent or restriction applies to a media format you wish to use in your
country.

  

So that you can play all videos and s, you will need to install some
codecs. ese are located within the Multiverse repository. is is now
enabled by default.
To install the codecs, open the Ubuntu Soware Center, either through
Dash or the Launcher. When the “Ubuntu Soware Center” window opens,
use the search box in the top right and search for the following:
‣ ubuntu-restricted-extras
‣ libdvdread
‣ libdvdnav
When you ﬁnd each one, select it with a double-click and then click the
Install buon. is may open an “Authenticate” window. If so, enter your
password then click Authenticate to start the installation process.
Playing videos from ﬁle

Open the Movie menu, then select Open…. is will open the “Select
Movies or Playlists” window. Find the ﬁle or ﬁles that you want to play
and click on the Add buon. e video or videos will start playing.
Playing a DVD

When you insert a  in the computer, Ubuntu should open the “You have
just inserted a Video . Choose what application to launch” window.
Make sure that Open Movie Player is chosen in the drop-down list and
then click OK. e “Movie Player” window will open and the movie will
start.
If the “Movie Player” window is already open, open Movie menu, then
select Play Disc… and the movie will start.
Listening to audio and music

Ubuntu comes with the Rhythmbox Music Player for listening to your
music, streaming Internet radio and managing playlists and podcasts.
Rhythmbox can also help you ﬁnd and purchase music, along with managing subscriptions to your favorite  feeds.
Starting Rhythmbox

ere are several ways to start Rhythmbox.
‣ Open the Dash, select Listen to Music, and choose any of the displayed
music ﬁles (if you have any).
‣ Open the Dash, type Rhythmbox and click on the Rhythmbox Music
Player icon.
‣ Ubuntu . comes with an indicator menu in the top bar for soundrelated applications and devices. is menu includes a link to start
Rhythmbox, and basic playback and volume controls.
If you close Rhythmbox by pressing Alt+F4 or clicking the red close buon
( ), it will disappear from view but continue to play in the background. You
can still control your music or reopen from the Sound indicator. To quit
Rhythmbox completely, press Ctrl+Q.
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Figure 3.23: Rhythmbox Music Player

Playing music

To play music, you must ﬁrst import music into your library. Choose Music ‣ Import Folder… or press Ctrl+O on your keyboard to import a folder
of media, a single ﬁle, an Amazon  purchase or media from an iOS or
Android device. e Rhythmbox toolbar contains most of the controls that
you will use for browsing and playing your music. If you want to play
a song, double-click a track or click it and press the Play buon on the
toolbar (you can also choose Control ‣ Play from the menubar or press
Ctrl+Space). When a song is playing, the Play buon will become a Pause
buon. Clicking on it will pause the song. Next and Previous buons are
next to the Play/Pause buon. You can click on these buons to play the
next and previous songs in your library or playlist. Rhythmbox also has
options to toggle Repeat or Shuﬄe modes. Rhythmbox oﬀers two diﬀerent types of shuﬄing, both of which can be accessed by clicking on the
drop-down menu next to Next buon or by using the global menubar
(Control ‣ Shuﬄe). Repeat controls are located in boom right hand corner
and through the global menubar (Control ‣ Repeat).
Playing Audio cds

To play your CD, insert it into your CD drive. It will automatically appear
within Rhythmbox in the Side Pane beneath your Music Library. You can
click the  (named Audio , or the name of the album) and double-click a
track in it to play the tracks on the .
Importing (Ripping) Audio cds

Begin by inserting a . Rhythmbox will automatically detect it and add
it to the side menu. If you have an active Internet connection, Rhythmbox
will try to ﬁnd the album details via the web. Click the . Uncheck any
tracks you don’t want imported. Press the Extract buon, located near the
upper-le corner of Rhythmbox. Rhythmbox will begin importing the .
As it ﬁnishes each track, it will appear in your Music Library.

  



Listening to streaming audio

Rhythmbox is pre-conﬁgured to enable you to stream audio from various
sources. ese include Internet broadcast stations (Radio from the Side
Pane), Last.fm and Libre.fm. To listen to an Internet radio station, click in
the Radio icon in the Side Pane for a list of pre-conﬁgured stations. You can
ﬁlter by genre in the middle pane. To add a new radio station, select Add
and enter the radio station .
Connect digital audio players

Streaming audio stations are “radio stations”
that broadcast over the Internet. Some of these
are real radio stations that also stream over the
Internet, and others broadcast only over the
Internet.

You can browse a selected list of radio stations
at http://en.wikipedia.org/wiki/List_of_
Internet_stations or you can use your browser
to search for “Internet radio stations.”

Rhythmbox can connect with many popular digital media players. Connected players will appear in the Devices list. Features will vary depending
on the player (and oen the player’s popularity), but common tasks like
transferring songs and playlists should be supported.
Figure 3.24: Rhythmbox connected to an
Android device

Listen to shared music

If you are on the same network as other Rhythmbox users (or most other
music player soware), you can share your music and listen to their shared
music. To do this, click Music ‣ Connect to DAAP Share… en enter the IP
address and the port number. en click OK. Clicking a shared library will
enable you to browse and play songs from other computers.
Manage podcasts

Rhythmbox can manage all of your favorite podcasts. Select Podcasts from
the Side Pane to view all added podcasts. e toolbar will display additional
options to Browse, Show All, Add and Update. Choose Add on the toolbar
and enter the URL of the podcasts to save it to Rhythmbox. Podcasts will be
automatically downloaded at regular intervals or you can manually update
feeds. Select an episode and click Play. You can also delete episodes.

DAAP stands for “Digital Audio Access Protocol,” and is a method designed by Apple Inc. to
let software share media across a network.
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View

Rhythmbox comes with the option of a party mode. To enter party mode
press F11 on your keyboard or use the global menubar (View ‣ Party Mode);
to exit from party mode press F11 again. Rhythmbox also has a browser
bar that is enabled by default (this area is the top-right half of the program
window). It gives you the option to search your music by artist (upperright) or album.
Rhythmbox preferences

e default conﬁguration of Rhythmbox may not be exactly what you want.
Choose Edit ‣ Preferences to alter the application seings. e Preferences
tool is broken into four main areas: General, Playback Music and Podcasts.
General includes how you want Rhythmbox to display artist and track
information. You can also adjust the columns visible in your library and
how the toolbar icons are displayed.
Playback options allow you to enable crossfading and the duration of the
fade between tracks.
Music includes where you would like to place your music ﬁles and the
library structure for new tracks added to Rhythmbox. You can also set
your preferred audio format.
Podcasts designates where podcasts are stored on your computer along
with the ability to change how oen podcast information is updated.
Plugins

Rhythmbox supports a wide array of plugins, which add functionality to
Rhythmbox. Many of the plugins provide basic audio playback, and you
may check a few more boxes, for example, to access the Magnatune Store.
To view or change the activated plugins, use the global menubar (Edit ‣
Plugins).
Managing your music

Rhythmbox supports creating playlists. Playlists either are static lists of
songs to be played in order, or can be smart playlists based on ﬁlter criteria.
Playlists contain references to songs in your library. ey do not contain
the actual songs, but only reference them. So, if you remove a song from
a playlist (right-cli on the song ‣ Remove from Playlist), the song will
remain in your library and on your hard drive.
To create a playlist, choose Music ‣ Playlist ‣ New Playlist, press Ctrl+N,
or right-click in the lower blank area of the side bar and select New Playlist.
It appears in the sidebar as “New Playlist.” Right-click and select Rename
to give the new playlist a name of your choosing. Drag songs from your
library to the new playlist in the side pane or right-click on songs and select
Add to Playlist and pick the playlist.
Smart Playlists are created in a similar way. Choose Music ‣ Playlist ‣
New Automatic Playlist or right-click in the lower blank area of the side
bar and select New Automatic Playlist. Deﬁne the ﬁlter criteria. You
can add multiple ﬁlter rules and select a name. Save. You can update any
playlist (including the predeﬁned ones) by right-clicking on the name and
choosing Edit.
Rhythmbox supports song ratings. Right-cli a song in your library ‣
Properties ‣ Details and click on the number of stars. To remove a rating,

  

select zero stars. Other song information such as Title, Artist and Album
can be changed. Right-cli a song in your library ‣ Properties ‣ Basic.
To remove a song, right-cli ‣ Remove. To delete a song from your hard
drive entirely, right-cli ‣ Move to the Rubbish Bin. If you ever want to
move a song, highlight the song (or group of songs) from your library and
drag it to a folder or to your desktop. is will make a copy of the audio ﬁle
in the new location.
Music stores

Rhythmbox has an integrated store that gives you access to a huge catalog
of music with a variety of licensing options. e Ubuntu One Music Store
(see ﬁgure below) sells music from global major and minor music labels.
e store oﬀers -free (no copy protection) songs encoded in high-quality
 format. You can browse the catalog, play previews, and buy songs with
the Ubuntu One Music Store. As the name suggests, the Ubuntu One Music
Store integrates with the Ubuntu One service. All purchases are transferred
to your personal cloud storage and are automatically copied to all of your
computers. For that reason, an Ubuntu One account is required (it is free of
charge and quick to register). e catalog of music available for purchase
will vary depending on where you live in the world. More information
about the Ubuntu One Music Store can be found at https://one.ubuntu.com/
music/.
Figure 3.25: Ubuntu One Music Store

Audio codecs

Diﬀerent audio ﬁles (, , , , etc.) require unique tools to decode them and play the contents. ese tools are called codecs. Rhythmbox
aempts to detect any missing codecs on your system so you can play all of
your audio ﬁles. If a codec is missing, it automatically tries to ﬁnd the codec
online and guides you through its installation.
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Rhythmbox support

Rhythmbox is used by many users throughout the world. ere are a variety of support resources available in many languages.
‣
‣
‣
‣

Help ‣ Contents or F1 for the main help.
Help ‣ Get Help Online to ask questions and report bugs.
e Rhythmbox website http://www.rhythmbox.org/.
e Multimedia & Video category of Ubuntu Forums: http://ubuntuforums.
org/forumdisplay.php?f=

Burning CDs and DVDs

To create a  or  open the Dash and search for Brasero Disc Burner,
then open Brasero. is opens Brasero, which gives you ﬁve burning options. Each one of these is explained below.
Figure 3.26: Brasero burns music, video, and
data DVDs and CDs.

Getting Started

Before you can use Brasero, you need to Create a new project. ere are
three types of projects available: Audio Project, Data Project, and Video
Project. Make your selection based on your requirements.
e following options apply for all projects except Disc copy and Burn
Image.

At this current time, Brasero does not support
Blu-Ray.

Adding ﬁles to a project

To add ﬁles to the list, click the Green + buon, which opens the “Select
Files” window. en navigate your way to the ﬁle you want to add, click the
desired ﬁle, and then click the Add buon. Repeat this process for each ﬁle
until all desired ﬁles have been added.
Removing ﬁles

If you want to remove a ﬁle from the project, click the ﬁle in the list and
click on the Red - buon. To remove all the ﬁles in the list click on the
Broom shaped buon.

Icons of a broom are often used in Ubuntu to
represent clearing a text ﬁeld or returning
something to its default state.

  



Saving a project

To save an unﬁnished project, choose Project ‣ Save. e “Save Current
Project” window will be opened. Choose where you would like to save the
project. en in the Name: text ﬁeld, enter a name for the project. Now
click the Save buon.
Burning the disc

When you click the Burn… buon, you will see the “Properties of …” window.
You can specify the burning speed in the Burning speed drop down. It is
best to choose the highest speed.
To burn your project directly to the disc, select the Burn the image
directly without saving it to disc option. With this option selected, no
image ﬁle is created and no ﬁles are saved to the hard disk. All data is saved
to the blank CD or DVD.
e Simulate before burning option is useful if you encounter problems
burning discs. Selecting this option allows you to simulate the disc burning
process without actually writing data to a disc—a wasteful process if your
computer isn’t writing data correctly. If the simulation is successful, Brasero
will burn the disc aer a ten second pause. During those ten seconds, you
have the option to cancel the burning process.

Temporary ﬁles are saved in the /tmp folder
by default. Should you wish to save these ﬁles
in another location, you will need to change
the setting in the Temporary ﬁles drop down
menu. Under normal conditions, you should not
need to change this setting.

Blanking a disk

If you are using a disc that has  wrien on it and you have used it before,
then you can erase it so that it can be reused. is will erase all of the data
currently on the disc. To erase a disc, open the Tools menu, then select
Blank. e “Disc Blanking” window will be open. In the Select a disc drop
down choose the disc that you would like to erase.
You can enable the Fast blank option if you would like to shorten the
amount of time to perform the blanking process. However, selecting this
option will not fully remove the ﬁles; if you have any sensitive data on your
disc, it would be best not to enable the Fast blank option.
Once the disc is erased (blank), you will see e disc was successfully
blanked. Click the Close buon to ﬁnish.
Audio project

If you record your own music, then you may want to transfer this music
onto an audio  so your friends and family can listen. You can start an
audio project by clicking Project ‣ New Project ‣ New Audio Project.
When burning a music CD, it is important to remember that commercial
music CDs usually have two-second gap between song. To ensure your
music has this same gap between songs, click the ﬁle and then clicking the
pause buon.
You can slice ﬁles into parts by clicking the Knife buon. is opens a
“Split Track” window. e Method drop down gives you four options each
one of these lets you split the track in a diﬀerent way. Once you have split
the track, click OK.
In the drop down window at the boom of the main “Brasero” window,
make sure that you have selected the disc where you want to burn the ﬁles.
en click the Burn buon.

RW stands for Re-Writable which means the disc
can be used more than once.
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Data project

If you want to make a back up of your documents or photos, it would
be best to make a data project. You can start a data project by clicking
Project ‣ New Project ‣ New Data Project.
If you want to add a folder you can click the Folder picture, then enter
the name of the folder.
In the drop down at the boom of the main “Brasero” window, make sure
that you have selected the disc where you want to burn the ﬁles. en click
the Burn buon.
Video project

If you want to make a  of your family videos, it would be best to make
a video project. You can start a video project by clicking Project ‣ New
Project ‣ New Video Project.
In the drop down window at the boom of the main “Brasero” window,
make sure that you have selected the disc where you want to burn the ﬁles.
en click the Burn buon.
Disc copy

You can copy a disc clicking Project ‣ New Project ‣ Disc copy. is opens
the “Copy /” window.
If you have two / drives you can copy a disc from one to the other,
the disc that you want to copy to must be in the / drive. If
you have only one drive you will need to make an image and then burn it to
a disc. In the Select disc to copy drop-down choose the disc to copy. In the
Select a disc to write to drop-down either choose image ﬁle or the disc that
you want to copy to.
Image ﬁle

You can change where the image ﬁle is saved by clicking Properties. is
shows the “Location for Image File”. You can edit the name of the ﬁle in the
Name: text ﬁeld.
e default save location is your home folder, you can change this by
clicking the + buon next to Browse for other folders. Once you have
chosen where you want to save the photo or image, click Close.
Back in the “Copy /” window click Create Image. Brasero will
open the “Creating Image” and will display the job progress. When the
process is complete, click Close.
Burn image

To burn an image, open the Project ‣ New Project ‣ Burn Image. Brasero
will open the “Image Burning Setup” window. Click on the Cli here to
select a disc image drop-down and the “Select Disc Image” window will
appear. Navigate your way to the image you wish to burn, click on it, and
then click Open.
In the Select a disc to write to drop-down menu, click on the disc to
which you’d like to write, then click Create Image.

  



Working with documents, spreadsheets, and presentations

LibreOﬃce suite is the default oﬃce suite when working with: word documents, spreadsheets, and slide presentations.
Working with documents

If you need to work with documents, you can use the LibreOﬃce Word Processor. To start the word processor, open the Dash home of the Launcher,
search for LibreOffice Writer and select it. Ubuntu should then open the
main window for the word processor.
Working with spreadsheets

If you need to work with spreadsheets, you can use the LibreOﬃce Spreadsheet. To start the spreadsheet application, click on the Dash home, type
LibreOffice Calc and select LibreOﬃce Calc.
Working with presentations

If you need to work with slides for a presentation, you can use the LibreOﬃce Impress. To start the presentation application, open the Dash home
menu, type LibreOffice Impress, and then click on it.
Getting more help

Each of these applications comes with a comprehensive set of help screens.
If you are looking for more assistance with these applications, press the F1
key aer starting the application.
Ubuntu One
What is Ubuntu One?

Ubuntu One is a service for storing your ﬁles online—in your Ubuntu One
Personal Cloud. Your Ubuntu One Personal Cloud is your personal online
storage space; it can be accessed in any web browser or using an Ubuntu
One application, such as those for Ubuntu, Windows, iPhone, or Android.
Because Ubuntu One stores your ﬁles online, it’s the perfect way to backup
your ﬁles to prevent data loss. You can also use Ubuntu One to share ﬁles
with other people—this makes Ubuntu One a great tool for friends, families,
and collaborative teams. Ubuntu One also provides services for backing
up your contacts and streaming music to mobile devices. e Ubuntu One
service is provided by Canonical.
How safe is Ubuntu One?

Before using Ubuntu One, you should bear the following points in mind:
‣ Uploading, downloading and synchronizing your information with
Ubuntu One is done over an encrypted connection, which prevents
anybody eavesdropping on your information as it is being transferred.
‣ Files are not stored by Canonical in encrypted form. It is important to
keep this in mind when deciding what to upload to Ubuntu One. You can
use other means to encrypt you data, such as an encrypted zip ﬁle.

The LibreOﬃce Word Processor is also known
as the LibreOﬃce Writer. Spreadsheet is also
known as Calc, and Presentation is known as
Impress.
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‣ Information uploaded to Ubuntu One can potentially be accessed by
Canonical. As with similar online services and websites, you are implicitly trusting them to respect your privacy, so if you feel you cannot trust
them with certain information, don’t upload it to Ubuntu One.
‣ If you violate the Ubuntu One terms and conditions and store illegal
material, Canonical may be required to hand the information over to law
enforcement agencies without your consent.
‣ Your online information can be accessed by anybody who knows (or can
guess) your account name and password. For this reason, you should
choose a good password and keep it secure.
Getting started with Ubuntu One

To use Ubuntu One, you will need to create a free Ubuntu One account
using an email address. is free account gives you access to GB of online
storage and the contact syncing service; access to more data storage or the
music streaming service requires a paid subscription.
ere are two ways to create an Ubuntu One account. You can either
sign up using the Ubuntu One Control Panel (pre-installed in Ubuntu), or
you can sign up on the Ubuntu One website https://one.ubuntu.com by
clicking the Sign Up link.
Creating an Ubuntu One account using the Ubuntu One Control Panel

5GB is enough to store about 1,500 music ﬁles
or 5,000 photographs (depending on size).

Figure 3.27: This Launcher icon opens the
Ubuntu One Control Panel.

In the Launcher, click the Ubuntu One icon, as shown in Figure .. is
should open the dialog shown in Figure ..
Figure 3.28: The Ubuntu One Control Panel
Welcome Page.

Click the I don’t have an account yet – sign me up buon.
Fill in the details requested. Make sure you use a valid email address that
only you have access to.
You should review the Terms of Service and Privacy Policy before
signing up. When you’re satisﬁed, click Set Up Account.
Within a few minutes, you will receive an email containing the veriﬁcation code. Enter the veriﬁcation code into the box as shown in Figure .
and click Next.
If all goes well, you will see a window saying: “You are now logged into
Ubuntu One.”; in this window click the Finish buon. You will also get
another email welcoming you to Ubuntu One. Now that you are logged into

If you do not have an email address, you can get
one for free at gmail.com.
The captcha acts as a check that it really is a
person ﬁlling in the form and not a computer
(because a computer won’t be able to read the
captcha text).

  



Figure 3.29: Fill in all ﬁelds with your information to sign up for an Ubuntu One account.

Figure 3.30: Enter the veriﬁcation code into the
ﬁeld.

Ubuntu One, you can conﬁgure your Ubuntu machine for Ubuntu One ﬁle
syncing.
Conﬁgure your Ubuntu machine for ﬁle syncing

e Ubuntu One desktop application syncs your Ubuntu One Personal
Cloud with ﬁles on your local ﬁle system. Aer logging into the Ubuntu
One desktop application the following dialog (Figure .) should appear,
allowing you to select which ﬁles to sync with your Ubuntu One Personal
Cloud.
If you have already used your Ubuntu One account, you may have more
folders in this view (Figure .). You can choose which Ubuntu One cloud
folders you would like synced with your local ﬁle system. If this is the ﬁrst
time you are using Ubuntu One, just click the Next buon.
You can also change your Ubuntu One sync connection seings at this time by
clicking on the Che Settings buon; you can change things like the maximum
upload and download rate, or if notiﬁcations should be allowed.

In this dialog (Figure .), you can choose which of your local ﬁle system folders you would like synced with your Ubuntu One cloud storage.

Sync is short for Synchronize; implying that
the contents of your Ubuntu One local ﬁle
system and your Ubuntu One Personal Cloud
will always be identical.
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Figure 3.31: This setup dialog lets you select
which existing Ubuntu One folders you would
like synced with your machine.

Figure 3.32: This setup dialog lets you select
which folders of your local ﬁle system you
would like synced with your Ubuntu One cloud
storage.

e folder Ubuntu One is implicitly synced, but you can select additional
folders you may like synced—your pictures, for instance. Once you’re
ﬁnished selecting folders, click the Finish buon to complete the setup
process. You are now ready to begin using Ubuntu One!
Using Ubuntu One with the Nautilus ﬁle manager

Ubuntu One integrates with Nautilus, the program you use to view your ﬁle
system. You can add, sync, and share ﬁles directly from Nautilus.
Adding and Modifying Files

You can add ﬁles to your Ubuntu One folder (or any other folder that you
have selected for sync) just as you normally would, and Ubuntu One will
automatically sync them to your personal cloud. For example, if you add
your vacation photos, you should see a screen similar to Figure ..
Aer moving the ﬁles into the Ubuntu One synced folder, you should receive a notiﬁcation informing you that syncing has begun. You can also see
that each ﬁle shows the circular arrow icon, indicating that it is currently
syncing with your personal cloud. When syncing completes, the circular
arrows will be replaced with check marks.

Figure 3.33: These symbols indicate the sync
status of a ﬁle or folder. The Checkmark
indicates that the ﬁle or folder has been
synced, and the circular arrows indicate that the
ﬁle or folder is in the process of syncing.

  



Figure 3.34: When you add ﬁles to an Ubuntu
One synced folder, they automatically sync to
your personal cloud.

Whenever you add or modify ﬁles that are in folders synced with Ubuntu
One, they will automatically sync to your personal cloud. Aer syncing is
complete, you can view the ﬁles on the Ubuntu One Web UI, and they will
also be synced to any other computers or mobile devices that you are using
Ubuntu One on.
Adding Folders to Sync

You can add other folders to be synced with your Ubuntu One Personal
Cloud, not just your Ubuntu One folder. You can add folders to be synced
through Nautilus by right-clicking the folder you would like to sync. In
the right-click menu, choose Ubuntu One ‣ Synronize is Folder, as
shown in Figure .. You can also stop syncing a folder through the same
right-click menu.
To view which ﬁles on your system are are currently syncing with
Ubuntu One, open the Ubuntu One Control Panel by clicking the Ubuntu
One Launcher icon, as shown in Figure .; a dialog similar to that in
Figure . should appear.
In the Ubuntu One Control Panel you can see which of your folders are
synced with your Ubuntu One Personal Cloud. You can also add ﬁles from
here, by clicking the Add a folder from this computer buon.
Using Ubuntu One with the Ubuntu One Web UI

You can access your ﬁles from any computer using the Ubuntu One Web
UI at https://one.ubuntu.com. When you ﬁrst reach the web page, you will
need to log in by clicking Log in or Sign up in the upper right-hand corner
of the page. On the following page, ﬁll in your email address and Ubuntu
One password, then click the Continue buon.
Once logged in, you should be taken to your Dashboard. e Dashboard
shows you a summary of your data usage, and keeps you informed of new
features in Ubuntu One.

A Web UI (User Interface) is a web site that you
can go to and do the same things that you do
on your computer. Emails, for instance, are
commonly accessed through a Web UI.
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Figure 3.35: Use a folder’s right-click menu to
sync or un-sync the folder from your Ubuntu
One Personal Cloud.

Figure 3.36: The Ubuntu One Control Panel
shows you which folders in your ﬁle system are
synced with your Ubuntu One Personal Cloud.

To view your ﬁles, click the Files link in the navigation bar in the upper
portion of the page.
Downloading and Uploading Files

To access your ﬁles from the Ubuntu One Web UI, you can simply download
them from your personal cloud. To download a ﬁle, click More shown
to the right of the ﬁle, as shown in the browser, then click on Download
ﬁle, as shown in Figure .. Clicking Download ﬁle will initiate a ﬁle
download through your browser.
If you make changes to the ﬁle or want to add a new ﬁle to your personal
cloud, simply click the Upload ﬁle buon in the upper portion of the page.
is will upload the ﬁle into the current folder and overwrite any old versions of the ﬁle. Once you have uploaded the ﬁle, it will be available in your
personal cloud, and will sync to your Ubuntu machine’s local ﬁle system.

  



Figure 3.37: A ﬁle’s More button in the Web UI
gives you many options.

Making Files Public

You can make a ﬁle public on the web by clicking More and choosing the
Publish ﬁle buon—this is also shown in Figure .. Aer clicking the
Publish ﬁle buon, the Web UI will generate a Public URL; you can share
this URL with anyone. By directing a browser to the Public URL of the
ﬁle, the browser should begin to download the ﬁle or it may display it,
depending on what type of ﬁle it is.
You can make the ﬁle private again at any time by clicking the Stop
publishing buon located to the le of the Public URL. Aer you click the
Stop publishing buon the Public URL ﬁeld will go away, and the URL
will stop working. If someone tries to use a Public URL for a ﬁle that has
been made private they will receive an error message and the ﬁle will not
download or displayed.
Sharing Files

Ubuntu One lets you share ﬁles with other Ubuntu One users, leing you
collaborate on ﬁles with ease. When one user makes a change to a shared
ﬁle the changes automatically sync to the other users’ personal clouds
and their local ﬁle system, so all users automatically have the most recent
version of the ﬁle.
To share ﬁles in Ubuntu One, you must share an entire folder. Before you
begin to share ﬁles, you should make sure only the ﬁles you want to share
are in this folder. en to share this folder, navigate to it in the Ubuntu One
Web UI, and click the More buon to the le of the folder name. In the
More menu, click on Share folder. A dialog box similar to that shown in
ﬁgure . should appear. Complete the ﬁelds in the dialog box, and click
the Share this folder buon when you are ﬁnished.
Once you share the folder, the user you are trying to share the folder
with should receive an email informing them that you would like to share
the ﬁle. ey will then have to accept the share request. If the email address
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Figure 3.38: Sharing folders with other users
makes collaborating on ﬁles simple.

you provide does not yet have an Ubuntu One account, they must ﬁrst sign
up for an Ubuntu One account before they can access the shared folder.
To stop sharing a folder, navigate to it, click the More buon, and click
Stop sharing.
If another user shares a folder with you, you will receive an email informing you of the share, and a link to click on to accept the share request.
Folders that are shared with you by other users will appear in the Shared
With Me folder inside your Ubuntu One folder (~/Ubuntu One/Shared With
Me/).
To stop syncing ﬁles that are shared with you, navigate to the folder in
the Ubuntu One Web UI, click the More buon, then click the Delete this
share buon.
Exceeding your Ubuntu One Storage Limit

If you exceed the storage limit of your Ubuntu One account—GB is the
free limit—Ubuntu One will stop syncing your ﬁles to your Ubuntu One
Personal Cloud.
Remedying an Exceeded Storage Limit

You can do several things to remedy an exceeded storage limit. Among
them are:
‣ Delete any ﬁles you no longer need—it’s good to clean out old ﬁles.
‣ Move any ﬁles you no longer need synced—to another location that is
not synced with Ubuntu One.
‣ Purchase additional storage space—you can purchase additional storage
in GB blocks.
Purchasing Additional Storage Space

You can purchase additional storage space by clicking the Get more storage
buon in the Ubuntu One Control Panel, or at https://one.ubuntu.com/

  



services/. Additional storage is available in GB blocks and is priced at
$./month, or $./year.
Figure 3.39: You can purchase additional
storage space on the Ubuntu One website.

Figure 3.40: Ubuntu One accepts credit cards,
and PayPal for purchasing additional storage.

Getting Ubuntu One Mobile Apps

Ubuntu One has mobile applications for Android and iPhone mobile devices. ese applications allow you to access your personal cloud ﬁles
on-the-go. You can get more information about the Android and iPhone
applications at https://one.ubuntu.com/downloads/android/ and https://one.
ubuntu.com/downloads/iphone/, respectively.

Figure 3.41: This is the icon for the Ubuntu One
Android and iPhone apps.
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Getting Ubuntu One for Windows

Ubuntu One also has a Windows application, which can sync your Ubuntu
One Personal Cloud ﬁles to the ﬁle system of a Windows operating system.
More information can be found at https://one.ubuntu.com/downloads/
windows/.
Additional Services of Ubuntu One

In addition to ﬁle syncing, Ubuntu One oﬀers Contact Syncing and Music
Streaming services. ese services are not discussed in this book, but additional information can be found at https://one.ubuntu.com/help/tutorial/
contact-sync-for-ubuntu--lts/ and https://one.ubuntu.com/services/
music/ respectively. e Music Streaming service requires a paid subscription of $./month, and has a  day free trial period.

4

Hardware

Using your devices

Ubuntu supports a wide range of hardware, and support for new hardware
improves with every release.
Hardware identiﬁcation

ere are various ways to identify your hardware in Ubuntu. e easiest
would be to install an application from the Ubuntu Soware Center, called
Sysinfo.
Firstly, open the “Ubuntu Soware Center”, then use the search box in
the top right corner to search for sysinfo. Select the Application, click
Install. Enter your password when prompted, to install the application.
To run the application, search for Sysinfo at the Dash search bar. Click
on the program once you ﬁnd it. e Sysinfo program will open a window
that displays information about the hardware in your system.
Displays
Hardware drivers

A driver is a piece of soware which tells your computer how to communicate with a piece of hardware. Every component in a computer requires a
driver to function, whether it’s the printer,  player, hard disk, or graphics card.
e majority of graphics cards are manufactured by three well-known
companies: Intel, /, and  Corp. You can ﬁnd your video card
manufacturer by referring to your computer’s manual, by looking for the
speciﬁcations of your computer’s model on the Internet, or by using the
command lspci in a terminal. e Ubuntu Soware Center houses a number of applications that can tell you detailed system information. SysInfo is
one such program that you can use to ﬁnd relevant information about your
System devices. Ubuntu comes with support for graphics devices manufactured by the above companies, and many others, out of the box. at means
you don’t have to ﬁnd and install any drivers yourself, Ubuntu takes care of
it all.
Keeping in line with Ubuntu’s philosophy, the drivers that are used by
default for powering graphics devices are open source. is means that the
drivers can be modiﬁed by the Ubuntu developers and problems with them
can be ﬁxed. However, in some cases a proprietary driver (restricted driver)
provided by the company may provide beer performance or features that
are not present in the open source driver. In other cases, your particular
device may not be supported by any open source drivers yet. In those
scenarios, you may want to install the restricted driver provided by the
manufacturer.
For both philosophical and practical reasons, Ubuntu does not install
restricted drivers by default but allows the user to make an informed choice.
Remember that restricted drivers, unlike the open source drivers for your
device, are not maintained by Ubuntu. Problems caused by those drivers

Your graphics card is the component in your
computer which outputs to the display.
Whether you are watching videos on YouTube,
viewing DVDs, or simply enjoying the smooth
transition eﬀects when you maximize/minimize
your windows, your graphics device is doing the
hard work behind the scenes.
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will be resolved only when the manufacturer wishes to address them.
To see if restricted drivers are available for your system, press the Super/Windows key on your keyboard to show the Dash or click the Ubuntu
icon on the Unity Launcher, and search for Additional Drivers. If a driver
is provided by the company for your particular device, it will be listed there.
You can simply click Activate to enable the driver. is process requires an
active Internet connection and it will ask for your password. Once installation is complete you may have to reboot your computer to ﬁnish activating
the driver.
e Ubuntu developers prefer open source drivers because they allow
any problem to be identiﬁed and ﬁxed by anyone with knowledge within
the community. Ubuntu development is extremely fast and it is likely that
your device will be supported by open source drivers. You can use the
Ubuntu Live  to check your device’s compatibility with Ubuntu before
installing, or go online to the Ubuntu forums or to http://www.askubuntu.
com to ask about your particular device.

Another useful resource is the oﬃcial online
documentation (http://help.ubuntu.com), which
contains detailed information about various
graphics drivers and known problems. This
same documentation can be found by searching
for Yelp in the Dash search bar or by pressing
F1 on your keyboard.

Setting up your screen resolution

One of the most common display related tasks is seing the correct screen
resolution for your desktop monitor or laptop.
Ubuntu correctly identiﬁes your native screen resolution by itself and
sets it for you. However, due to a wide variety of devices available, sometimes it can’t properly identify your resolution.
To set or check your screen resolution, go to System Settings ‣ Displays.
e “Displays” window detects automatically the type of display and shows
your display’s name, size. e screen resolution and refresh rate is set to
the recommended value by Ubuntu. If the recommended seings are not to
your liking, you can change the same from the Resolution drop-down to
the resolution of your choice.
Adding an extra display

Sometimes, you may want to add more than one display device to your
desktop, or may want to add an external monitor to your laptop. Doing
this is quite simple. Whether it’s an extra monitor, LCD TV, or a projector,
Ubuntu can handle it all. Ubuntu supports the addition of multiple displays
by default, which is as easy as plug and play. Ubuntu recognizes almost
all the latest monitors, TVs and projectors by default. Sometimes it may
happen that your additional display is not detected when you connect it to
the machine. To resolve this, go to System Settings ‣ Displays and click on
Detect Displays. is will detect the monitors connected to the machine.
is menu can also be found from the Power Oﬀ menu on the top panel.
You can also search for Displays at the Dash search bar. Now, there are two
modes which you can enable for your displays. One option is to spread your
desktop across two or more monitors. is is particularly useful if you are
working on multiple projects and need to keep an eye on each of them at
the same time. e second option is to mirror the desktop onto each of the
displays. is is particularly useful when you are using a laptop to display
something on a larger screen or a projector. To enable this option just
check the box beside Mirror displays and click Apply to save the seings.
You will get a pop-up notiﬁcation asking if you want to keep the current
seing or revert to the previous seing. Click to keep the current seing.

Displays are made up of thousands of tiny
pixels. Each pixel displays a diﬀerent color,
and when combined they all display the image
that you see. The native screen resolution is a
measure of the amount of actual pixels on your
display.

 

Starting from Ubuntu ., you can also select whether you want the Unity
Launcher in both the displays or only in the primary display.
Connecting and using your printer

Ubuntu supports most new printers. You can add, remove, and change
printer properties by navigating to System Settings ‣ Printing. You can also
search for Printing from the Dash search bar. Opening Printing will display
the “Printing-localhost” window.
When you want to add a printer, you will need to make sure that it is
switched on, and plugged into your computer with a  cable or connected
to your network.
Adding a local printer

If you have a printer that is connected to your computer with a  cable
then this is termed a local printer. You can add a printer by clicking on the
Add Printer buon.
In the le hand pane of the “New Printer” window any printers that you
can install will be listed. Select the printer that you would like to install and
click Forward.
You can now specify the printer name, description and location. Each of
these should remind you of that particular printer so that you can choose
the right one to use when printing. Finally, click Apply.
Adding a network printer

If your printer can automatically do double
sided printing, it will probably have a duplexer.
Please refer to the instructions that came with
the printer if you are unsure. If you do have a
duplexer, make sure the Duplexer Installed
option is checked and then click the Forward
button.

Make sure that your printer is connected to your network either with an
Ethernet cable or via wireless and is turned on. You can add a printer by
clicking Add Printer. e “New Printer” window will open. Click the “+”
sign next to Network Printer.
If your printer is found automatically it will appear under Network
Printer. Click the printer name and then click Forward. In the text ﬁelds
you can now specify the printer name, description and location. Each of
these should remind you of that particular printer so that you can choose
the right one to use when printing. Finally click Apply.
You can also add your network printer by entering the  address of the
printer. Select “Find Network Printer,” enter the  address of the printer
in the box that reads Host: and press the Find buon. Ubuntu will ﬁnd the
printer and add it. Most printers are detected by Ubuntu automatically. If
Ubuntu cannot detect the printer automatically, it will ask you to enter the
make and model number of the printer.

The default printer is the one that is automatically selected when you print a ﬁle. To set a
printer as default, right-click the printer that
you want to set as default and then click Set As
Default.

Changing printer options

Printer options allow you to change the printing quality, paper size and
media type. ey can be changed by right-clicking a printer and choosing
Properties. e “Printer Properties” window will show; in the le pane,
select Printer Options.
You can now specify seings by changing the drop-down entries. Some
of the options that you might see are explained.
Media size

is is the size of the paper that you put into your printer tray.
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Media source

is is the tray that the paper comes from.
Color Model

is is very useful if you want to print in Grayscale to save on ink, or to
print in Color, or Inverted Grayscale.
Media type

Depending on the printer you can change between:
‣
‣
‣
‣
‣

Plain Paper
Automatic
Photo Paper
Transparency Film
 or  Media

Print quality

is speciﬁes how much ink is used when printing, Fast Dra using the
least ink and High-Resolution Photo using the most ink.
Sound

Ubuntu usually detects the audio hardware of the system automatically
during installation. e audio in Ubuntu is provided by a sound server
named PulseAudio. e audio preferences are easily conﬁgurable with the
help of a very easy to use  which comes preinstalled with Ubuntu.
Volume icon and Sound Preferences

A volume icon, siing on the top right corner of the screen, provides quick
access to a number of audio related functions. When you le-click on the
volume icon you are greeted with four options: A mute option at the very
top, a slider buon which you can move horizontally to increase/decrease
volume, a shortcut to the default music player, Rhythmbox, and an option
for accessing the Sound Seings. Selecting Sound Seings opens up another
window, which provides access to options for changing input and output
hardware preferences for speakers, microphones and headphones. It also
provides options for seing the volume level for each application. Sound
Seings can also be found from System Settings. It is known as Sound.
Output e Output tab will have a list of all the sound cards available
in your system. Usually there is only one listed; however, if you have a
graphics card which supports  audio, it will also show up in the list.
e Output tab is used for conﬁguring the output of audio. You can increase/decrease and mute/unmute output volume and select your preferred
output device. If you have more than one output device, it will be listed in
the section which reads “Choose a device for sound output.” e default
output hardware, which is automatically detected by Ubuntu during installation will be selected. is section also allows you to change the balance of
sound on the le and right speakers of your desktop/laptop.

A microphone is used for making audio/video
calls which are supported by applications like
Skype or Empathy. It can also be used for sound
recording.
If you change your sound output device, it will
remain as default.

 

Input e second tab is for conﬁguring audio Input. You will be able to
use this section when you have an in-built microphone in your system or
if you’ve plugged in an external microphone. You can also add a Bluetooth
headset to your input devices which can serve as a microphone. You can
increase/decrease and mute/unmute input volume from this tab. If there is
more than one input device, you will see them listed in the white box which
reads Choose a device for sound input.
Sound Eﬀects e third tab is Sound Eﬀects. You can enable, disable, or
change the existing sound theme from this section. You can also change the
alert sounds for diﬀerent events.
Applications e Applications tab is for changing the volume for running
applications. is comes in handy if you have multiple audio applications
running, for example, if you have Rhythmbox, Totem Movie Player and a
web-based video playing at the same time. In this situation, you will be able
to increase/decrease, mute/unmute volume for each application from this
tab.

You should note that by default in any Ubuntu
installation, the input sound is muted. You
will have to manually unmute to enable your
microphone to record sound or use it during
audio/video calls.
By default, the volume in Ubuntu is set to
maximum during installation.

You can add new sound themes by installing
them from Software Center (e.g., Ubuntu
Studio’s GNOME audio theme.) You will get the
installed sound themes from the drop down
menu. You can also enable window and button
sounds.
The Ubuntu Design Team have made a few
changes to the volume icon post Ubuntu 11.10.

More functionality

e icon can control various aspects of the system, application volume
and music players like Rhythmbox, Banshee, Clementine and Spotify. e
volume indicator icon can now be easily referred to as the sound menu,
given the diverse functionality of the icon. Media controls available include
play/pause, previous track, and next track. You can also switch between
diﬀerent playlists from the Choose Playlist option. ere is also a seek bar
which you can manually drag to skip some portions of any song. If the
current playing song has album art, it will show up beside the name of the
current track, otherwise you will see only the details of the song. It displays
the track name, the artist name and the album name of the current track.

You can start and control the default music
player, Rhythmbox, by simply left clicking on
the sound menu and selecting Rhythmbox from
the list. Clicking the play button also starts the
player.

Using a webcam

Webcams oen come built into laptops and netbooks. Some desktops, such
as Apple iMacs, have webcams built into their displays. If you purchase a
webcam because your computer doesn’t have its own, it will most likely
have a  connection. To use a  webcam, plug it into any empty 
port of your desktop.
Almost all new webcams are detected by Ubuntu automatically. You can
conﬁgure webcams for individual applications such as Skype and Empathy
from the application’s setup menu. For webcams which do not work right
away with Ubuntu, visit https://wiki.ubuntu.com/Webcam for help.
Scanning text and images

Scanning a document or an image is very simple in Ubuntu. Scanning is
handled by the application Simple Scan. Most of the time, Ubuntu will
simply detect your scanner and you should just be able to use it. To scan a
document, follow these steps:
. Place what you want to scan on the scanner.
. Click to open the Dash and enter scan.

There are several applications which are useful
if you have a webcam. Cheese can capture
pictures with your webcam and VLC media
player can capture video from your webcam.
You can install these from the Ubuntu Software
Center.
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Click on Simple Scan.
Click to choose between Text or Photo from Document ‣ Scan ‣ Text.
Click Scan.
Click the Paper Icon to add another page.
Click Save to save.

You can save the scanned documents and pictures in . You can also
save in  format to enable opening in Acrobat Reader. To do that, add the
extension .pdf at the end of the ﬁlename.
Troubleshooting your scanner

If your scanner is not detected, Ubuntu may give you a “No devices available” message when trying to scan. ere may be a reason why Ubuntu
cannot ﬁnd your scanner.
‣ Simply unplug the scanner and plug it back in. If it is a newer  scanner, it is likely that it will just work.
‣ e driver for your scanner is not being automatically loaded. Restart
your system. It might help!
‣ Your scanner is not supported in Ubuntu. e most common type
of scanner not supported is old parallel port or Lexmark All-in-One
printer/scanner/faxes.
‣  project listing of supported scanners. e  (Scanner Access
Now Easy) project provides most of the back-ends to the scanning soware on Ubuntu.
‣ Check https://wiki.ubuntu.com/HardwareSupportComponentsScanners
to ﬁnd out which scanners work with Ubuntu.
Other devices
USB

USB ports are available as standard on almost all computers available now.
ey are used to connect a multitude of devices to your computer. ese
could include portable hard drives, ﬂash drives, removable //Blu-ray
drives, printers, scanners and mobile phones. When connected, ﬂash drives
and portable hard drives are automatically detected—the ﬁle manager will
open and display the contents of the drive. You can then use the drives
for copying data to and from the computer. All new cameras, camcorders
and mobile phone  cards are automatically detected by Ubuntu. ese
SD cards have diﬀerent types of data, so a window will appear with a drop
down menu to choose between video, audio import and the ﬁle manager
—you can choose your desired action from this menu.
Firewire

Firewire is a connection on some computers that allows you to transfer data
from devices. is port is generally used by camcorders and digital cameras.
If you want to import video from your camcorder you can do so by
connecting your camcorder to the Firewire port. You will need to install a
program called Kino which is available in the Ubuntu Soware Center.

Firewire is oﬃcially known as IEEE 1394. It
is also known as the Sony i.LINK and Texas
Instruments Lynx.

To ﬁnd out more about Kino, visit http://www.
kinodv.org/.

 

Bluetooth

Bluetooth is a wireless technology that is widely used by diﬀerent types of
devices to connect to each other. It is common to see a mouse or a keyboard
that supports Bluetooth. You can also ﬁnd  devices, mobile phones,
headsets, music players and many other devices that can connect to your
desktops or laptop and let you transfer data, listen to music, or play games
as an example.
If your computer has Bluetooth support then you should see a Bluetooth
icon in the top panel, usually near the volume icon. Click on the Bluetooth
icon to open a popup menu with several choices, such as an option to Turn
oﬀ Bluetooth.
e Bluetooth preferences can also be accessed from System Settings ‣
Bluetooth. If you want to connect a new device—for example, to have a
mobile phone send pictures or videos to your computer—select Setup new
device….
Ubuntu will open a window for new device setup. When you click Forward, Ubuntu will show you how many Bluetooth devices are present near
your computer. e list of available devices might take a minute or so to
appear on the screen as your system scans for these devices. Each device
will be displayed as soon as it is found by Ubuntu. Once a device you’d like
to connect with appears in the list, click on it. en, choose a  number
by selecting PIN options.
ree predeﬁned  numbers are available, but you can also create a
custom . You will need to enter this  on the device you will be pairing
with Ubuntu.
Once the device has been paired, Ubuntu will open the “Setup completed” window. In Ubuntu, your computer is hidden by default for security
reasons. is means that your Ubuntu system can search other Bluetooth
devices, but others cannot ﬁnd your Ubuntu system when they perform
a search on their own computer. If you would like to let another device
ﬁnd your computer, you will have to explicitly allow your computer to be
found. To allow your computer to be found, select “Make computer discoverable” in Bluetooth preferences. You can also click on the Bluetooth icon
and select Visible to make your computer discoverable.
You can also add a fancy name for your Bluetooth-enabled Ubuntu system by changing the text under Friendly Name.
Another feature present in the Bluetooth icon menu is “Send ﬁles to
device.” Use this option to send a ﬁle to a mobile phone without pairing
with the computer.

Figure 4.1: The Bluetooth applet menu.

When you pair two Bluetooth devices, you are
letting each device trust the other one. After
you pair two devices, they will automatically
connect to each other in the future without
requiring a PIN.

Android devices need to be paired at all times,
even while transferring ﬁles.
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Software Management

Software management in Ubuntu

As discussed in Chapter : Working with Ubuntu, Ubuntu oﬀers you a wide
range of applications for your daily work. Ubuntu comes with a basic set
of applications for common tasks like surﬁng the Internet, checking your
email, listening to music, and organizing your photos and videos. Sometimes you may need an extra level of specialization: for example you may
want to retouch your photos, run some soware for your business, or play
some new games. In each of these cases you can search for an application,
install it and use it—usually, with no extra cost.
Soware in Ubuntu is delivered as packages, simplifying the installation
to one click. A package is a compressed ﬁle archive containing everything needed to run the application. Packages can also contain information
describing which other applications, called dependencies or libraries, are
needed. Linux is designed in a way that any library can be updated without
having to reinstall the complete application, minimizing hard drive usage by
leing other applications use the same library.
Most other operating systems require a user to purchase commercial
soware (online or through a physical store), or search the Internet for a
free alternative (if one is available). e correct installation ﬁle must then
be veriﬁed for integrity, downloaded and located on the computer, followed
by the user proceeding through a number of installation prompts and options. By default Ubuntu gives you a centralized point with two diﬀerent
ways to browse the repositories for searching, installing and removing soware.
‣ Ubuntu Soware Center
‣ Command line apt-get
Searching, installing and/or removing applications with Ubuntu Soware
Center is the easiest and most comfortable way. It is recommended for all
kinds of users, starting from beginners to the most experienced.
Using the Ubuntu Software Center

ere are numerous ways to install soware on an operating system. In
Ubuntu, the quickest and easiest way to ﬁnd and install new applications is
through the Ubuntu Soware Center.
To start the application, click on the Ubuntu Soware Center icon in the
Launcher, or click on the Dash and search for Ubuntu Soware Center.
e Ubuntu Soware Center can be used to install applications that are
available in the oﬃcial Ubuntu repositories. e Soware Center window
has four parts—a list of categories on the le, a banner at the top, a Recommended For You panel at the boom and two featured areas on the right.
Clicking on a category will take you to a list of related applications. For
example, the Internet category contains Firefox Web Browser. e featured
areas highlight What’s New and Top Rated soware. Each area shows different application icons. Just click an icon to get more information on the
application or to install it. To see all soware the area contains, click More.

Figure 5.1: Software Center icon
We recommend Ubuntu Software Center for
searching, installing and removing applications,
although you still have the possibility to use the
command-line application apt-get, or install
and use the advanced application Synaptic
Package Manager.
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Figure 5.2: You can install and remove applications from your computer using the Software
Center.

ree sections at the top represent your current view of the Soware
Center’s catalog. Click the All Soware buon to see soware that is available to install, click Installed to see a list of soware that is already installed
on your computer, or click History to see previous installations and deletions organized by date.
Find your application

Ubuntu Soware Center displays diﬀerent sources in the “Get Soware”
section. Clicking the arrow next to “All Soware” will show a list of individual sections. Selecting “Provided by Ubuntu” will show free oﬃcial
soware, “For Purchase” will show soware for purchasing, and “Canonical
Partners” will show soware from partners of Canonical, such as Adobe.
If you are looking for an application, you may already know a speciﬁc
name (for example, VLC Media Player), or you may just have a general
category in mind (for example, the Sound and Video category includes a
number of diﬀerent soware applications such as video converters, audio
editors, and music players).
To help you ﬁnd the right application, you can browse the Soware
Center catalog by clicking on the category that reﬂects the type of soware
you are looking for, or use the Search ﬁeld at the top right of the window to
look for speciﬁc names or keywords.
When you select a category, you will be shown a list of applications.
Some categories have sub-categories—for example, the Games category has
subcategories for Simulation and Card Games. To move through categories
you can use the back and forward buons at the top of the window. is
version of Ubuntu has a new category “Books & Magazines” which contains
interesting books and magazines.

  

Installing software

Once you have found an application you would like to try, installing it is
just one click away.
To install soware:
. Click the Install buon to the right of the selected package to install it. If
you would like to read more about the soware package before installing
it, ﬁrst click on “More Info.” is will take you to a short description of
the application, as well as a screenshot and a Web link when available.
Related add-ons will be listed below the application’s description. You
can click Install from this screen as well. In addition, if you use the
Gwibber micro-blogging application, you can hit the “Share…” link below
the description of an application to tell your friends about it.
. Aer clicking Install, enter your password into the authentication window that appears. is is the same password you use to log in to your
account. You are required to enter it whenever installing or removing
soware in order to prevent someone without administrator access
from making unauthorized changes to your computer. If you receive an
Authentication Failure message aer typing in your password, check
that you typed it correctly by trying again. If the error continues, this
may mean that your account is not authorized to install soware on the
computer.
. Wait until the package is ﬁnished installing. During the installation
(or removal) of programs, you will see an animated icon of rotating
arrows to the le of the In Progress buon in the sidebar. If you like, you
can now go back to the main browsing window and choose additional
soware packages to be installed by following the steps above. At any
time, clicking the Progress buon on the top will take you to a summary
of all operations that are currently processing. Here you can also click
the X icon to cancel any operation.
Once the Soware Center has ﬁnished installing an application, it is ready
to be used. You can start the newly installed application by going to the
Dash and typing the name of the application in the search bar. By default
application is added to the Launcher. You can change this behavior by
deselecting View ‣ New Applications in Launer.
Removing software

Removing applications is very similar to installing them. First ﬁnd the installed soware in Ubuntu Soware Center. You can click on the Installed
buon which will show all the installed soware listed in diﬀerent categories. Scroll down to the application you wish to remove. If you click on
the arrow next to Installed buon, you will ﬁnd a list of soware providers,
which can help you to narrow your search. You also can enter keywords in
the Search ﬁeld to quickly ﬁnd installed soware, or you can search by date
in the History tab (more on History below).
To remove soware:
. Click the Remove buon to the right of the selected application.
. Enter your password into the authentication window that appears. Removing Soware also requires that you enter your password to help
protect your computer against unauthorized changes. e package will
then be queued for removal, and will appear under the progress section
in the top.

You must have administrative privileges, and
you will need to be connected to the Internet
for the Software Center to work. To learn how
to set up your Internet connection, see Getting
online.
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Figure 5.3: Installing Software via the Ubuntu
Software Center.

Removing a package will also update your menus accordingly.
Software history

e Ubuntu Soware Center keeps track of past soware management
in the History section. is is useful if you wish to revert installations or
removals and do not remember the application’s name.
ere are four buons in the history section—All Changes, Installations,
Updates and Removals. Clicking one will show a list of days that action
occurred. If you click the arrow next to a day, a list of individual packages
will be shown, along with what was done with them and at what time. e
History section shows all soware installation history, not just changes
made within the Soware Center. For example, packages updated through
the Update Manager will also be listed.
Software Recommendations

e Ubuntu Soware Center oﬀers two types of recommendations—per
user based and per application based. Click the Turn On Recommendations
buon at the boom of the Ubuntu Soware Center to enable per—user
based recommendations. You will have to log in with your Ubuntu Soware Center account. is is the same as your Ubuntu One or Launchpad
account. When you enable recommendations, your list of installed soware
will be periodically sent to servers of Canonical. Recommendations will
appear in the boom panel. If you want to disable these recommendations
then go to View ‣ Turn Oﬀ Recommendations.
Figure 5.4: You can turn on Software Recommendations via clicking on the Turn On
Recommendations button.

Per—application based recommendations do not require log in. ey

  

are labeled as “People Also Installed.” ese are the applications installed
by users who also installed the application which you are about to install.
ese recommendations are shown in the detailed page of particular application.
Figure 5.5: The “People Also Installed” section
shows applications installed by users who also
installed the application which you are about to
install.

Managing additional software

Although the Ubuntu Soware Center provides a large library of applications to choose from, initially only those packages available within the
oﬃcial Ubuntu repositories are listed. At times, you may be interested in a
particular application that is not available in these repositories. If this happens, it is important to understand some alternative methods for accessing
and installing soware in Ubuntu, such as downloading an installation ﬁle
manually from the Internet, or adding extra repositories. First, we will look
at how to manage your repositories through Soware Sources.
Software Sources

e Ubuntu Soware Center lists only those applications that are available
in your enabled repositories. Repositories can be added or removed through
the Soware Sources application. You can open Soware Sources from the
Ubuntu Soware Center. Simply go to Edit ‣ Soware Sources or open the
 (Alt key) and search for “sources.”
Managing the oﬃcial repositories

When you open Soware Sources, it shows you the Ubuntu Soware tab
where the ﬁrst four options are enabled by default.
Canonical-supported open source soware (main) is repository contains
all the open-source packages that are maintained by Canonical.
Community-maintained open source soware (universe) is repository
contains all the open-source packages that are developed and maintained
by the Ubuntu community.
Proprietary drivers for devices (restricted) is repository contains proprietary drivers, which may be required to utilize the full capabilities of
some of your devices or hardware.
Soware restricted by copyright or legal issues (multiverse) is repository
contains soware that may be protected from use in some states or
countries by copyright or licensing laws. By using this repository you
assume responsibility for the usage of any packages that you install.
Source code is repository contains the source code that is used to build
the soware packages from some of the other repositories. e Source
code option should not be selected unless you have experience with
building applications from source.

The Ubuntu Software tab lists the oﬃcial
Ubuntu repositories, each containing diﬀerent
types of packages.

Closed-source packages are sometimes
referred to as non-free. This is a reference to
freedom of speech, rather than monetary cost.
Payment is not required to use these packages.

Building applications from source is an advanced process for creating packages, and
usually only concerns developers. You may
also require source ﬁles when using a custom
kernel, or if trying to use the latest version of
an application before it is released for Ubuntu.
As this is a more advanced area, it will not be
covered in this manual.

     .

Figure 5.6: Drivers can be installed or removed
via the Additional Drivers application.

Selecting the best software server

Ubuntu provides and allows many servers around the world to mirror the
packages from the sources listed under “Managing the oﬃcial repositories.”
When selecting a server, you may want to consider the following:
Distance to server. is will aﬀect the speed you can achieve with the ﬁle
server.
Internet Service Provider. Some Internet service providers oﬀer cheaper, or
even unlimited free downloads from their own servers.
ality of server. Some servers may only oﬀer downloads at a capped
speed, limiting the rate at which you can install and update soware on
your computer.
Ubuntu will automatically choose an appropriate server while installing,
and as such these seings should not be changed unless your physical
location changes drastically or if you feel a higher speed should be achieved
by your Internet connection. e guide below will help in choosing an
optimal server.
Ubuntu provides a tool for selecting the server that provides the fastest
connection with your computer.
. Click the dropdown box next to “Download from:” in the Soware
Sources window.
. Select “Other…” from the list.
. In the “Server Selection” window that appears. Click the Select Best
Server buon in the upper right. Your computer will now aempt a
connection with all the available servers, then select the one with the
fastest speed.
If you are happy with the automatic selection, click Choose Server to
return to the Soware Sources window.
If you are not happy with the automatic selection or prefer not to use
the tool, the fastest server is oen the closest server to you geographically.
In this case simply choose “Other” then ﬁnd the nearest location to your
computer. When you are happy with the seings chosen click Choose
Server to return to the Soware Sources window.

Ubuntu grants permission to many servers all
across the world to act as mirrors. That is, they
host an exact copy of all the ﬁles contained in
the oﬃcial Ubuntu repositories.

  

If you do not have a working Internet connection, updates and programs
can be installed from the installation media itself by inserting your media
and clicking the box under “Installable from /.” Once this box is
checked the media within the/ drive will function as an online
repository and as such the soware on the media will be installable from
the Ubuntu Soware Center.
Adding more software repositories

Ubuntu makes it easy to add additional, third-party repositories to your
list of soware sources. e most common repositories added to Ubuntu
are called s. ese allow you to install soware packages that are not
available in the oﬃcial repositories, and automatically be notiﬁed whenever
updates for these packages are available.
If you know the web address of a ’s Launchpad site, adding it to your
list of soware sources is relatively simple. To do so, you will need to use
the Other Soware tab in the “Soware Sources” window.
On the Launchpad site for a , you will see a heading to the le called
“Adding this PPA to your system.” Underneath will be a short paragraph
containing a unique  in the form of ppa:test-ppa/example. Highlight this
 by selecting it with your mouse, then right-click and select Copy.

A PPA is a Personal Package Archive. These
are online repositories used to host the latest
versions of software packages, digital projects,
and other applications.

Figure 5.7: This is an example of the Launchpad
page for the Lifesaver PPA. Lifesaver is an
application that is not available in the oﬃcial
Ubuntu repositories. However, by adding
this PPA to your list of software sources, it
would then be easy to install and update this
application through the Software Center.

Return to the “Soware Sources” window, and in the Other Soware tab
click Add… at the boom. A new window will appear, and you will see the
words “Apt line:” followed by a text ﬁeld. Right-click on the empty space in
this text ﬁeld and select Paste, and you should see the  appear that you
copied from the s Launchpad site earlier. Click Add Source to return to
the “Soware Sources” window. You will see a new entry has been added
to the list of sources in this window, with a selected check box in front
meaning it is enabled.
If you click Close in the boom right corner of this window, a message
will appear informing you that “e information about available soware
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is out-of-date.” is is because you have just added a new repository to
Ubuntu, and it now needs to connect to that repository and download a
list of the packages that it provides. Click Reload, and wait while Ubuntu
refreshes all of your enabled repositories (including this new one you just
added). When it has ﬁnished, the window will close automatically.
Congratulations, you have just added a  to your list of soware
sources. You can now open the Soware Center and install applications
from this , in the same way you previously installed applications from
the default Ubuntu repositories.
Manual software installation

Although Ubuntu has extensive soware available, on some occasions you
may want to manually install soware packages that are not available in the
repositories. If there is not a  for the soware, you will need to install it
manually. Before you choose to do so, make sure you trust the package and
its maintainer.
Packages in Ubuntu have a .deb extension. Double-clicking a package
will open an overview page in the Soware Center, which will give you
more information about that package.
e overview gives some technical information about that package, a
website link (if applicable) and the option to install. Clicking Install will
install the package just like any other installation in the Soware Center.
Figure 5.8: Installing .deb ﬁles manually using
software center.

Updates and upgrades

Ubuntu also allows you to decide how to manage package updates through
the Updates tab in the Soware Sources window.

  

Ubuntu updates

In this section, you are able to specify the kinds of updates you wish to
install on your system, and usually depends on your preferences around
stability, versus having access to the latest developments.
Figure 5.9: You can update installed software
by using the Update Manager application in
Ubuntu.

Important security updates ese updates are highly recommended to
ensure your system remains as secure as possible. ese are enabled by
default.
Recommended updates ese updates are not as important for keeping your
system secure, but will mean your packages always have the most recent
bug ﬁxes or minor updates that have been tested and approved. is
option is also enabled by default.
Pre-released updates is option is for those who would rather remain
up-to-date with the very latest releases of applications, at the risk of installing an update that has unresolved bugs or conﬂicts. Note that it is
possible that you will encounter problems with these updated applications, therefore this option is not enabled by default.
Unsupported updates ese are updates that have not yet been fully tested
and reviewed by Canonical. Some bugs may occur when using these
updates, and so this option is also not enabled by default.

Automatic updates

e middle section of this window allows you to customize how your system manages updates, such as the frequency with which it checks for new
packages, as well as whether it should install important updates right away
(without asking for your permission), download them only, or just notify
you about them.
Release upgrade

Here you can decide which system upgrades you would like to be notiﬁed
about.
Never Choose this if you would rather not be notiﬁed about any new
Ubuntu releases.

Every six months, Canonical will release a new
version of the Ubuntu operating system. These
are called normal releases. Every four normal
releases—or 24 months—Canonical releases
a long-term support (LTS) release. Long-term
support releases are intended to be the most
stable releases available, and are supported for
a longer period of time.
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For any new version Choose this if you always want to have the latest
Ubuntu release, regardless of whether it is a long-term support release or
not. is option is recommended for normal home users.
For long-term support versions Choose this option if you need a release
that will be more stable and have support for a longer time. If you use
Ubuntu for business purposes, you may want to consider selecting this
option.
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Advanced Topics

Ubuntu for advanced users

We hope you understand how using Ubuntu can make your computing
experience easier, safer, and more eﬃcient. To this point, we’ve provided
detailed instructions on geing the most from Ubuntu’s basic features. In
this chapter, we’ll detail some of Ubuntu’s more advanced features—like the
terminal, a powerful utility that can help you accomplish tasks without the
need for a graphical user interface (). We’ll also discuss some advanced
security measures you can implement to make your computer even safer.
We’ve wrien this chapter with advanced users in mind. If you’re new to
Ubuntu, don’t feel as though you’ll need to master these topics to get the
most out of your new soware (you can quite easily skip to the next chapter
without any adverse impact to your experience with Ubuntu). However, if
you’re looking to expand your knowledge of Ubuntu, we encourage you to
keep reading.
Introduction to the terminal

roughout this manual, we have focused primarily on the graphical desktop user interface. In order to fully realize the power of Ubuntu, you may
want to learn how to use the terminal.
What is the terminal?

Most operating systems, including Ubuntu, have two types of user interfaces. e ﬁrst is a graphical user interface (). is is the desktop, windows, menus, and toolbars that you click to get things done. e second,
and much older, type of interface is the command-line interface ().
e terminal is Ubuntu’s command-line interface. It is a method of
controlling some aspects of Ubuntu using only commands that you type on
the keyboard.
Why would I want to use the terminal?

You can perform most day-to-day activities without ever needing to open
the terminal. However, the terminal is a powerful and invaluable tool that
can be used to perform many useful tasks you might not be able to accomplish with a . For example:
‣ Troubleshooting any diﬃculties that may arise when using Ubuntu
sometimes requires you to use the terminal.
‣ A command-line interface is sometimes a faster way to accomplish a
task. For example, it is oen easier to perform operations on many ﬁles
concurrently using the terminal.
‣ Learning the command-line interface is the ﬁrst step towards more
advanced troubleshooting, system administration, and soware development skills. If you are interested in becoming a developer or an advanced
Ubuntu user, knowledge of the command-line will be essential.
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Opening the Terminal

You can open the terminal by clicking Dash ‣ Applications ‣ Terminal.
When the terminal window opens, it will be largely blank apart from
some text at the top le of the screen, followed by a blinking block. is
text is your prompt—it displays, by default, your login name and your
computer’s name, followed by the current directory. e tilde (~) means that
the current directory is your home directory. Finally, the blinking block is
the cursor—this marks where text will be entered as you type.
To test a terminal command, type pwd and press Enter. e terminal
should display /home/yourusername. is text is called the “output.” You
have just used the pwd (print working directory) command, which outputs
(displays) the current directory.

The terminal gives you access to what is called a
shell. When you type a command in the terminal
the shell interprets this command, resulting
in the desired action. Diﬀerent types of shells
accept slightly diﬀerent commands. The most
popular is called “bash,” and is the default shell
in Ubuntu.
In GUI environments the term “folder” is
commonly used to describe a place where
ﬁles are stored. In CLI environments the term
“directory” is used to describe the same thing.
This metaphor is exposed in many commands
(i.e., cd or pwd) throughout this chapter.

Figure 6.1: The default terminal window allows
you to run hundreds of useful commands.

All commands in the terminal follow the same approach: Type a command, possibly followed by some parameters, and press Enter to perform
the speciﬁed action. Oen some output will be displayed that conﬁrms the
action was completed successfully, although this can depend on the command being executed. For example, using the cd command to change your
current directory (see below) will change the prompt, but will not display
any output.
e rest of this chapter covers some very common uses of the terminal.
However, it cannot address the nearly inﬁnite possibilities available to
you when using the command-line interface in Ubuntu. roughout the
second part of this manual, we will continue to refer to the command line,
particularly when discussing steps involved in troubleshooting and the
more advanced management of your computer.
Ubuntu ﬁle system structure

Ubuntu uses the Linux ﬁle system, which is based on a series of folders in
the root directory. Each of these folders contains important system ﬁles that
cannot be modiﬁed unless you are running as the root user or use sudo. is
restriction exists for both security and safety reasons: computer viruses will
not be able to change the core system ﬁles, and ordinary users should not
be able to accidentally damage anything vital.
Below are some of the most important directories.
e root directory—denoted by /—contains all other directories and ﬁles.
Here are the contents of some essential system directories:
/bin

& /sbin Many essential system applications (equivalent to C:\Windows)

Parameters are extra segments of text,
usually added at the end of a command, that
change how the command itself is interpreted.
These usually take the form of -h or -help, for example. In fact, --help can be
added to most commands to display a short
description of the command, as well as a list
of any other parameters that can be used with
that command.

  

Figure 6.2: Some of the most important
directories in the root ﬁle system.

/

media

ipod

pendrive

usr

etc

bin

lib

var

home

log

user

Documents

Music

Photos

System-wide conﬁguration ﬁles
Each user will have a subdirectory to store personal ﬁles (for example /home/your-username, equivalent to C:\Users or C:\Documents and
Settings)
/lib Library ﬁles, similar to .dll ﬁles on Windows
/media Removable media ( and  drives) will be mounted in this
directory
/root is contains the root user’s ﬁles (not to be confused with the root
directory)
/usr Pronounced “user,” it contains most program ﬁles (not to be confused
with each user’s home directory, equivalent to C:\Program Files)
/var/log Contains log ﬁles wrien by many applications
/etc

/home

Every directory has a path. e path is a directory’s full name—it describes a way to navigate the directory from anywhere in the system.
For example, the directory /home/your-username/Desktop contains all
the ﬁles that are on your Ubuntu desktop. e path /home/your-username/Desktop
can be broken down into a handful of key pieces:
. /—indicates that the path starts at the root directory
. home/—from the root directory, the path goes into the home directory
. your-username/—from the home directory, the path goes into the yourusername directory
. Desktop—from the your-username directory, the path ends up in the
Desktop directory
Every directory in Ubuntu has a complete path that starts with the / (the
root directory) and ends in the directory’s own name.
Directories and ﬁles that begin with a period are hidden directories.
ese are usually only visible with a special command or by selecting a
speciﬁc option. In the Nautilus you can show hidden ﬁles and directories
by selecting View ‣ Show Hidden Files, or by pressing Ctrl+H. If you are
using the terminal, then you would type ls -a and press Enter to see the
hidden ﬁles and directories. ere are many hidden directories in your
home folder used to store program preferences. For example, /home/yourusername/.evolution stores preferences used by the Evolution mail application.

If you are creating a ﬁle or directory from
the command line and ultimately want it
hidden, then simply start the ﬁlename or
directory name with a dot (.)—this signals to
the ﬁlesystem that the ﬁle/directory should
be hidden unless expressly viewed through
showing hidden ﬁles and folders through the
GUI or through the appropriate command line
switch.
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Mounting and unmounting removable devices

Any time you add storage media to your computer—an internal or external
hard drive, a  ﬂash drive, a —it needs to be mounted before it is
accessible. Mounting a device means associating a directory name with the
device, allowing you to navigate to the directory to access the device’s ﬁles.
When a device, such as a  ﬂash drive or a media player, is mounted in
Ubuntu, a folder is automatically created for it in the media directory, and
you are given the appropriate permissions to be able to read and write to
the device.
Most ﬁle managers will automatically add a shortcut to the mounted
device in the side bar of your home folder so the device is easy to access.
You shouldn’t have to physically navigate to the media directory in Ubuntu,
unless you choose to do so from the command line.
When you’ve ﬁnished using a device, you can unmount it. Unmounting a
device disassociates the device from its directory, allowing you to eject it.
Securing Ubuntu

Now that you know a bit more about using the command line, we can use it
to make your computer more secure. e following sections discuss various
security concepts, along with procedures for keeping your Ubuntu running
smoothly, safely, and securely.
Why Ubuntu is safe

Ubuntu is secure by default for a number of reasons:
‣ Ubuntu clearly distinguishes between normal users and administrative
users.
‣ Soware for Ubuntu is kept in a secure online repository, which contains
no false or malicious soware.
‣ Open-source soware like Ubuntu allows security ﬂaws to be easily
detected.
‣ Security patches for open-source soware like Ubuntu are oen released
quickly.
‣ Many viruses designed to primarily target Windows-based systems do
not aﬀect Ubuntu systems.

Basic security concepts

e following sections discuss basic security concepts—like ﬁle permissions,
passwords, and user accounts. Understanding these concepts will help you
follow the remaining procedures for securing your computer.
Permissions

In Ubuntu, ﬁles and folders can be set up so that only speciﬁc users can
view, modify, or run them. For instance, you might wish to share an important ﬁle with other users, but do not want those users to be able to edit the
ﬁle. Ubuntu controls access to ﬁles on your computer through a system of
“permissions.” Permissions are seings conﬁgured to control exactly how
ﬁles on your computer are accessed and used.

Just because Ubuntu implements strong
security by default doesn’t mean the user
can ”throw caution to the wind.” Care should
be taken when downloading ﬁles, opening
email, and browsing the Internet. Using a good
antivirus program is warranted.

  

To learn more about modifying permissions, visit https://help.ubuntu.
com/community/FilePermissions.
Passwords

You should use a strong password to increase the security of your computer.
Your password should not contain names, common words, or common
phrases. By default, the minimum length of a password in Ubuntu is four
characters. We recommend a password with more than the minimum number of characters. A password with a minimum of eight characters which
includes both upper and lower case leers, numbers, and symbols is considered strong.
Locking the screen

When you leave your computer unaended, you may want to lock the
screen. Locking your screen prevents anyone from using your computer
until your password is entered. To lock the screen:
‣ Click the session menu icon in the right corner of the top panel, then
select Lo Screen, or
‣ press Ctrl+Alt+L to lock the screen. is keyboard shortcut can be
changed in Dash ‣ Applications ‣ Keyboard Shortcuts
User accounts

Users and groups

When Ubuntu is installed, it is automatically conﬁgured for a single person
to use. If more than one person will use the computer, each person should
have his or her own user account. is way, each user can have separate
seings, documents, and other ﬁles. If necessary, you can also protect ﬁles
from being viewed or modiﬁed by users without administrative privileges.
Like most operating systems, Ubuntu allows you to create separate user
accounts for each person. Ubuntu also supports user groups, which allow
you to administer permissions for multiple users at the same time.
Every user in Ubuntu is a member of at least one group—at a bare minimum, the user of the computer has permissions in a group with the same
name as the user. A user can also be a member of additional groups. You
can conﬁgure some ﬁles and folders to be accessible only by a user and a
group. By default, a user’s ﬁles are only accessible by that user; system ﬁles
are only accessible by the root user.
Managing users

You can manage users and groups using the Users and Groups administration application. To ﬁnd this application, click Session Indicator ‣ Systems
and Settings ‣ User Accounts.
To adjust the user seings, ﬁrst click the Unlo buon and enter your
password to unlock the user seings. Next, select the user that you want to
modify from the list. en click on the element that you want to change.
Adding a user Click the + buon which appears underneath the list of the
current user accounts that have already been created. A window will appear that has two ﬁelds. e Name ﬁeld is for a friendly display name. e
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Figure 6.3: Add, remove and change the user
accounts.

Username ﬁeld is for the actual username. Fill in the requested information,
then click OK. A new dialog box will appear asking you to enter a password
for the user you have just created. Fill out the ﬁelds, then click OK. You can
also click the gears buon to generate a password. Privileges you grant to
the new user can be altered in “Users Seings”.
Modifying a user Click on the name of a user in the list of users, then click
on the text entry which appears next to each of following options:
‣ Account type:
‣ Password:
‣ Automatic Login:
Deleting a user Select a user from the list and click -. Ubuntu will deactivate the user’s account, and you can choose whether to remove the user’s
home folder or leave it in place. If a user is removed and the user’s ﬁles
remain, the only user that can access the ﬁles will be root or anyone associated with the ﬁle’s group.
Managing groups

Group management is accomplished through the command line (Terminal)
or by adding third-party applications that are beyond the scope of this manual. You will ﬁnd more information in the subsection “Using the command
line” below.
Adding a group To add a group, type sudo addgroup groupname and press
Enter, replacing groupname with the name of the group you wish to add.
Modifying a group To alter the users in an existing group, type sudo adduser username groupname (adding a user) or sudo deluser username
groupname (removing a user) and press Enter, replacing username and
groupname with the user and group name with which you’re working.
Deleting a group To delete a group, type sudo delgroup groupname and
press Enter, replacing groupname with the name of the group you wish to
delete.

  

Applying groups to ﬁles and folders

To change the group associated with a ﬁle or folder, open the Nautilus ﬁle
browser and navigate to the appropriate ﬁle or folder. en, either select
the folder and choose File ‣ Properties from the menubar, or right-click on
the ﬁle or folder and select Properties. In the Properties dialog window,
click on the Permissions tab and select the desired group from the Groups
drop-down list. en close the window.
Using the command line

You can also modify user and group seings via the command line. We
recommend that you use the graphical method above unless you have a
good reason to use the command line. For more information on using the
command line to modify users and groups, see the Ubuntu Server Guide at
hps://help.ubuntu.com/./serverguide/C/user-management.html
System updates

Good security happens with an up-to-date system. Ubuntu provides free
soware and security updates. You should apply these updates regularly.
See Updates and upgrades to learn how to update your Ubuntu computer
with the latest security updates and patches.
Trusting third party sources

Normally, you will add applications to your computer via the Ubuntu Soware Center which downloads soware from the Ubuntu repositories as
described in Chapter : Soware Management. However, it is occasionally necessary to add soware from other sources. For example, you may
need to do this when an application is not available in the Ubuntu repositories or when you need a newer version of the one available in the Ubuntu
repositories.
Additional repositories are available from sites such as getdeb.net and
Launchpad s which can be added as described in Soware Sources. You
can download the  packages for some applications from their respective
project sites on the Internet. Alternately, you can build applications from
their source code (an advanced method of installing and using applications).
Using only recognized sources such as a project’s site, , or various
community repositories (such as getdeb.net) is more secure than downloading applications from an arbitrary (and perhaps less reputable) source.
When using a third party source, consider its trustworthiness, and be sure
you know exactly what you’re installing on your computer.
Firewall

A ﬁrewall is an application that protects your computer against unauthorized access by people on the Internet or your local network. Firewalls
block connections to your computer from unknown sources. is helps
prevent security breaches.
Uncomplicated Firewall () is the standard ﬁrewall conﬁguration program in Ubuntu. It runs from the command line, but a program called Gufw
allows you to use it with a graphical user interface . See Chapter :
Soware Management to learn more about installing the Gufw package.
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Once Gufw is installed, start Gufw by clicking Dash ‣ Applications ‣
Firewall conﬁguration. To enable the ﬁrewall, select the Enable option. By
default, all incoming connections are denied. is seing should be suitable
for most users.
If you are running server soware on your Ubuntu system (such as a
web server, or an  server), then you will need to open the ports these
services use. If you are not familiar with servers, you will likely not need to
open any additional ports.
To open a port click on the Add buon. For most purposes, the Preconﬁgured tab is suﬃcient. Select Allow from the ﬁrst box and then select the
program or service required.
e simple tab can be used to allow access on a single port, and the
Advanced tab can be used to allow access on a range of ports.
Encryption

You may wish to protect your sensitive personal data—for instance, ﬁnancial records—by encrypting it. Encrypting a ﬁle or folder essentially “locks”
that ﬁle or folder by encoding it with an algorithm that keeps it scrambled
until it is properly decoded with a password. Encrypting your personal data
ensures that no one can open your personal folders or read your private
data without your authorization through the use of a private key.
Ubuntu includes a number of tools to encrypt ﬁles and folders. is
chapter will discuss two of them. For further information on using encryption with either single ﬁles or email, see Ubuntu Community Help
documents at hps://help.ubuntu.com/community.
Home folder

When installing Ubuntu, it is possible to encrypt a user’s home folder. See
Chapter : Installation for more on encrypting the home folder.
Private folder

If you have not chosen to encrypt a user’s entire home folder, it is possible
to encrypt a single folder—called Private—in a user’s home folder. To do
this, follow these steps:
. Install the ecryptfs-utils soware package from the Ubuntu Soware
Center. (For more information about the Soware Center, review Using
the Ubuntu Soware Center.)
. Use the terminal to run ecryptfs-setup-private to set up the private
folder.
. Enter your account’s password when prompted.
. Either choose a mount passphrase or generate one.
. Record both passphrases in a safe location. ese are required if you ever
have to recover your data manually.
. Log out and log back in to mount the encrypted folder.
Aer the Private folder has been set up, any ﬁles or folders in it will
automatically be encrypted.
If you need to recover your encrypted ﬁles manually see https://help.
ubuntu.com/community/EncryptedPrivateDirectory.

7

Troubleshooting

Resolving problems

Sometimes, things may not work as they should. Luckily, problems that
are encountered while working with Ubuntu are oen easily ﬁxed. Below,
we oﬀer a guide for resolving the basic problems that users may encounter
while using Ubuntu. If you need any additional help beyond what this
chapter provides, take a look at other support options that are discussed in
Finding additional help and support later in this book.
Troubleshooting guide

e key to an eﬀective troubleshooting is to work slowly, complete all
of troubleshooting steps, and to document the changes that you make to
Ubuntu. is way, you will be able to undo your work, or give fellow users
the information about your previous aempts in cases when you need to
turn to the community for support.
Ubuntu fails to start after I’ve installed Windows

Occasionally you may install Ubuntu and then decide to install Microso
Windows as a second operating system running side-by-side with Ubuntu.
is is supported by Ubuntu, but you might also ﬁnd that aer installing
Windows you will no longer be able to start Ubuntu.
When you ﬁrst turn on your computer, a “bootloader” must start Ubuntu
or another operating system. When you installed Ubuntu, you installed an
advanced bootloader called  which allows you to choose between the
various operating systems on your computer, such as Ubuntu, Windows,
Solaris or Mac  . However, when you installed Windows, it replaced the
 with its own bootloader, thus removing the ability to choose which
operating system you’d like to use. You can restore  and regain the
ability to choose your operating system by using the same  you used to
install Ubuntu.
First, insert your Ubuntu  into your computer and then restart it,
making sure to have your computer start from the  (see Chapter : Installation). Next, choose your language (e.g., English) and select Try Ubuntu.
Once Ubuntu starts, click on the top-most icon in the Launcher (the Dash
icon). en, search for Terminal using the search box and then select Terminal in the search results. A window should open with a blinking prompt
line. Enter the following, and press Enter:
$ sudo fdisk -l
Disk /dev/hda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot

Start

End

1

1224

1225

2440

/dev/sda3

2441

14593

/dev/sda4

14532

14593

/dev/sda1
/dev/sda2

*

Blocks
64228+
9767520
97618972+
498015

Id

System

83

Linux

a5

Windows

5
82

Extended
Linux swap

A bootloader is the initial software that loads
the operating system when you switch on the
computer.
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Partition table entries are not in disk order

is output shows that your system (Linux, on which Ubuntu is based) is
installed on device /dev/sda1, but your computer is booting to /dev/sda2
(where Windows is located). We need to ﬁx this by telling the computer to
boot to the Linux device instead.
To do this, ﬁrst create a place to connect your existing existing Ubuntu
installation with your temporary troubleshooting session:
$ sudo mkdir /media/root

Next, link your Ubuntu installation and this new folder:
$ sudo mount /dev/sda1 /media/root

If you’ve done this correctly, then you should see the following:
$ ls /media/root
bin dev home lib mnt root srv usr
boot etc initrd lib64 opt sbin sys var
cdrom initrd.img media proc selinux tmp vmlinuz

Now, you can reinstall :
$ sudo grub-install --root-directory=/media/root /dev/sda
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script grub-install.
(hd0) /dev/sda

Finally, remove the Ubuntu disc from your  drive, reboot your
computer, and then start enjoying your Ubuntu operating system once
again.
is guide may not work for all Ubuntu users due to diﬀerences in the
various system conﬁguration. Still, this is the recommended and most
successful method for restoring the  bootloader. If you are following
this guide and if it does not restore  on your computer, then try the
other troubleshooting methods at https://help.ubuntu.com/community/
RecoveringUbuntuAfterInstallingWindows.
I forgot my password

If you forget your password in Ubuntu, you will need to reset it using the
“Recovery mode.”
To start the Recovery mode, shut down your computer and then start
again. As the computer starts up, press Shift. Select the Recovery mode
option using the arrow keys on your keyboard. Recovery mode should be
the second item in the list.
Wait until Ubuntu starts up—this may take a few minutes. Once booted,
you will not be able to see a normal login screen. Instead, you will be presented with the Recovery Menu. Select root using the arrow keys and press
Enter.
You will now be at a terminal prompt:
root@ubuntu:~#

To reset your password, enter:
# passwd username

The device (/dev/sda1, /dev/sda2, etc.) we
are looking for is identiﬁed by the word “Linux”
in the System column. Modify the instructions
below if necessary, replacing /dev/sda1 with
the name of your Linux device.

 

Figure 7.1: This is the grub screen in which you
can choose recovery mode.

Replace “username” above with your username, aer which Ubuntu will
prompt you for a new password. Enter your desired password and press the
Enter key and then re-type your password again, and press Enter. (Ubuntu
asks for your password twice to make sure you did not make a mistake
while typing). Once you have restored your password, return to the normal
system environment by entering:
# init 2

Login as usual and continue enjoying Ubuntu.
I accidentally deleted some ﬁles that I need

If you’ve deleted a ﬁle by accident, you may be able to recover it from
Ubuntu’s trash folder. is is a special folder where Ubuntu stores deleted
ﬁles before they are permanently removed from your computer.
To access the trash folder click on the Trash icon at the boom of the
Unity Launcher.
If you want to restore deleted items from the trash:
. Open Trash
. Click on each item you want to restore to select it. Press and hold Ctrl
to select multiple items.
. Click Restore Selected Items to move the deleted items back to their
original locations.
How do I clean Ubuntu?

Over time, Ubuntu’s soware packaging system can accumulate unused
packages and temporary ﬁles. ese temporary ﬁles, also called caches,
contain ﬁles from all of the packages that you have installed. Over time this
cache can grow quite large. Cleaning out the cache allows you to reclaim
space on your computer’s hard drive for storing your documents, music,
photographs, or other ﬁles.
To clear the cache, you can either use the clean, or the autoclean option
for the command-line program apt-get.
To run clean, open Terminal and enter:
$ sudo apt-get clean

Packages can also become unused over time. If a package was installed
to assist with running another program—and that program was subse-

The clean command will remove every
single cached item, while the autoclean
command only removes cached items that can
no longer be downloaded (these items are
often unnecessary).
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quently removed you no longer need the supporting package. You can
remove it with apt-get autoremove.
Load Terminal and enter:
$ sudo apt-get autoremove

I can’t play certain audio or video ﬁles

Many of the formats used to deliver rich media content are proprietary,
meaning they are not free to use, modify, or distribute with an open-source
operating system like Ubuntu. erefore, Ubuntu does not include the capability to use these formats by default; however, users can easily conﬁgure
Ubuntu to use these proprietary formats. For more information about the
diﬀerences between open source and proprietary soware, see Chapter :
Learning More.
If you ﬁnd yourself in need of a proprietary format, you may install
the ﬁles necessary for using this format from the Ubuntu Soware Center.
Ensure that you have Universe and Multiverse repositories enabled before
continuing. See the Soware Sources section to learn how to do this. When
you are ready to continue, install the necessary soware as follows:
. Open the Ubuntu Soware Center by searching for it from the Dash (the
top-most buon on the Launcher).
. Search for ubuntu-restricted-extras by typing “Ubuntu restricted
extras” in the search box on the right-hand side of the Ubuntu Soware
Center main window. When the Soware Center ﬁnds the appropriate
soware, click the arrow next to its title.
. Click Install, then wait while Ubuntu installs the soware.
One program that can play many of these formats is VLC media player.
It can be installed from the Ubuntu Soware Center. Once Ubuntu has
successfully installed this soware, your rich media content should work
properly.
How can I change my screen resolution?

e image on every monitor is composed of millions of lile colored dots
called pixels. Changing the number of pixels displayed on your monitor is
called “changing the resolution.” Increasing the resolution will make the
displayed images sharper, but will also tend to make them smaller. e
opposite is true when screen resolution is decreased. Most monitors have
a “native resolution,” which is a resolution that most closely matches the
number of pixels in the monitor. Your display will usually be sharpest when
your operating system uses a resolution that matches your display’s native
resolution.
e Ubuntu conﬁguration utility Displays allows users to change the
resolution. Open it by clicking on the session indicator and then on Displays…. e resolution can be changed using the drop-down list within
the program. Picking options higher up on the list (for example, those with
larger numbers) will increase the resolution.
You can experiment with various resolutions by clicking Apply at the
boom of the window until you ﬁnd one that is comfortable for you. Typically the highest resolution will be the native resolution. Selecting a resolution and clicking Apply will temporarily change the screen resolution
to the selected value and a dialog box will also be displayed. It allows you

 

Figure 7.2: You can change your display
settings.

to revert to the previous resolution seing or keep the new resolution. e
dialog box will disappear in  seconds, restoring the old resolution.
Figure 7.3: You can revert back to your old
settings if you need to.

is feature was implemented to prevent someone from being locked
out of the computer by a resolution that distorts the monitor and makes it
unusable. When you have ﬁnished seing the screen resolution, click Close.
Ubuntu is not working properly on my Apple MacBook or MacBook Pro

When installed on notebook computers from Apple—such as the MacBook
or MacBook Pro—Ubuntu does not always enable all of the computer’s
built-in components, including the iSight camera and the Airport wireless
Internet adapter. Luckily, the Ubuntu community oﬀers documentation
on ﬁxing these and other problems. If you are having trouble installing or
using Ubuntu on your Apple notebook computer, please follow the instructions at https://help.ubuntu.com/community/MacBook. You can select the
appropriate guide aer identifying your computer’s model number. For
instructions on doing this, visit the web page above.
Ubuntu is not working properly on my Asus EeePC

When installed on netbook computers from Asus—such as the EeePC—
Ubuntu does not always enable all of the computer’s built-in components,
including the keyboard shortcut keys and the wireless Internet adapter.
e Ubuntu community oﬀers documentation on enabling these components and ﬁxing other problems. If you are having trouble installing
or using Ubuntu on your Asus EeePC, please follow the instructions at
https://help.ubuntu.com/community/EeePC. is documentation page contains information pertaining speciﬁcally to EeePC netbooks.
To enable many of the features and Function Keys, a quick ﬁx is to add
“acpi_osi=Linux” to your grub conﬁguration. From the Terminal
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$ gksudo gedit /etc/default/grub

and very carefully change the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

Save and close the ﬁle. en, from the terminal:
sudo update-grub

Aer the command ﬁnishes, and you restart the computer, you will be able
to use the Fn keys normally.
My hardware is not working properly

Ubuntu occasionally has diﬃculties running on certain computers, generally when hardware manufacturers use non-standard or proprietary
components. e Ubuntu community oﬀers documentation to help you
troubleshoot many common issues that may arise from this situation, including problems with wireless cards, scanners, mouse and printers. You
can ﬁnd the complete hardware troubleshooting guide on Ubuntu’s support wiki, accessible at https://wiki.ubuntu.com/HardwareSupport. If your
hardware problems persist, please see Geing more help for more troubleshooting options or information on obtaining support or assistance from
an Ubuntu user.
Getting more help

is guide does not cover every possible workﬂow, task or issue in Ubuntu.
If you require assistance beyond the information in the manual, you can
ﬁnd a variety of support opportunities online.
More details about many support options available to you can be found
at Finding additional help and support later in this book.
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Learning More

What else can I do with Ubuntu?

You should now be able to use Ubuntu for most of your daily activities
—such as browsing the web, sending email, and creating documents. But
you may be interested in learning about other versions of Ubuntu you
can integrate into your digital lifestyle. In this chapter, we’ll introduce
you to additional versions of Ubuntu specialized for certain tasks. We’ll
also provide you with resources for answering any remaining questions
you may have, and tell you how you can get involved in the worldwide
community of Ubuntu users. But ﬁrst, we’ll discuss the technologies that
make Ubuntu a powerful collection of soware.
Open source software

Ubuntu is open source soware. Open source soware diﬀers from proprietary soware—soware whose source code is not freely available for
modiﬁcation or distribution by anyone but the rightsholder. Microso
Windows and Adobe Photoshop are examples of proprietary soware.
Unlike proprietary soware applications, the soware included with
Ubuntu is speciﬁcally licensed to promote sharing and collaboration. e
legal rules governing Ubuntu’s production and distribution ensure that
anyone can obtain, run, or share it for any purpose she or he wishes.
Computer users can modify open source soware like Ubuntu to suit
their individual needs, to share it, to improve it, or to translate it into
other languages—provided they release the source code for these modiﬁcations so others can do the same. In fact, the terms of many open
source licensing agreements actually make it illegal not to do so. For
more information regarding Ubuntu’s soware licensing standards, see
http://www.ubuntu.com/project/about-ubuntu/licensing.
Because open source soware is developed by large communities of
programmers distributed throughout the globe, it beneﬁts from rapid development cycles and speedy security releases (in the event that someone
discovers bugs in the soware). In other words, open source soware is
updated, enhanced, and made more secure every day as programmers all
over the world continue to improve it.
Aside from these technical advantages, open source soware also has
economic beneﬁts. While users must adhere to the terms of an open source
licensing agreement when installing and using Ubuntu, they needn’t pay
to obtain this license. And while not all open source soware is free of
monetary costs, much is.
To learn more about open source soware, see the Open Source Initiative’s open source deﬁnition, available at http://www.opensource.org/docs/
definition.php.
Distribution families

Ubuntu is one of several popular operating systems based on Linux (an
open source operating system). ese Linux-based operating systems—

The source code of a program is the collection
of ﬁles that have been written in a computer
language to make the program.
Proprietary software is software that cannot be
copied, modiﬁed, or distributed freely.
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called Linux “distributions,”—may look diﬀerent from Ubuntu at ﬁrst glance,
but they share similar characteristics because of their common roots.
Linux distributions can be divided into two broad families: the Debian
family and the Red Hat family. Each family is named for a distribution on
which subsequent distributions are based. For example, “Debian” refers
to both the name of a Linux distribution as well as the family of distributions derived from Debian. Ubuntu is part of this family. When describing
relationships between various open source projects, soware developers
oen use the metaphor of tributaries connecting to a common body of
water. For this reason, you may hear someone say that Ubuntu is located
“downstream” from Debian, because alterations to Debian ﬂow into new
versions of Ubuntu. Additionally, improvements to Ubuntu usually trickle
“upstream”—back to Debian and its family members, which beneﬁt from the
work of the Ubuntu community. Other distributions in the Debian family
include Linux Mint, Xandros, and CrunchBang Linux. Distributions in the
Red Hat family include Fedora, and Mandriva.
e most signiﬁcant diﬀerence between Debian-based and Red Hat-based
distributions is the system each uses for installing and updating soware.
ese systems are called “package management systems.” Debian soware
packages are  ﬁles, while Red Hat soware packages are  ﬁles.
e two systems are generally incompatible. For more information about
package management, see Chapter : Soware Management.
You will also ﬁnd Linux distributions that have been specialized for
certain tasks. Next, we’ll describe these versions of Ubuntu and explain the
uses for which each has been developed.
Choosing amongst Ubuntu and its derivatives

Just as Ubuntu is based on Debian, several distributions are subsequently
based on Ubuntu. Each diﬀers with respect to the soware included as part
of the distribution. Some are developed for general use, while others are
designed for accomplishing a more narrow set of tasks.
Alternative interfaces

Ubuntu features a graphical user interface () based on the open source
 desktop. As we explained in Chapter : e Ubuntu Desktop, a
“user interface” is a collection of soware elements—icons, colors, windows,
themes, and menus—that determines how someone may interact with a
computer. Some people prefer using alternatives to , so they have
created Ubuntu distributions featuring diﬀerent user interfaces. ese
include:
‣ Kubuntu, which uses the  graphical environment instead of the
 environment found in Ubuntu;
‣ Lubuntu, which uses the  graphical environment instead of the
 environment found in Ubuntu; and
‣ Xubuntu, which uses the  graphical environment instead of the
 environment found in Ubuntu.
Additionally, each of these distributions may contain default applications
diﬀerent from those featured in Ubuntu. For instance, the default music
player in Ubuntu is Rhythmbox, but in Lubuntu the default music player
is Aqualung, and in Kubuntu the default is Amarok. Be sure to investigate

A distribution, or “distro,” is an operating
system made from open source applications,
which are bundled together to make them
easier to install and use.

Package management systems are the means by
which users can install, remove, and organize
software installed on computers with open
source operating systems like Ubuntu.

 



these diﬀerences if you are considering installing an Ubuntu distribution
with an alternative desktop environment.
For more information about these and other derivative distributions, see
http://www.ubuntu.com/project/derivatives.
Task-speciﬁc distributions

Other Ubuntu distributions have been created to accomplish speciﬁc tasks
or run in specialized seings.
Ubuntu Server Edition

e Ubuntu Server Edition is an operating system optimized to perform
multi-user tasks when installed on servers. Such tasks include ﬁle sharing and website or email hosting. If you are planning to use a computer
to perform tasks like these, you may wish to use this specialized server
distribution in conjunction with server hardware.
is manual does not explain the process of running a secure web server
or performing other tasks possible with Ubuntu Server Edition. For details
on using Ubuntu Server Edition, refer to the manual at http://www.ubuntu.
com/business/server/overview.
Edubuntu

Edubuntu is an Ubuntu derivative customized for use in schools and other
educational institutions. It contains soware similar to that oﬀered in
Ubuntu, but also features additional applications—like a collaborative text
editor and educational games.
For additional information regarding Edubuntu, visit http://www.
edubuntu.org/
Ubuntu Studio

is derivative of Ubuntu is designed speciﬁcally for people who use computers to create and edit multimedia projects. It features applications to
help users manipulate images, compose music, and edit video. While users
can install these applications on computers running the desktop version of
Ubuntu, Ubuntu Studio makes them all available immediately upon installation.
If you would like to learn more about Ubuntu Studio (or obtain a copy
for yoursel), visit http://ubuntustudio.org/home.
Mythbuntu

Mythbuntu allows users to turn their computers into entertainment systems. It helps users organize and view various types of multimedia content
such as movies, television shows, and video podcasts. Users with  tuners
in their computers can also use Mythbuntu to record live video and television shows.
To learn more about Mythbuntu, visit http://www.mythbuntu.org/.
Finding additional help and support

is guide cannot possibly contain everything you’ll ever need to know
about Ubuntu. Because Geing Started with Ubuntu . could never an-

A server is a computer that’s been conﬁgured to
manage, or “serve,” ﬁles many people wish to
access.

     .

swer all your questions, we encourage you to take advantage of Ubuntu’s
vast community when seeking further information, troubleshooting technical issues, or asking questions about your computer. Next, we’ll discuss a
few of these resources so you can learn more about Ubuntu or other Linux
distributions.
Live chat

If you are familiar with Internet relay chat (), you can use chat clients
such as XChat or Pidgin to join the channel #ubuntu on irc.freenode.net.
Here, hundreds of volunteer users can answer your questions or oﬀer support in real time. To learn more about using Internet Relay Chat to seek
help with Ubuntu, visit https://help.ubuntu.com/community/InternetRelayChat.
LoCo teams

Within the Ubuntu community are dozens of local user groups called “LoCo
teams.” Spread throughout the world, these teams oﬀer support and advice,
answer questions and promote Ubuntu in their communities by hosting
regular events. To locate and contact the LoCo team nearest you, visit
http://loco.ubuntu.com/.
Books and Magazines

Many books have been wrien about Ubuntu, and professional magazines
oen feature news and information related to Ubuntu. You will frequently
ﬁnd these resources at your local bookstore or newsstand. However, many
of these print publications are also available as digital downloads for purchase in the Ubuntu Soware Center. To ﬁnd these, launch the Soware
Center, then click on “Books & Magazines” in the le panel.
Oﬃcial Ubuntu Documentation

e Ubuntu Documentation team maintains a series of oﬃcial wiki pages
designed to assist both new and experienced users wishing to learn more
about Ubuntu. e Ubuntu community endorses these documents, which
serve as a reliable ﬁrst point of reference for users seeking help online. You
can access these at http://help.ubuntu.com. To get to the built-in Ubuntu
Desktop Guide, press F1 on your desktop, or type yelp in the Dash.
The Ubuntu Forums

e Ubuntu Forums are the oﬃcial forums of the Ubuntu community. Millions of Ubuntu users use them daily to seek help and support from one
another. You can create an Ubuntu Forums account in minutes. To create
an account and learn more about Ubuntu from community members, visit
http://ubuntuforums.org.
Launchpad Answers

Launchpad, an open source code repository and user community, provides a
question and answer service that allows anyone to ask questions about any
Ubuntu-related topic. Signing up for a Launchpad account requires only
a few minutes. You can ask a question by visiting Launchpad at https://
answers.launchpad.net/ubuntu/+addquestion.

In addition to oﬃcial Ubuntu and community
help, you will often ﬁnd third-party help available on the Internet. While these documents
can often seem like great resources, some
could be misleading or outdated. It’s always
best to verify information from third-party
sources before taking their advice. When possible, rely on oﬃcial Ubuntu documentation for
assistance with Ubuntu.

 



Ask Ubuntu

Ask Ubuntu is a free, community-driven website for Ubuntu users and
developers. Like the Ubuntu Forums, it allows users to post questions that
other members of the Ubuntu community can answer. But Ask Ubuntu also
allows visitors to “vote” on the answers users provide, so the most useful or
helpful responses get featured more prominently on the site. Ask ubuntu
is part of the Stack Exchange network of websites, and is one of the best
Ubuntu support resources available at no cost. Visit http://www.askubuntu.
com to get started.
Search Engines

Because Ubuntu is a popular open source operating system, many users
have wrien about it online. erefore, using search engines to locate
answers to your questions about Ubuntu is oen an eﬀective means of
acquiring help. When using search engines to answer questions about
Ubuntu, ensure that your search queries are as speciﬁc as possible. In other
words, a search for “Unity interface” will return results that are less useful
than those associated with the query “how to use Ubuntu Unity interface”
or “how to customize Ubuntu Unity interface.”
Community support

If you’ve exhausted all these resources and still can’t ﬁnd answers to your
questions, visit Community Support at http://www.ubuntu.com/support/
community.
The Ubuntu community

Surrounding Ubuntu is a global community of passionate users who want to
help others adopt, use, understand, and even modify or enhance Ubuntu. By
choosing to install and run Ubuntu, you’ve become part of this community.
As you learn more about Ubuntu, you may wish to collaborate with others
to make it beer—to discuss the future of Ubuntu, to report soware bugs
you discover, to promote Ubuntu to new users, to share Ubuntu advice,
or to answer other users’ questions. In this section, we’ll discuss a few
community projects that can connect you to other Ubuntu users.
Full Circle Magazine

Full Circle Magazine is “the independent magazine for the Ubuntu Linux
community.” Released every month, Full Circle Magazine contains reviews
of new soware (including games) for Ubuntu, step-by-step tutorials for
projects you can undertake with Ubuntu, editorials discussing important
issues in the Ubuntu community, and Ubuntu tips from other users. You can
download issues of Full Circle Magazine at http://fullcirclemagazine.org/.
The Ubuntu UK Podcast

Produced by members of the UK’s Ubuntu LoCo team, this bi-weekly online
audio broadcast (or “podcast”) features lively discussion about Ubuntu, and
oen includes interviews with Ubuntu community members who work to
improve Ubuntu. Episodes are available at http://podcast.ubuntu-uk.org/.

A podcast is a radio-style broadcast available as
an audio ﬁle for download to computers and
portable media players.

     .

OMG! Ubuntu!

OMG! Ubuntu! is a weblog that aims to inform the Ubuntu community
about Ubuntu news, events, announcements, and updates in a timely fashion. It also allows Ubuntu users to discuss ways they can promote or share
Ubuntu. You can read this blog or subscribe to it at http://www.omgubuntu.
co.uk/.
Contributing
Contributing to Ubuntu

As we mentioned earlier in this chapter, Ubuntu is a community-maintained
operating system. You can help make Ubuntu beer in a number of ways.
e community consists of thousands of individuals and teams. If you
would like to contribute to Ubuntu, please visit https://wiki.ubuntu.com/
ContributeToUbuntu.
You can also participate in the Ubuntu community by contributing to
this manual. You might choose to write new content for it, edit its chapters
so they are easier for new Ubuntu users to understand and use, or translate it in your own language. You may also provide the screenshots found
throughout the manual. To get involved in the Ubuntu Manual Project, visit
http://ubuntu-manual.org/getinvolved.
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Creative Commons Attribution–ShareAlike 3.0 Legal Code
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. Deﬁnitions
(a) “Adaptation” means a work based upon the Work, or upon the Work
and other pre-existing works, such as a translation, adaptation,
derivative work, arrangement of music or other alterations of a literary or artistic work, or phonogram or performance and includes
cinematographic adaptations or any other form in which the Work
may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work that constitutes
a Collection will not be considered an Adaptation for the purpose of
this License. For the avoidance of doubt, where the Work is a musical
work, performance or phonogram, the synchronization of the Work in
timed-relation with a moving image (“synching”) will be considered
an Adaptation for the purpose of this License.
(b) “Collection” means a collection of literary or artistic works, such
as encyclopedias and anthologies, or performances, phonograms
or broadcasts, or other works or subject maer other than works
listed in Section () below, which, by reason of the selection and
arrangement of their contents, constitute intellectual creations, in
which the Work is included in its entirety in unmodiﬁed form along
with one or more other contributions, each constituting separate and
independent works in themselves, which together are assembled into
a collective whole. A work that constitutes a Collection will not be
considered an Adaptation (as deﬁned below) for the purposes of this
License.
(c) “Creative Commons Compatible License” means a license that is
listed at http://creativecommons.org/compatiblelicenses that has been
approved by Creative Commons as being essentially equivalent to this
License, including, at a minimum, because that license: (i) contains
terms that have the same purpose, meaning and eﬀect as the License
Elements of this License; and, (ii) explicitly permits the relicensing
of adaptations of works made available under that license under this
License or a Creative Commons jurisdiction license with the same
License Elements as this License.
(d) “Distribute” means to make available to the public the original and
copies of the Work or Adaptation, as appropriate, through sale or
other transfer of ownership.
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(e) “License Elements” means the following high-level license aributes
as selected by Licensor and indicated in the title of this License: Aribution, ShareAlike.
() “Licensor” means the individual, individuals, entity or entities that
oﬀer(s) the Work under the terms of this License.
(g) “Original Author” means, in the case of a literary or artistic work, the
individual, individuals, entity or entities who created the Work or if
no individual or entity can be identiﬁed, the publisher; and in addition
(i) in the case of a performance the actors, singers, musicians, dancers,
and other persons who act, sing, deliver, declaim, play in, interpret or
otherwise perform literary or artistic works or expressions of folklore;
(ii) in the case of a phonogram the producer being the person or legal
entity who ﬁrst ﬁxes the sounds of a performance or other sounds;
and, (iii) in the case of broadcasts, the organization that transmits the
broadcast.
(h) “Work” means the literary and/or artistic work oﬀered under the
terms of this License including without limitation any production
in the literary, scientiﬁc and artistic domain, whatever may be the
mode or form of its expression including digital form, such as a book,
pamphlet and other writing; a lecture, address, sermon or other work
of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition
with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography;
a work of drawing, painting, architecture, sculpture, engraving or
lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art;
an illustration, map, plan, sketch or three-dimensional work relative
to geography, topography, architecture or science; a performance; a
broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or
circus performer to the extent it is not otherwise considered a literary
or artistic work.
(i) “You” means an individual or entity exercising rights under this License who has not previously violated the terms of this License with
respect to the Work, or who has received express permission from
the Licensor to exercise rights under this License despite a previous
violation.
(j) “Publicly Perform” means to perform public recitations of the Work
and to communicate to the public those public recitations, by any
means or process, including by wire or wireless means or public
digital performances; to make available to the public Works in such a
way that members of the public may access these Works from a place
and at a place individually chosen by them; to perform the Work to
the public by any means or process and the communication to the
public of the performances of the Work, including by public digital
performance; to broadcast and rebroadcast the Work by any means
including signs, sounds or images.
(k) “Reproduce” means to make copies of the Work by any means including without limitation by sound or visual recordings and the right
of ﬁxation and reproducing ﬁxations of the Work, including storage
of a protected performance or phonogram in digital form or other
electronic medium.

 

. Fair Dealing Rights. Nothing in this License is intended to reduce, limit,
or restrict any uses free from copyright or rights arising from limitations
or exceptions that are provided for in connection with the copyright
protection under copyright law or other applicable laws.
. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the
rights in the Work as stated below:
(a) to Reproduce the Work, to incorporate the Work into one or more
Collections, and to Reproduce the Work as incorporated in the Collections;
(b) to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable
steps to clearly label, demarcate or otherwise identify that changes
were made to the original Work. For example, a translation could be
marked “e original work was translated from English to Spanish,”
or a modiﬁcation could indicate “e original work has been modiﬁed.”;
(c) to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
(d) to Distribute and Publicly Perform Adaptations.
(e) For the avoidance of doubt:
i. Non-waivable Compulsory License Schemes. In those jurisdictions
in which the right to collect royalties through any statutory or
compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise
by You of the rights granted under this License;
ii. Waivable Compulsory License Schemes. In those jurisdictions
in which the right to collect royalties through any statutory or
compulsory licensing scheme can be waived, the Licensor waives
the exclusive right to collect such royalties for any exercise by You
of the rights granted under this License; and,
iii. Voluntary License Schemes. e Licensor waives the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary
licensing schemes, via that society, from any exercise by You of the
rights granted under this License.
e above rights may be exercised in all media and formats whether
now known or hereaer devised. e above rights include the right to
make such modiﬁcations as are technically necessary to exercise the
rights in other media and formats. Subject to Section (), all rights
not expressly granted by Licensor are hereby reserved.
. Restrictions. e license granted in Section  above is expressly made
subject to and limited by the following restrictions:
(a) You may Distribute or Publicly Perform the Work only under the
terms of this License. You must include a copy of, or the Uniform
Resource Identiﬁer (URI) for, this License with every copy of the Work
You Distribute or Publicly Perform. You may not oﬀer or impose
any terms on the Work that restrict the terms of this License or the
ability of the recipient of the Work to exercise the rights granted to
that recipient under the terms of the License. You may not sublicense
the Work. You must keep intact all notices that refer to this License
and to the disclaimer of warranties with every copy of the Work
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You Distribute or Publicly Perform. When You Distribute or Publicly
Perform the Work, You may not impose any eﬀective technological
measures on the Work that restrict the ability of a recipient of the
Work from You to exercise the rights granted to that recipient under
the terms of the License. is Section (a) applies to the Work as
incorporated in a Collection, but this does not require the Collection
apart from the Work itself to be made subject to the terms of this
License. If You create a Collection, upon notice from any Licensor You
must, to the extent practicable, remove from the Collection any credit
as required by Section (c), as requested. If You create an Adaptation,
upon notice from any Licensor You must, to the extent practicable,
remove from the Adaptation any credit as required by Section (c), as
requested.
(b) You may Distribute or Publicly Perform an Adaptation only under the
terms of: (i) this License; (ii) a later version of this License with the
same License Elements as this License; (iii) a Creative Commons jurisdiction license (either this or a later license version) that contains the
same License Elements as this License (e.g., Aribution-ShareAlike
. US)); (iv) a Creative Commons Compatible License. If you license
the Adaptation under one of the licenses mentioned in (iv), you must
comply with the terms of that license. If you license the Adaptation
under the terms of any of the licenses mentioned in (i), (ii) or (iii) (the
“Applicable License”), you must comply with the terms of the Applicable License generally and the following provisions: (I) You must
include a copy of, or the URI for, the Applicable License with every
copy of each Adaptation You Distribute or Publicly Perform; (II) You
may not oﬀer or impose any terms on the Adaptation that restrict
the terms of the Applicable License or the ability of the recipient of
the Adaptation to exercise the rights granted to that recipient under the terms of the Applicable License; (III) You must keep intact all
notices that refer to the Applicable License and to the disclaimer of
warranties with every copy of the Work as included in the Adaptation You Distribute or Publicly Perform; (IV) when You Distribute or
Publicly Perform the Adaptation, You may not impose any eﬀective
technological measures on the Adaptation that restrict the ability of a
recipient of the Adaptation from You to exercise the rights granted to
that recipient under the terms of the Applicable License. is Section
(b) applies to the Adaptation as incorporated in a Collection, but this
does not require the Collection apart from the Adaptation itself to be
made subject to the terms of the Applicable License.
(c) If You Distribute, or Publicly Perform the Work or any Adaptations
or Collections, You must, unless a request has been made pursuant
to Section (a), keep intact all copyright notices for the Work and
provide, reasonable to the medium or means You are utilizing: (i) the
name of the Original Author (or pseudonym, if applicable) if supplied,
and/or if the Original Author and/or Licensor designate another party
or parties (e.g., a sponsor institute, publishing entity, journal) for aribution (“Aribution Parties”) in Licensor’s copyright notice, terms of
service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the extent reasonably
practicable, the URI, if any, that Licensor speciﬁes to be associated
with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and (iv) , consistent with
Ssection (b), in the case of an Adaptation, a credit identifying the

 

use of the Work in the Adaptation (e.g., “French translation of the
Work by Original Author,” or “Screenplay based on original Work
by Original Author”). e credit required by this Section (c) may be
implemented in any reasonable manner; provided, however, that in
the case of a Adaptation or Collection, at a minimum such credit will
appear, if a credit for all contributing authors of the Adaptation or
Collection appears, then as part of these credits and in a manner at
least as prominent as the credits for the other contributing authors.
For the avoidance of doubt, You may only use the credit required by
this Section for the purpose of aribution in the manner set out above
and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship
or endorsement by the Original Author, Licensor and/or Aribution
Parties, as appropriate, of You or Your use of the Work, without the
separate, express prior wrien permission of the Original Author,
Licensor and/or Aribution Parties.
(d) Except as otherwise agreed in writing by the Licensor or as may be
otherwise permied by applicable law, if You Reproduce, Distribute
or Publicly Perform the Work either by itself or as part of any Adaptations or Collections, You must not distort, mutilate, modify or take
other derogatory action in relation to the Work which would be prejudicial to the Original Author’s honor or reputation. Licensor agrees
that in those jurisdictions (e.g. Japan), in which any exercise of the
right granted in Section (b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modiﬁcation
or other derogatory action prejudicial to the Original Author’s honor
and reputation, the Licensor will waive or not assert, as appropriate,
this Section, to the fullest extent permied by the applicable national
law, to enable You to reasonably exercise Your right under Section
(b) of this License (right to make Adaptations) but not otherwise.
. Representations, Warranties and Disclaimer
         ,
        
       , , 
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  , ,    
, ,        
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 .       
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. Limitation on Liability.       
 ,            
   , , ,  
           
,           
.
. Termination
(a) is License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals
or entities who have received Adaptations or Collections from You
under this License, however, will not have their licenses terminated
provided such individuals or entities remain in full compliance with
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those licenses. Sections , , , , , and  will survive any termination
of this License.
(b) Subject to the above terms and conditions, the license granted here is
perpetual (for the duration of the applicable copyright in the Work).
Notwithstanding the above, Licensor reserves the right to release
the Work under diﬀerent license terms or to stop distributing the
Work at any time; provided, however that any such election will not
serve to withdraw this License (or any other license that has been, or
is required to be, granted under the terms of this License), and this
License will continue in full force and eﬀect unless terminated as
stated above.
. Miscellaneous
(a) Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor oﬀers to the recipient a license to the Work on the
same terms and conditions as the license granted to You under this
License.
(b) Each time You Distribute or Publicly Perform an Adaptation, Licensor
oﬀers to the recipient a license to the original Work on the same
terms and conditions as the license granted to You under this License.
(c) If any provision of this License is invalid or unenforceable under
applicable law, it shall not aﬀect the validity or enforceability of the
remainder of the terms of this License, and without further action
by the parties to this agreement, such provision shall be reformed
to the minimum extent necessary to make such provision valid and
enforceable.
(d) No term or provision of this License shall be deemed waived and no
breach consented to unless such waiver or consent shall be in writing
and signed by the party to be charged with such waiver or consent.
(e) is License constitutes the entire agreement between the parties
with respect to the Work licensed here. ere are no understandings,
agreements or representations with respect to the Work not speciﬁed
here. Licensor shall not be bound by any additional provisions that
may appear in any communication from You. is License may not be
modiﬁed without the mutual wrien agreement of the Licensor and
You.
() e rights granted under, and the subject maer referenced, in this
License were draed utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on
September , ), the Rome Convention of , the WIPO Copyright Treaty of , the WIPO Performances and Phonograms Treaty
of  and the Universal Copyright Convention (as revised on July
, ). ese rights and subject maer take eﬀect in the relevant
jurisdiction in which the License terms are sought to be enforced
according to the corresponding provisions of the implementation of
those treaty provisions in the applicable national law. If the standard
suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are
deemed to be included in the License; this License is not intended to
restrict the license of any rights under applicable law.

 

Creative Commons Notice

Creative Commons is not a party to this License, and makes no warranty
whatsoever in connection with the Work. Creative Commons will not be
liable to You or any party on any legal theory for any damages whatsoever,
including without limitation any general, special, incidental or consequential damages arising in connection to this license. Notwithstanding the
foregoing two () sentences, if Creative Commons has expressly identiﬁed
itself as the Licensor hereunder, it shall have all rights and obligations of
Licensor.
Except for the limited purpose of indicating to the public that the Work
is licensed under the CCPL, Creative Commons does not authorize the use
by either party of the trademark “Creative Commons” or any related trademark or logo of Creative Commons without the prior wrien consent of
Creative Commons. Any permied use will be in compliance with Creative
Commons’ then-current trademark usage guidelines, as may be published
on its website or otherwise made available upon request from time to time.
For the avoidance of doubt, this trademark restriction does not form part of
the License.
Creative Commons may be contacted at http://creativecommons.org/.

Glossary
Canonical Canonical, the ﬁnancial backer of Ubuntu, provides support for
the core Ubuntu system. It has over  paid staﬀ members worldwide
who ensure that the foundation of the operating system is stable, as well
as checking all the work submied by volunteer contributors. To learn
more about Canonical, go to http://www.canonical.com.
  or command-line interface is another name for the terminal.
cursor e (usually) blinking square or vertical line used to show you
where text will appear when you start typing. You can move it around
with the arrow keys on your keyboard prompt in a terminal or other
text-input application.
desktop environment A generic term to describe a  interface for humans
to interact with computers. ere are many desktop environments such
as , ,  and  just to name a few.
  stands for Dynamic Host Conﬁguration Protocol, it is used by a
 server to assign computers on a network an  address automatically.
dialup connection A dialup connection is when your computer uses a modem to connect to an  through your telephone line.
distribution A distribution is a collection of soware that is already compiled and conﬁgured ready to be installed. Ubuntu is an example of a
distribution.
dual-booting dual-booting is the process of being able to choose one of two
diﬀerent operating systems currently installed on a computer from the
boot menu. Once selected your computer will then boot into whichever
operating system you chose at the boot menu. Dual booting is oen used
generically, and may refer to booting among more than two operating
systems.
encryption Encryption is a security measure, it prevents others from accessing and viewing the contents of your ﬁles and/or hard drives, the ﬁles
must ﬁrst be decrypted with your password.
Ethernet port An Ethernet port is what an Ethernet cable is plugged into
when you are using a wired connection.
  (which once stood for  Network Object Model Environment) is the default desktop environment used in Ubuntu.
 e  (which stands for Graphical User Interface) is a type of user interface that allows humans to interact with the computer using graphics
and images rather than just text.
  stands for Internet Service Provider, an  is a company that provides
you with your Internet connection.
kernel A kernel is the central portion of a Unix-based operating system,
responsible for running applications, processes, and providing security
for the core components.
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maximize When you maximize an application in Ubuntu it will ﬁll the
whole desktop, excluding the panels.
minimize When you minimize an open application, the window will no
longer be shown. If you click on a minimized application’s panel buon,
it will then be restored to its normal state and allow you to interact with
it.
output e output of a command is any text it displays on the next line
aer typing a command and pressing enter, e.g., if you type pwd into a
terminal and press Enter, the directory name it displays on the next line
is the output.
package Packages contain soware in a ready-to-install format. Most of
the time you can use the Soware Center instead of manually installing
packages. Packages have a .deb extension in Ubuntu.
parameter Parameters are special options that you can use with other
commands in the terminal to make that command behave diﬀerently, this
can make a lot of commands far more useful.
partition A partition is an area of allocated space on a hard drive where
you can put data.
partitioning partitioning is the process of creating a partition.
prompt e prompt displays some useful information about your computer,
it can be customized to display in diﬀerent colors as well as being able to
display the time, date and current directory as well as almost anything
else you like.
proprietary Soware made by companies that don’t release their source
code under an open source license.
router A router is a specially designed computer that using its soware and
hardware, routes information from the Internet to a network. It is also
sometimes called a gateway.
server A server is a computer that runs a specialized operating system and
provides services to computers that connect to it and make a request.
shell e terminal gives access to the shell, when you type a command into
the terminal and press enter the shell takes that command and performs
the relevant action.
Soware Center e Soware Center is where you can easily manage soware installation and removal as well as the ability to manage soware
installed via Personal Package Archives.
terminal e terminal is Ubuntu’s text-based interface, it is a method of
controlling the operating system using only commands entered via the
keyboard, the other method if using your Ubuntu computer is to use a
 such as Unity.
USB Universal Serial Bus is a standard interface speciﬁcation for connecting peripheral hardware devices to computers. USB devices range from
external hard drives to scanners and printers.
wired connection A wired connection is when your computer is physically
connected to a router or Ethernet port with a cable, this is the most
method of connecting to the Internet and local network for desktop
computers.



wireless connection A network connection that uses a wireless signal to
communicate with either a router, access point, or computer.
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LibreOﬃce, 
Linux, –
Linux distributions, –
Live , see Ubuntu Live 
locking the screen, 
logging out, 
login options, 
Mac  , see MacBook
MacBook
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